Doomsday engine a novější OpenGL

Vojtěch Hutla

Doomsday engine a novější OpenGL
« kdy: 12. 04. 2014, 18:57:04 »
Zdravím,
rád bych zkusil Doomsday engine, ale podle chybové hlášky mám starou verzi OpenGL.

Kód: [Vybrat]
OpenGL implementation is too old!
Driver version: 1.4 Mesa 8.0.5
The minimum supported version is 2.0

Chtěl bych se zeptat, jakým způsobem mám OpenGL aktualizovat? Používám Crunchbang Linux 11. Děkuji za rady.
« Poslední změna: 13. 04. 2014, 23:12:28 od Petr Krčmář »


anonym

Re:Doomsday engine vyžaduje novější verzi OpenGL - jak postupovat?
« Odpověď #1 kdy: 12. 04. 2014, 19:53:18 »
jakou mas grafickou kartu?

mesa 8 by mela umet az ogl 3.0

Vojtěch Hutla

Re:Doomsday engine vyžaduje novější verzi OpenGL - jak postupovat?
« Odpověď #2 kdy: 12. 04. 2014, 20:14:22 »
Nejsem si jistý, jedná se o Netbook s integrovanou kartou. Přidávám výstup lspci.

Kód: [Vybrat]
vojtech@Netbook:~$ lspci -vnnk | grep -A 15 -i vga
00:02.0 VGA compatible controller [0300]: Intel Corporation Mobile 945GSE Express Integrated Graphics Controller [8086:27ae] (rev 03) (prog-if 00 [VGA controller])
Subsystem: Acer Incorporated [ALI] Device [1025:022f]
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at 98280000 (32-bit, non-prefetchable) [size=512K]
I/O ports at 60f0 [size=8]
Memory at 80000000 (32-bit, prefetchable) [size=256M]
Memory at 98300000 (32-bit, non-prefetchable) [size=256K]
Expansion ROM at <unassigned> [disabled]
Capabilities: <access denied>
Kernel driver in use: i915

00:02.1 Display controller [0380]: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller [8086:27a6] (rev 03)
Subsystem: Acer Incorporated [ALI] Device [1025:022f]
Flags: bus master, fast devsel, latency 0
Memory at 98200000 (32-bit, non-prefetchable) [size=512K]
Capabilities: <access denied>

Re:Doomsday engine vyžaduje novější verzi OpenGL - jak postupovat?
« Odpověď #3 kdy: 12. 04. 2014, 20:34:49 »
zkusil bych novejsi Mesa, pripadne kernel. Jelikoz je Crunchbang Linux na Debian stable (wheezy), zkusil bych pridat repozitar z Debian testing (jessie), pripadne zapinovat a nainstalovat z toho Mesu + kernel

anonym

Re:Doomsday engine vyžaduje novější verzi OpenGL - jak postupovat?
« Odpověď #4 kdy: 12. 04. 2014, 20:38:45 »
3D-wise, GMA 950 supports up to 4pixels per clock rendering, Microsoft DirectX 9.0 hardware acceleration & Vertex shader 3.0 and OpenGL 1.4 with ARB extensions.

neboli smula, na tomhle HW to proste nepujde


sidenote: pri pouziti llvmpipe by si moh ziskat oGL 2.0 (nebo dokonce 3.0 u nejnovejsi verze mesa), ale rychlost bude nepouzitelna


Pavouk106

  • *****
  • 2 354
    • Zobrazit profil
    • Můj blog
    • E-mail
Re:Doomsday engine vyžaduje novější verzi OpenGL - jak postupovat?
« Odpověď #5 kdy: 12. 04. 2014, 20:58:31 »
3D-wise, GMA 950 supports up to 4pixels per clock rendering, Microsoft DirectX 9.0 hardware acceleration & Vertex shader 3.0 and OpenGL 1.4 with ARB extensions.

neboli smula, na tomhle HW to proste nepujde


sidenote: pri pouziti llvmpipe by si moh ziskat oGL 2.0 (nebo dokonce 3.0 u nejnovejsi verze mesa), ale rychlost bude nepouzitelna
Mám GMA3150, která podle wiki taky končí na 1.4, ale funguju na 2.0. Protože 1.4 platí (u mě) pro MS WIndows, ale v Linuxu umí i 2.0. Stačí k tomu nainstalovat driconf a tam to zapnout. Možná to funguje i na 950. Za zkoušku nebo alespoň Google to určitě stojí.

OpenGL nejde upgradovat jako takový. OpenGL musí podporovat karta. Takže když něco chce OpenGL3.0, tak potřebuješ kartu, která to podporuje a pak teprve řešit ovladače...

Jimm

Re:Doomsday engine vyžaduje novější verzi OpenGL - jak postupovat?
« Odpověď #6 kdy: 12. 04. 2014, 21:39:08 »
Já nevím, co na tom Doomu všichni vidíte, kam se to hrabe na Wolfenstein3d. :)

Vojtěch Hutla

Re:Doomsday engine vyžaduje novější verzi OpenGL - jak postupovat?
« Odpověď #7 kdy: 13. 04. 2014, 09:13:57 »
Citace
Já nevím, co na tom Doomu všichni vidíte, kam se to hrabe na Wolfenstein3d.
Připouštím, že kosit nácky může být zábavné, ale Doom má něco do sebe, mj. je to první hra, kterou jsem hrál ;)

Nevím, nerad bych zasahoval do systému, díky stabilitě jsem si ho vybral. Tak musím počkat, než si koupím počítač nový. Do té doby se pokusím najít původního Dooma a rozchodit ho na DOSBoxu. Díky za všechny odpovědi.