Debian – odhlášení po spuštění aplikace

ZAJDAN

  • *****
  • 2 060
    • Zobrazit profil
    • E-mail
Debian – odhlášení po spuštění aplikace
« kdy: 30. 04. 2013, 10:20:45 »
Ahojte...
nevím, zda se 4letí dcerce povedlo něco záškodného, ale z ničeho nic pozoruju podivné chování systému DEBIAN 6 x64
spustím browser Opera a během sekundy se sytím odhlásí na úrovň přihlašovací obrazovky
spustím virtual box a stane se to samé a takto to postihlo několik aplikací v systému.....
dřív něž reinstaluju bych se rád zeptal, zda nemáte někdo tušení co by se mohlo dít

díky
« Poslední změna: 30. 04. 2013, 11:02:00 od Roman Bořánek »
Vesele, vesele do továrny dělník běží...vesele, vesele do továrny jde. Vesele se usmívá když mu soustruh zazpívá...vesele, vesele do továrny jde. Vesele si poskočí když se soustruh roztočí ...vesele, vesele do továrny jde.


2X4B-523P

Re:Debian – odhlášení po spuštění aplikace
« Odpověď #1 kdy: 30. 04. 2013, 11:41:23 »
dělá to třeba i přeplněný disk, kdy si už programy nemohou nic zapsat třeba do /tmp

Re:Debian – odhlášení po spuštění aplikace
« Odpověď #2 kdy: 30. 04. 2013, 11:47:51 »
Tipl bych si, ze z nejakyho duvodu spadnou a restartuji Xka, neco podobnyho (ale z duvodu bugu v graf ovladacich) se mi na jednom starsim notasu stavalo - ale vicemene nahodne.
Pokud je me tuseni spravne, chce to zjistit duvod padu -> prostudovat logy

Ego

Re:Debian – odhlášení po spuštění aplikace
« Odpověď #3 kdy: 30. 04. 2013, 11:49:21 »
S plnym diskem skvely tip :).  Pokud jde o ty logy, uzitecny je vypis programu dmesg a soubory /home/*/.xsession-errors.  Pripadne i /var/log/Xorg.0.log, protoze to vypada na pad Xserveru.  Kompletni reinstalaci nejspis bude mozne se vyhnout, pokud ovsem dcerka nepracovala jako root...

Re:Debian – odhlášení po spuštění aplikace
« Odpověď #4 kdy: 30. 04. 2013, 12:03:25 »
dělá to třeba i přeplněný disk, kdy si už programy nemohou nic zapsat třeba do /tmp

JJ, jak správně píše kolaga Kryton.
Co třeba vypisuje příkaz
Kód: [Vybrat]
df -h?


ZAJDAN

  • *****
  • 2 060
    • Zobrazit profil
    • E-mail
Re:Debian – odhlášení po spuštění aplikace
« Odpověď #5 kdy: 30. 04. 2013, 12:33:58 »
moc díky za náměty
hned dnes jak přijdu domů, prověřím zde zmiňované
Vesele, vesele do továrny dělník běží...vesele, vesele do továrny jde. Vesele se usmívá když mu soustruh zazpívá...vesele, vesele do továrny jde. Vesele si poskočí když se soustruh roztočí ...vesele, vesele do továrny jde.

ZAJDAN

  • *****
  • 2 060
    • Zobrazit profil
    • E-mail
Re:Debian – odhlášení po spuštění aplikace
« Odpověď #6 kdy: 30. 04. 2013, 16:23:47 »
df -h
Souborový systém  Velikost Užito Volno Uži% Připojeno do
/dev/sda1              46G  5,6G   38G  13% /
tmpfs                 4,0G     0  4,0G   0% /lib/init/rw
udev                  4,0G  228K  4,0G   1% /dev
tmpfs                 4,0G  164K  4,0G   1% /dev/shm
/dev/sda7             340G  150G  173G  47% /home
/dev/sda6              56G   29G   24G  55% /mnt/virtuals

takze nedostatek mista vyloucen
zacnu pozorovat logy
Vesele, vesele do továrny dělník běží...vesele, vesele do továrny jde. Vesele se usmívá když mu soustruh zazpívá...vesele, vesele do továrny jde. Vesele si poskočí když se soustruh roztočí ...vesele, vesele do továrny jde.

ZAJDAN

  • *****
  • 2 060
    • Zobrazit profil
    • E-mail
Re:Debian – odhlášení po spuštění aplikace
« Odpověď #7 kdy: 30. 04. 2013, 16:35:05 »
takže hned po tom co jsem spustil virtualbox a system mne odhlásil jsem po novém přihlášení udělal výstup z dmesg:
Kód: [Vybrat]
[    2.203425] usbcore: registered new interface driver usbhid
[68578.181755] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)
[74713.849126] scsi 9:0:0:0: Direct-Access     Generic  Flash Disk       8.07 PQ: 0 ANSI: 2
[74713.850257] sd 9:0:0:0: Attached scsi generic sg6 type 0
[74713.860125] sd 9:0:0:0: [sdf] 8002560 512-byte logical blocks: (4.09 GB/3.81 GiB)
[74713.860845] sd 9:0:0:0: [sdf] Write Protect is off
[74713.860851] sd 9:0:0:0: [sdf] Mode Sense: 03 00 00 00
[74713.860856] sd 9:0:0:0: [sdf] Assuming drive cache: write through
[74713.865951] sd 9:0:0:0: [sdf] Assuming drive cache: write through
[74713.865963]  sdf: sdf1
[74714.011569] sd 9:0:0:0: [sdf] Assuming drive cache: write through
[74714.011578] sd 9:0:0:0: [sdf] Attached SCSI removable disk
[74714.416411] FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
[74727.577329] nautilus: sending ioctl 2285 to a partition!
[74736.119922] usb 1-6: USB disconnect, address 5
[132376.087602] CPU0 attaching NULL sched-domain.
[132376.087615] CPU1 attaching NULL sched-domain.
[132376.112681] CPU0 attaching sched-domain:
[132376.112689]  domain 0: span 0-1 level MC
[132376.112694]   groups: group ffff880008c0fbf0 cpus 0 group ffff880008c8fbf0 cpus 1
[132376.112709] CPU1 attaching sched-domain:
[132376.112714]  domain 0: span 0-1 level MC
[132376.112718]   groups: group ffff880008c8fbf0 cpus 1 group ffff880008c0fbf0 cpus 0
[132376.460549] wlan0: deauthenticating from 00:20:a6:5b:af:b2 by local choice (reason=3)
[132377.256358] PM: Marking nosave pages: 000000000009f000 - 0000000000100000
[132377.256362] PM: Marking nosave pages: 00000000c7de0000 - 0000000100000000
[132377.257225] PM: Marking nosave pages: 0000000020000000 - 0000000024000000
[132377.257420] PM: Basic memory bitmaps created
[132377.257422] PM: Syncing filesystems ... done.
[132377.304528] Freezing user space processes ... (elapsed 0.00 seconds) done.
[132377.305203] Freezing remaining freezable tasks ... (elapsed 0.00 seconds) done.
[132377.305243] PM: Preallocating image memory... done (allocated 1938900 pages)
[132388.988692] PM: Allocated 7755600 kbytes in 11.68 seconds (664.00 MB/s)
[132388.988695] Suspending console(s) (use no_console_suspend to debug)
[132389.240016] sd 2:0:0:0: [sda] Synchronizing SCSI cache
[132389.240556] ACPI handle has no context!
[132389.240615] ACPI handle has no context!
[132389.364098] HDA Intel 0000:00:14.2: PCI INT A disabled
[132389.380127] pata_atiixp 0000:00:14.1: PCI INT A disabled
[132389.476219] ahci 0000:00:11.0: PCI INT A disabled
[132389.476707] ACPI: Preparing to enter system sleep state S4
[132389.476855] PM: Saving platform NVS memory
[132389.477666] Disabling non-boot CPUs ...
[132389.477681] CPU0 attaching NULL sched-domain.
[132389.477683] CPU1 attaching NULL sched-domain.
[132389.524025] CPU0 attaching NULL sched-domain.
[132389.628015] CPU 1 is now offline
[132389.628016] SMP alternatives: switching to UP code
[132389.631163] PM: Creating hibernation image:
[132389.632008] PM: Need to copy 72098 pages
[132389.632008] PM: Normal pages needed: 72098 + 1024, available pages: 2007873
[132389.632008] PM: Restoring platform NVS memory
[132389.632008] PCI-DMA: Resuming GART IOMMU
[132389.632008] PCI-DMA: Restoring GART aperture settings
[132389.632008] Enabling non-boot CPUs ...
[132389.632008] SMP alternatives: switching to SMP code
[132389.633938] Booting processor 1 APIC 0x1 ip 0x6000
[132389.631015] Initializing CPU#1
[132389.631015] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[132389.631015] CPU: L2 Cache: 1024K (64 bytes/line)
[132389.631015] CPU 1/0x1 -> Node 0
[132389.631015] CPU: Physical Processor ID: 0
[132389.631015] CPU: Processor Core ID: 1
[132389.724063] CPU1: AMD Athlon(tm) 64 X2 Dual Core Processor 6400+ stepping 03
[132389.724093] CPU0 attaching NULL sched-domain.
[132389.752028] CPU0 attaching sched-domain:
[132389.752030]  domain 0: span 0-1 level MC
[132389.752031]   groups: group ffff880008c0fbf0 cpus 0 group ffff880008c8fbf0 cpus 1
[132389.752036] CPU1 attaching sched-domain:
[132389.752037]  domain 0: span 0-1 level MC
[132389.752038]   groups: group ffff880008c8fbf0 cpus 1 group ffff880008c0fbf0 cpus 0
[132389.752270] CPU1 is up
[132389.752503] ACPI: Waking up from system sleep state S4
[132389.753218] ahci 0000:00:11.0: restoring config space at offset 0x1 (was 0x2300003, writing 0x2300007)
[132389.753436] pata_atiixp 0000:00:14.1: restoring config space at offset 0x1 (was 0x2300001, writing 0x2300005)
[132389.753452] HDA Intel 0000:00:14.2: restoring config space at offset 0xf (was 0x107, writing 0x7)
[132389.753472] HDA Intel 0000:00:14.2: restoring config space at offset 0x1 (was 0x4100006, writing 0x4100002)
[132389.753576] nvidia 0000:01:00.0: restoring config space at offset 0x3 (was 0x800001, writing 0x800000)
[132389.753713] p54pci 0000:03:06.0: restoring config space at offset 0x3 (was 0x2001, writing 0x2010)
[132389.753720] p54pci 0000:03:06.0: restoring config space at offset 0x1 (was 0x2980006, writing 0x2980016)
[132389.792513] ahci 0000:00:11.0: PCI INT A -> GSI 22 (level, low) -> IRQ 22
[132389.851991] usb usb3: root hub lost power or was reset
[132389.911990] usb usb4: root hub lost power or was reset
[132389.912017] usb usb1: root hub lost power or was reset
[132389.971990] usb usb5: root hub lost power or was reset
[132390.032011] usb usb6: root hub lost power or was reset
[132390.032021] usb usb2: root hub lost power or was reset
[132390.032073] pata_atiixp 0000:00:14.1: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[132390.032085] HDA Intel 0000:00:14.2: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[132390.112034] ata6: SATA link down (SStatus 0 SControl 300)
[132390.112062] ata8: SATA link down (SStatus 0 SControl 300)
[132390.112089] ata4: SATA link down (SStatus 0 SControl 300)
[132390.112134] ata7: SATA link down (SStatus 0 SControl 300)
[132390.112159] ata5: SATA link down (SStatus 0 SControl 300)
[132390.192110] usb usb7: root hub lost power or was reset
[132390.197359] ata1.00: ACPI cmd ef/03:0c:00:00:00:a0 (SET FEATURES) filtered out
[132390.197362] ata1.00: ACPI cmd ef/03:44:00:00:00:a0 (SET FEATURES) filtered out
[132390.212928] ata1.00: configured for UDMA/66
[132390.276018] ata3: softreset failed (device not ready)
[132390.276021] ata3: applying SB600 PMP SRST workaround and retrying
[132390.440026] ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[132390.466309] ata3.00: configured for UDMA/133
[132391.204015] usb 2-4: reset high speed USB device using ehci_hcd and address 2
[132391.339956] sd 2:0:0:0: [sda] Starting disk
[132391.628013] usb 4-1: reset low speed USB device using ohci_hcd and address 2
[132391.941340] PM: Image restored successfully.
[132391.941341] Restarting tasks ... done.
[132391.942204] PM: Basic memory bitmaps freed
[132426.317317] r8169 0000:02:00.0: eth0: link down
[132426.320303] ADDRCONF(NETDEV_UP): eth0: link is not ready
[132426.727437] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[132428.420206] CPU0 attaching NULL sched-domain.
[132428.420217] CPU1 attaching NULL sched-domain.
[132428.448175] CPU0 attaching sched-domain:
[132428.448182]  domain 0: span 0-1 level MC
[132428.448188]   groups: group ffff880008c0fbf0 cpus 0 group ffff880008c8fbf0 cpus 1
[132428.448203] CPU1 attaching sched-domain:
[132428.448208]  domain 0: span 0-1 level MC
[132428.448213]   groups: group ffff880008c8fbf0 cpus 1 group ffff880008c0fbf0 cpus 0
[136172.388784] wlan0: direct probe to AP 00:20:a6:5b:af:b2 (try 1)
[136172.392581] wlan0: direct probe responded
[136172.392585] wlan0: authenticate with AP 00:20:a6:5b:af:b2 (try 1)
[136172.394557] wlan0: authenticated
[136172.394570] wlan0: associate with AP 00:20:a6:5b:af:b2 (try 1)
[136172.396810] wlan0: RX AssocResp from 00:20:a6:5b:af:b2 (capab=0x431 status=0 aid=1)
[136172.396812] wlan0: associated
[136172.397926] ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[136182.532010] wlan0: no IPv6 routers present
[140154.688034] usb 1-6: new high speed USB device using ehci_hcd and address 6
[140154.821125] usb 1-6: New USB device found, idVendor=04e8, idProduct=6860
[140154.821134] usb 1-6: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[140154.821140] usb 1-6: Product: GT-B5330
[140154.821145] usb 1-6: Manufacturer: samsung
[140154.821149] usb 1-6: SerialNumber: 4d00395c4d8e9f00
[140154.821367] usb 1-6: configuration #1 chosen from 1 choice
[140155.216539] cdc_acm 1-6:1.1: This device cannot do calls on its own. It is not a modem.
[140155.217088] cdc_acm 1-6:1.1: ttyACM0: USB ACM device
[140155.218152] cdc_acm 1-6:1.3: This device cannot do calls on its own. It is not a modem.
[140155.218442] cdc_acm 1-6:1.3: ttyACM1: USB ACM device
[140155.220418] usbcore: registered new interface driver cdc_acm
[140155.220426] cdc_acm: v0.26:USB Abstract Control Model driver for USB modems and ISDN adapters
[140159.393717] usb 1-6: USB disconnect, address 6
[140159.672547] usb 1-6: new high speed USB device using ehci_hcd and address 7
[140159.806137] usb 1-6: New USB device found, idVendor=04e8, idProduct=6860
[140159.806146] usb 1-6: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[140159.806152] usb 1-6: Product: GT-B5330
[140159.806157] usb 1-6: Manufacturer: samsung
[140159.806161] usb 1-6: SerialNumber: 4d00395c4d8e9f00
[140159.806385] usb 1-6: configuration #1 chosen from 1 choice
[140159.807981] cdc_acm 1-6:1.1: This device cannot do calls on its own. It is not a modem.
[140159.808211] cdc_acm 1-6:1.1: ttyACM0: USB ACM device
[140159.809559] cdc_acm 1-6:1.3: This device cannot do calls on its own. It is not a modem.
[140159.809793] cdc_acm 1-6:1.3: ttyACM1: USB ACM device
[140214.251918] usb 1-6: USB disconnect, address 7
[140214.524537] usb 1-6: new high speed USB device using ehci_hcd and address 8
[140214.656966] usb 1-6: New USB device found, idVendor=04e8, idProduct=6865
[140214.656975] usb 1-6: New USB device strings: Mfr=2, Product=3, SerialNumber=4
[140214.656980] usb 1-6: Product: GT-B5330
[140214.656984] usb 1-6: Manufacturer: samsung
[140214.656989] usb 1-6: SerialNumber: 4d00395c4d8e9f00
[140214.657211] usb 1-6: configuration #1 chosen from 1 choice
[140504.511128] usb 1-6: USB disconnect, address 8
[158313.980053] wlan0: deauthenticating from 00:20:a6:5b:af:b2 by local choice (reason=3)
[158323.733233] NVRM: GPU at 0000:01:00: GPU-4da6d2e6-62f2-3ab9-56e3-c04be4650f4f
[158351.188795] wlan0: direct probe to AP 00:20:a6:5b:af:b2 (try 1)
[158351.192767] wlan0: direct probe responded
[158351.192770] wlan0: authenticate with AP 00:20:a6:5b:af:b2 (try 1)
[158351.194508] wlan0: authenticated
[158351.194520] wlan0: associate with AP 00:20:a6:5b:af:b2 (try 1)
[158351.196916] wlan0: RX AssocResp from 00:20:a6:5b:af:b2 (capab=0x431 status=0 aid=1)
[158351.196917] wlan0: associated

cat /home/zajdan/.xsession-errors:
Kód: [Vybrat]
/etc/gdm3/Xsession: Beginning session setup...
GNOME_KEYRING_CONTROL=/tmp/keyring-JANjI7
SSH_AUTH_SOCK=/tmp/keyring-JANjI7/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-JANjI7
SSH_AUTH_SOCK=/tmp/keyring-JANjI7/ssh
GNOME_KEYRING_CONTROL=/tmp/keyring-JANjI7
SSH_AUTH_SOCK=/tmp/keyring-JANjI7/ssh
Varování správce oken: Chyba při čtení uloženého souboru sezení /home/zajdan/.config/metacity/sessions/10bc437ab52167bf27136733193231860200000179070024.ms: Nelze otevřít soubor "/home/zajdan/.config/metacity/sessions/10bc437ab52167bf27136733193231860200000179070024.ms": Adresář nebo soubor neexistuje
warning :  (cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:171) 
  couldn't find an appropriate visual, trying to get one without Stencil buffer
(it may cause some little deterioration in the rendering) ...
warning :  (cairo-dock-opengl.c:cairo_dock_initialize_opengl_backend:282) 
  GLX version too old (1.2).
Cairo-Dock needs at least GLX 1.3. Indirect rendering will be toggled on/off as a workaround.
Failed to play sound: File or data not found
Invalid borders specified for theme pixmap:
        /home/zajdan/.themes/Cillop-Midnite/gtk-2.0/null.png,
borders don't fit within the image

(polkit-gnome-authentication-agent-1:18002): GLib-GObject-WARNING **: cannot register existing type `_PolkitError'

(polkit-gnome-authentication-agent-1:18002): GLib-CRITICAL **: g_once_init_leave: assertion `initialization_value != 0' failed

 ============================================================================
Cairo-Dock version: 2.1.3-10-lucid
Compiled date:  Oct  9 2010 07:11:14
Running with OpenGL: 1
 ============================================================================


(gnome-panel:17977): Gdk-WARNING **: /scratch/build-area/gtk+2.0-2.20.1/gdk/x11/gdkdrawable-x11.c:952 drawable is not a pixmap or window
Initializing nautilus-gdu extension
OpenGL config summary :
 - bNonPowerOfTwoAvailable : 1
 - bPBufferAvailable : 1
 - direct rendering : 0
 - bTextureFromPixmapAvailable : 1
 - GLX version : 1.2
 - OpenGL version: 1.4 (2.1 Mesa 7.7.1)
 - OpenGL vendor: Mesa Project
 - OpenGL renderer: Software Rasterizer

** Message: <info>  No keyring secrets found for Auto LINGU/802-11-wireless-security; asking user.

warning :  (cairo-dock-opengl.c:_cairo_dock_create_pbuffer:331) 
  No suitable visual could be found for pbuffer
 this might affect the drawing of some applets which are inside a dock
activating pbuffer, usually buggy drivers will crash here ... ok, they are fine enough.
mode etendu : pDock->iMaxDockWidth : 26

** (nm-applet:17992): WARNING **: Invalid borders specified for theme pixmap:
        /home/zajdan/.themes/Cillop-Midnite/gtk-2.0/null.png,
borders don't fit within the image
pRenderAttr->iMemorySize : 48
cd_sysmonitor_get_cpu_data: assertion `fTimeElapsed > 0.1' failed
cairo_dock_replace_values_in_conf_file (/home/zajdan/.config/cairo-dock/current_theme/plug-ins/dnd2share/dnd2share.conf)
warning :  (cairo-dock-keyfile-utilities.c:cairo_dock_open_key_file:34) 
  Adresář nebo soubor neexistuje
warning :  (cairo-dock-keyfile-utilities.c:cairo_dock_open_key_file:34) 
  Adresář nebo soubor neexistuje
cairo_dock_replace_values_in_conf_file (/home/zajdan/.config/cairo-dock/current_theme/plug-ins/quick-browser/quick-browser.conf)
_cd_find_volume_name_from_drive_name: assertion `pDrive != NULL' failed
warning :  (applet-read-data.c:cd_weather_get_distant_data:363) 
  weather : file '/tmp/weather-cc.nmfwLV' doesn't exist or is empty (no connection ?)
warning :  (applet-read-data.c:cd_weather_get_distant_data:378) 
  weather : file '/tmp/weather-forecast.o49BXz' doesn't exist or is empty (no connection ?)
(null) -> -1;-1
separateur necessaire
cairo_dock_create_surface_from_image: assertion `rsvg_handle != NULL' failed
warning :  (applet-dbus.c:_cd_dbus_launch_third_party_applets_in_dir:126) 
  Chyba při otevírání adresáře "/usr/share/cairo-dock/plug-ins/Dbus/third-party": Adresář nebo soubor neexistuje
warning :  (applet-dbus.c:_cd_dbus_launch_third_party_applets_in_dir:126) 
  Chyba při otevírání adresáře "/home/zajdan/.config/cairo-dock/third-party": Adresář nebo soubor neexistuje
separateur necessaire
[18199:18221:0430/162703:ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[18199:18221:0430/162703:ERROR:object_proxy.cc(624)] Failed to get name owner. Got org.freedesktop.DBus.Error.NameHasNoOwner: Could not get owner of name 'org.chromium.Mtpd': no such name
[18199:18199:0430/162703:ERROR:object_proxy.cc(529)] Failed to call method: org.chromium.Mtpd.EnumerateStorages: object_path= /org/chromium/Mtpd: org.freedesktop.DBus.Error.ServiceUnknown: The name org.chromium.Mtpd was not provided by any .service files
Varování správce oken: Received a _NET_WM_MOVERESIZE message for 0x320006b (Účty Goo); these messages lack timestamps and therefore suck.
Varování správce oken: Received a _NET_WM_MOVERESIZE message for 0x320006b (Účty Goo); these messages lack timestamps and therefore suck.
Varování správce oken: Received a _NET_WM_MOVERESIZE message for 0x320006b (Účty Goo); these messages lack timestamps and therefore suck.
[18199:18199:0430/162708:ERROR:omnibox_view_gtk.cc(431)] Not implemented reached in virtual void OmniboxViewGtk::ApplyCaretVisibility()
 -> action !
cairo_dock_search_icon_s_path: assertion `cFileName != NULL' failed

Vesele, vesele do továrny dělník běží...vesele, vesele do továrny jde. Vesele se usmívá když mu soustruh zazpívá...vesele, vesele do továrny jde. Vesele si poskočí když se soustruh roztočí ...vesele, vesele do továrny jde.

Ego

Re:Debian – odhlášení po spuštění aplikace
« Odpověď #8 kdy: 30. 04. 2013, 18:11:00 »
takže hned po tom co jsem spustil virtualbox a system mne odhlásil jsem po novém přihlášení udělal výstup z dmesg:

bylo by lepší vysledovat, jestli (a co) do tohoto logu přibyde v okamžiku pádu.  Výpis dmesg ale vypadá v pořádku, v .xsession-errors taky nic nevidím, ale tady to mohlo být ovlivněné i tím novým přihlášením--pokud je při něm soubor přepsán (založen) znovu od začátku, nic tam najít nemůžeme.  Možná bude na první řádce informace, kdy X session začala (já ji tam mám, ale mám Debian testing).  Pak by pomohlo přihlásit se jen v konzoli (po stisku Ctrl-Alt-Fneco) nebo na jiného uživatele.  Dále bych se podíval na již zmíněný /var/log/Xorg.0.log.  Ten také může být přepsán při novém přihlášení, pak by tam mohl být Xorg.0.log.old z minulého běhu.  Skoukněte timestampy a obsah těch souborů, z toho rychle pochopíte, kde hledat.  Případně je někam uploadněte, ať je vidíme celé.

Kdyby došlo na reinstalaci--pokud vám není zatěžko ji provést--možná by stálo za to zkusit novější verzi Debianu, tj. Wheezy (dosavadní testing), která už je zcela stabilizovaná a 5. května má vyjít jako nová stable (možná s pár last moment opravami).  Nevím které graf. ovladače máte teď (ani už si nepamatuju jak to ve squeeze bylo), ale ve Wheezym už je standardně (v non-free) balík nvidia-glx, se kterým můžete mít skvělý oficiální ovladač přímo od NVidie, mně fungoval vždy výborně.  I tak s ním lze občas narazit na chyták, ale nemělo by přitom jít o nic, co mohla rozbít dcerka.

Re:Debian – odhlášení po spuštění aplikace
« Odpověď #9 kdy: 30. 04. 2013, 19:47:57 »
Neco podezreleho ve /val/log/messages? (tam je zaznamenano i snadno citelne datum a cas).
V mem zminovanem pripade tam naskocilo
Kód: [Vybrat]
May  1 15:42:07 old-notas gnome-session[2057]: Gdk-WARNING: gnome-session: Fatal IO error 11 (Resource temporarily unavailable) on X server :0.#012Nasledne to bud podivne vymrzlo (mys furt reagovala atp), nebo se X restartoval.
Duvodem bylo, ze kernel 3.1 se nemel rad s postarsi ATI Mobility Radeon X2300 :P. Novejsi kernel 3.4 uz tuto chybu neobsahuje.

Nevyznam se natolik, abych mohl vyvozovat nejake zavery, ale pripomenulo mi to tu situaci, tak sem si rikal, ze by nebylo od veci ji zminit ;)

monitor

Re:Debian – odhlášení po spuštění aplikace
« Odpověď #10 kdy: 30. 04. 2013, 21:54:13 »
Niekto iný mal podobné chyby v Debiane (Squeeze 6.0.7 )
http://forums.debian.net/viewtopic.php?f=30&t=101495
ale píše, že problémy začal mať 15.3.2013 - ale nie kvôli dcére, ale po update-e.

On vraj mal v ~/.config/autostart
programy, čo už boli odinštalované, no stále sa odtiaľ chceli spúšťať...
(čiže on mal problémy hneď po prihláseni, takže je to možno mierne iné)


Ešte, ja by som možno skúsil ten program XYZ spustiť takto - z grafického terminálu v Xoch:

strace XYZ > xyz.strace.log 2>&1 &

a keď to spadne, tak hádam ku koncu súboru by malo byť vidno, akú operáciu sa pokúšal robiť, a ktorá zlyhala (zrejme niečo s grafikou, keď to zhodí X-y...)

Inak, VirtualBox ma tiez svoje logy(v adresári ~/.VirtualBox ?), mozno by aj tie pomohli...
(inak, v tom VirtualBoxe, nema ten virtualny OS zapnute 3D? Skús vypnúť...)

Ďalšia vec: nejde náhodou o binárne NVidia drivery?

(aj keď, je to fakt divné, že to "predtým"  fungovalo OK...)

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Debian – odhlášení po spuštění aplikace
« Odpověď #11 kdy: 01. 05. 2013, 02:03:17 »
Co takle cvicne zalozit noveho usera a zkusit to pod nim?

noname

Re:Debian – odhlášení po spuštění aplikace
« Odpověď #12 kdy: 01. 05. 2013, 12:28:42 »
takže hned po tom co jsem spustil virtualbox a system mne odhlásil jsem po novém přihlášení udělal výstup z dmesg:

bylo by lepší vysledovat, jestli (a co) do tohoto logu přibyde v okamžiku pádu.  Výpis dmesg ale vypadá v pořádku, v .xsession-errors taky nic nevidím, ale tady to mohlo být ovlivněné i tím novým přihlášením--pokud je při něm soubor přepsán (založen) znovu od začátku, nic tam najít nemůžeme.  Možná bude na první řádce informace, kdy X session začala (já ji tam mám, ale mám Debian testing).  Pak by pomohlo přihlásit se jen v konzoli (po stisku Ctrl-Alt-Fneco) nebo na jiného uživatele.  Dále bych se podíval na již zmíněný /var/log/Xorg.0.log.  Ten také může být přepsán při novém přihlášení, pak by tam mohl být Xorg.0.log.old z minulého běhu.  Skoukněte timestampy a obsah těch souborů, z toho rychle pochopíte, kde hledat.  Případně je někam uploadněte, ať je vidíme celé.

Kdyby došlo na reinstalaci--pokud vám není zatěžko ji provést--možná by stálo za to zkusit novější verzi Debianu, tj. Wheezy (dosavadní testing), která už je zcela stabilizovaná a 5. května má vyjít jako nová stable (možná s pár last moment opravami).  Nevím které graf. ovladače máte teď (ani už si nepamatuju jak to ve squeeze bylo), ale ve Wheezym už je standardně (v non-free) balík nvidia-glx, se kterým můžete mít skvělý oficiální ovladač přímo od NVidie, mně fungoval vždy výborně.  I tak s ním lze občas narazit na chyták, ale nemělo by přitom jít o nic, co mohla rozbít dcerka.

.xsession_error je pro mě španělská vesnice, ale u výpisu dmesg si myslím (taky trochu španělská vesnice) že se jeho výpis nerestartoval, je zde zobrazena činnost VirtualBoxu. Vypadá, že byl při činnosti připojen a odpojen USB disk a podle toho, co jsem z logu vyčetl tipuji, že by se systém mohl snažit neúspěšně přejít do režimu spánku (narychlo jsem proletěl google, nemám bohužel čas). Ve zmíněném logu mě každopádně zaujaly následující řádky:

Kód: [Vybrat]
[    2.203425] usbcore: registered new interface driver usbhid
[68578.181755] warning: `VirtualBox' uses 32-bit capabilities (legacy support in use)
[74713.849126] scsi 9:0:0:0: Direct-Access     Generic  Flash Disk       8.07 PQ: 0 ANSI: 2
[74713.850257] sd 9:0:0:0: Attached scsi generic sg6 type 0
[74713.860125] sd 9:0:0:0: [sdf] 8002560 512-byte logical blocks: (4.09 GB/3.81 GiB)
[74713.860845] sd 9:0:0:0: [sdf] Write Protect is off

[74714.011578] sd 9:0:0:0: [sdf] Attached SCSI removable disk

[74736.119922] usb 1-6: USB disconnect, address 5

[132376.460549] wlan0: deauthenticating from 00:20:a6:5b:af:b2 by local choice (reason=3)

[132377.304528] Freezing user space processes ... (elapsed 0.00 seconds) done.

[132388.988695] Suspending console(s) (use no_console_suspend to debug)
[132389.240016] sd 2:0:0:0: [sda] Synchronizing SCSI cache
[132389.240556] ACPI handle has no context!
[132389.240615] ACPI handle has no context!

[132389.476707] ACPI: Preparing to enter system sleep state S4
[132389.476855] PM: Saving platform NVS memory

[132389.633938] Booting processor 1 APIC 0x1 ip 0x6000
[132389.631015] Initializing CPU#1
[132389.631015] CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)
[132389.631015] CPU: L2 Cache: 1024K (64 bytes/line)
[132389.631015] CPU 1/0x1 -> Node 0
[132389.631015] CPU: Physical Processor ID: 0
[132389.631015] CPU: Processor Core ID: 1
[132389.724063] CPU1: AMD Athlon(tm) 64 X2 Dual Core Processor 6400+ stepping 03
[132389.724093] CPU0 attaching NULL sched-domain.
[132389.752028] CPU0 attaching sched-domain:
[132389.752030]  domain 0: span 0-1 level MC
[132389.752031]   groups: group ffff880008c0fbf0 cpus 0 group ffff880008c8fbf0 cpus 1
[132389.752036] CPU1 attaching sched-domain:
[132389.752037]  domain 0: span 0-1 level MC
[132389.752038]   groups: group ffff880008c8fbf0 cpus 1 group ffff880008c0fbf0 cpus 0
[132389.752270] CPU1 is up

pokračuje spouštění pc...


Především mě tedy zaujalo toto hlášení:
[132389.240556] ACPI handle has no context!

Co jsem zběžně prolistoval nějaké stránky (POUZE PROLISTOVAL!) tak vypadá, že je spojeno s chybou přechodu do standby, což se podle hlášení pravděpodobně děje. Navíc podle hlášení procesoru vidím, že je PC poněkud starší. Možná by stálo za úvahu zkontrolovat také HW, jmenovitě kondenzátory na MB a zdrojovou část.
Pokud bude HW v pořádku, zkusil bych aktualizaci a mrknout na inicializaci USB, případně další konfiguraci. Na druhou stranu je možné, že odpojení USB je při pádu náhodou a nemá s chybou žádnou souvislost. Každopádně přeji hodně štěstí. Osobně se potýkám s podobným problémem.
U takto "nahodilé" chyby by to chtělo více výpisů z logů.

ZAJDAN

  • *****
  • 2 060
    • Zobrazit profil
    • E-mail
Re:Debian – odhlášení po spuštění aplikace
« Odpověď #13 kdy: 01. 05. 2013, 22:08:32 »
začal jsem tedy úplně tím nejsnadnějším co se tady zmínilo a založil účet nového uživatele
problémové aplikace jsem spustil pod ním a je klid
ovšem u původního uživatele problém setrvává
Vesele, vesele do továrny dělník běží...vesele, vesele do továrny jde. Vesele se usmívá když mu soustruh zazpívá...vesele, vesele do továrny jde. Vesele si poskočí když se soustruh roztočí ...vesele, vesele do továrny jde.

gdgdf

Re:Debian – odhlášení po spuštění aplikace
« Odpověď #14 kdy: 01. 05. 2013, 22:56:05 »
Zazalohuje a projdi skryte soubory (s teckou v  $HOME, ls -a, mc,..). Jeden z nich to bude.