Horší WiFi na MikroTik hAP ax3

vpn22

Horší WiFi na MikroTik hAP ax3
« kdy: 18. 01. 2023, 17:34:30 »
Dobrý den,

zakoupil jsem MikroTik hAP ax3 jako náhradu za hAP ac3. Nový ax3 ale bohužel má značně horší WiFi. Měřil jsem pomocí iperf3 oproti počítači připojenému přes Ethernet a a rychlosti jsou v průměru o 30 % horší. Rovněž indikovaná úrově signálu (aplikace nettest) je zhruba o 20 % horší. Detaily měření dávám v příloze.

V čem může být problém?

ac3 (ROS 7.7):
Kód: [Vybrat]
/interface wireless
set [ find default-name=wlan1 ] band=2ghz-onlyn channel-width=20/40mhz-XX \
    country="czech republic" disable-running-check=yes disabled=no distance=\
    indoors frequency=auto installation=indoor mode=ap-bridge ssid=2G \
    wireless-protocol=802.11 wps-mode=disabled
set [ find default-name=wlan2 ] band=5ghz-onlyac channel-width=\
    20/40/80mhz-XXXX country="czech republic" disable-running-check=yes \
    disabled=no distance=indoors frequency=auto installation=indoor mode=\
    ap-bridge skip-dfs-channels=all ssid=5G wireless-protocol=802.11 \
    wps-mode=disabled

ax3:
Kód: [Vybrat]
interface/wifiwave2/export
# jan/18/2023 17:22:52 by RouterOS 7.7
# software id = HGT8-C7QW
#
# model = C53UiG+5HPaxD2HPaxD
/interface wifiwave2 security
add authentication-types=wpa2-psk,wpa3-psk encryption=ccmp,gcmp,ccmp-256,gcmp-256 name=default wps=disable
/interface wifiwave2 configuration
add country=Czech mode=ap name=default security=default ssid=W
/interface wifiwave2
set [ find default-name=wifi1 ] channel.band=5ghz-ac .skip-dfs-channels=all .width=20/40/80mhz comment="WiFi 5 GHz" configuration=default configuration.mode=ap disabled=no
set [ find default-name=wifi2 ] channel.band=2ghz-n .skip-dfs-channels=all .width=20/40mhz comment="WiFi 2.4 GHz" configuration=default configuration.mode=ap disabled=no


Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #1 kdy: 18. 01. 2023, 21:16:56 »
a jak vypadá konfigurace? Jak máš umístěné antény a sílu signálu? Ty routery nejsou totožné, chovají se rádiově lehce jinak.

Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #2 kdy: 18. 01. 2023, 22:02:50 »
Ty jo, tak to docela koukám. Taky mám v plánu si tento router pořídit. Má s ním zkušenosti někdo další? Je to náhoda nebo standard?

czipis

  • ***
  • 207
    • Zobrazit profil
    • E-mail
Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #3 kdy: 19. 01. 2023, 07:18:45 »
hAP ax3
jeden rychlý test notebook cca 3 metry. iperf proti PC na 1GBit portu.

Kód: [Vybrat]
wlp0s20f3  IEEE 802.11  ESSID:"obyvak" 
          Mode:Managed  Frequency:5.26 GHz  Access Point: 4A:A9:8A:07:9A:70   
          Bit Rate=866.7 Mb/s   Tx-Power=22 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=60/70  Signal level=-50 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:30   Missed beacon:0

$ iperf3 -c 192.168.11.5  -t 60 -i 10
Connecting to host 192.168.11.5, port 5201
[  5] local 192.168.11.99 port 58954 connected to 192.168.11.5 port 5201
[ ID] Interval           Transfer     Bitrate         Retr  Cwnd
[  5]   0.00-10.00  sec   483 MBytes   405 Mbits/sec  109    407 KBytes       
[  5]  10.00-20.00  sec   511 MBytes   429 Mbits/sec   28    385 KBytes       
[  5]  20.00-30.00  sec   401 MBytes   337 Mbits/sec    7    823 KBytes       
[  5]  30.00-40.00  sec   394 MBytes   330 Mbits/sec   19   1.08 MBytes       
[  5]  40.00-50.00  sec   414 MBytes   347 Mbits/sec    0   1.22 MBytes       
[  5]  50.00-60.00  sec   412 MBytes   346 Mbits/sec    0   2.51 MBytes       
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-60.00  sec  2.55 GBytes   366 Mbits/sec  163             sender
[  5]   0.00-60.02  sec  2.55 GBytes   365 Mbits/sec                  receiver

iperf Done.



$ iperf3 -c 192.168.11.5  -t 60 -i 10 -R
Connecting to host 192.168.11.5, port 5201
Reverse mode, remote host 192.168.11.5 is sending
[  5] local 192.168.11.99 port 42100 connected to 192.168.11.5 port 5201
[ ID] Interval           Transfer     Bitrate
[  5]   0.00-10.00  sec   581 MBytes   487 Mbits/sec                 
[  5]  10.00-20.00  sec   717 MBytes   602 Mbits/sec                 
[  5]  20.00-30.00  sec   737 MBytes   618 Mbits/sec                 
[  5]  30.00-40.00  sec   751 MBytes   630 Mbits/sec                 
[  5]  40.00-50.00  sec   742 MBytes   622 Mbits/sec                 
[  5]  50.00-60.00  sec   708 MBytes   594 Mbits/sec                 
- - - - - - - - - - - - - - - - - - - - - - - - -
[ ID] Interval           Transfer     Bitrate         Retr
[  5]   0.00-60.01  sec  4.14 GBytes   592 Mbits/sec  130             sender
[  5]   0.00-60.00  sec  4.14 GBytes   592 Mbits/sec                  receiver

iperf Done.

czipis

  • ***
  • 207
    • Zobrazit profil
    • E-mail
Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #4 kdy: 19. 01. 2023, 11:16:10 »
proc na tom ax3 nemate nastavene ax, ale jedete v ac?

tady je muj config

Kód: [Vybrat]
/interface wifiwave2
set [ find default-name=wifi1 ] channel.band=5ghz-ax .frequency=5260 .skip-dfs-channels=disabled .width=20/40/80mhz  configuration.country=Czech .mode=ap .ssid=obyvak disabled=no security=obyvak
set [ find default-name=wifi2 ] channel.band=2ghz-ax .frequency=2462 .width=20/40mhz-eC configuration.country=Czech .mode=ap .ssid=obyvak disabled=no security=obyvak

ax3:
Kód: [Vybrat]
interface/wifiwave2/export
# jan/18/2023 17:22:52 by RouterOS 7.7
# software id = HGT8-C7QW
#
# model = C53UiG+5HPaxD2HPaxD
/interface wifiwave2 security
add authentication-types=wpa2-psk,wpa3-psk encryption=ccmp,gcmp,ccmp-256,gcmp-256 name=default wps=disable
/interface wifiwave2 configuration
add country=Czech mode=ap name=default security=default ssid=W
/interface wifiwave2
set [ find default-name=wifi1 ] channel.band=5ghz-ac .skip-dfs-channels=all .width=20/40/80mhz comment="WiFi 5 GHz" configuration=default configuration.mode=ap disabled=no
set [ find default-name=wifi2 ] channel.band=2ghz-n .skip-dfs-channels=all .width=20/40mhz comment="WiFi 2.4 GHz" configuration=default configuration.mode=ap disabled=no


vpn22

Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #5 kdy: 19. 01. 2023, 11:33:18 »
802.11ac mám nastavené na obou, abych porovnával stejné standardy.

Rychlosti na 802.11ax jsou podobné jako na ac.

Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #6 kdy: 19. 01. 2023, 11:38:34 »
802.11ac mám nastavené na obou, abych porovnával stejné standardy.

Rychlosti na 802.11ax jsou podobné jako na ac.

a co kanál, jeho šířka, rušení? Jaký je šum na rádiu? Pořád tady platí nějaké fyzikální zákon a prostě nelze prohodit dvě zařízení, nenastavit stejné podmínky a měřit to jen tak. Vždyť i blbé natočení routeru o 20 stupňů může mít desítky % dopad na přenosovou rychlost a ten ax3 přitom má antény řešeny lehce jinak.

vpn22

Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #7 kdy: 19. 01. 2023, 12:51:30 »
Umístění je stejné, šířka kanálu je stejná. Na 2,4 GHz tři jiná AP se signálem o 25 až 30 dBm horším, na 5 GHz není žádné další AP.

Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #8 kdy: 19. 01. 2023, 14:04:10 »
hm, to není moc informací :).

V jednom případě je ax3 rychlejší o 1/3, ve všech ostatní výrazně pomalejší. Není tam teda nějaké technické omezení nebo jeho nevýkonnost. Co mě zaujalo je právě variabilita mezi jednotlivými měřeními, až na ten jediný případ u ax3 (to spíše vylučuje, že by to byl vadný kus), tak ax3 dost skáče nahoru dolu, zatímco ac3 má daleko vyrovnanější čísla mezi jednotlivými měřeními.

Směřujem mi to právě k tomu, že máš problémy s rušením, odrazem signálu. Při měření přes nettest je rychlost stabilní, až při vyšších přenosech se projevuje problém.

Hledal bych rozdíly právě v rádiové části, v něčem bude rozdíl. Nemůžeš zkusit změnit místo, kde to měříš? Ax3 jsem měl několikrát v ruce a neměl jsem s ním tyhle problémy.

Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #9 kdy: 19. 01. 2023, 14:06:21 »
Zkus pro jistotu ROS 7.6. Verze 7.7 je venku asi týden a můžou s ní být nějaké problémy.

Ymzk

Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #10 kdy: 20. 01. 2023, 09:26:38 »
Toto je uz roky omielana tema ktora proste raz musi skoncit. Prosim ludi, nepouzivajte preboha wifi na mikrotikoch. Z biznisju je to to najhorsie snad co existuje. Uz ma nebavi neustale citat o wifi issues s mikrotikom. Mikrotik mam rad kvoli ich routovaciemu vykonu a nastaveniach ale preboha ludia. Nepouzivajte mikrotik kvoli wifi, je to snad najtragickejsie co existuje.

Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #11 kdy: 20. 01. 2023, 10:52:24 »
A co doporučuješ? Odpad typu Asus, TP-Link a podobně? Nebo zaplatit několikanásobek a nasadit Arubu nebo Cisco? Nebo tu zoufalost Unifi, která taky stojí dvoj až trojnásobek Mikrotiku, občas dojebou firmware a nebo prostě utnou podporu a bez externího managementu to nejde nastavit?
U Mikrotiku je největší problém v tom, že lidi je špatně nasazují. Buď pořídí poddimenzovaný model nebo ho prostě neumí nakonfigurovat. No a taky je šílenost dávat týden po vydání nový firmware.

Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #12 kdy: 20. 01. 2023, 11:30:21 »
nahodou, volakedy pouzivali atheros wifi moduly, a slapalo to paradne.
Ja mam doma nejake tie najlacnejsie hAP, ale tie su vyslovene na pokrytie 1 miestnosti - mam 2 na kazdom poschodi jedno. A mikrotiky musim mat, lebo napr. ja mam 3 siete - domacu, hostia a IoT. a kazda je oddelena. Viem to spravovat cez capsman - hlavny router mam 750G
Dokazem toto s inym vyrobcom?

ja.

  • ****
  • 250
    • Zobrazit profil
    • E-mail
Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #13 kdy: 20. 01. 2023, 16:10:31 »
Toto je uz roky omielana tema ktora proste raz musi skoncit. Prosim ludi, nepouzivajte preboha wifi na mikrotikoch. Z biznisju je to to najhorsie snad co existuje. Uz ma nebavi neustale citat o wifi issues s mikrotikom. Mikrotik mam rad kvoli ich routovaciemu vykonu a nastaveniach ale preboha ludia. Nepouzivajte mikrotik kvoli wifi, je to snad najtragickejsie co existuje.

Ale zase nepreháňajme. Áno, Mikrotik nie je najdokonalejšia wifi v celom známom vesmíre, ale mnohým vyhovuje, napríklad aj mne. Áno, Mikrotik má v porovnaní s inými len spodnú časť ponuky (napr. cap ac je ekvivalent ac lite, prichdázajúci cap ax je ekvivalent u6 lite, na vyššie modely ako nanohd alebo u6 pro/ent odpoveď nemajú), ale v mnohých prípadoch to stačí a ako spomenuli ostatní, iné značky majú aj iné problémy.

No a wifiwave2 už používajú vendor wifi stack, už nie sú žiadne vlastné drivery, takže zariadenia majú podobné vlastnosti ako iné, s tým istých chipsetom.

nahodou, volakedy pouzivali atheros wifi moduly, a slapalo to paradne.
Ja mam doma nejake tie najlacnejsie hAP, ale tie su vyslovene na pokrytie 1 miestnosti - mam 2 na kazdom poschodi jedno. A mikrotiky musim mat, lebo napr. ja mam 3 siete - domacu, hostia a IoT. a kazda je oddelena. Viem to spravovat cez capsman - hlavny router mam 750G
Dokazem toto s inym vyrobcom?

Áno, viacero SSID a ich tagovanie na VLAN-y dokážu aj iné AP. Napríklad vyššie spomínané Unifi, alebo Omada. Na rozdiel od capsmanu, cez Unifi alebo Omada controller manažuješ komplet zariadenie, nie len rádio.

Re:Horší WiFi na MikroTik hAP ax3
« Odpověď #14 kdy: 20. 01. 2023, 16:25:54 »
No a wifiwave2 už používajú vendor wifi stack, už nie sú žiadne vlastné drivery, takže zariadenia majú podobné vlastnosti ako iné, s tým istých chipsetom.
Mám to chápat tak, že pokud se objeví nějaké problémy s Wi-Fi, tak je dobré zkusit wifiwave2? Já se na wifiwave2 díval asi před rokem, a tehdy mi to přišlo jako RC verze, teď to na první pohled vypadá hotověji.

Áno, viacero SSID a ich tagovanie na VLAN-y dokážu aj iné AP.
Mikrotik to zvládá i v rámci jednoho SSID, a to s různými PSK (která jsou přiřazena k MAC adresám). Při větším počtu VLAN může být znát ta režie na další SSID.