reklama

Externí disk nefunguje

Externí disk nefunguje
« kdy: 07. 12. 2018, 00:00:34 »
zdravim Vas

Zakoupil jsem externi disk Seegate expansion portable 1TB ale bohuzel nejde na mem notasu s Arch Linuxem pouzivat.
Chova se to hodne divne a pokazde trochu jinak. Asi tomu chybi nejaky ovladac.
Po pripojeni disku k notasu se rozblika LED dioda na disku a trva asi minutu, nez se disk zobrazi jako dalsi pripojene zarizeni v PCManFM. Kdyz na toto zarizeni v PCManFM kliknu, tak se zobrazi misto sipky mysi symbol ze zarizeni pracuje, to trva asi dve minuty, procesor jede na 100 procent a pote se jen zobrazi hlaseni :

"Chyba při otevírání složky „/run/media/marek/Seagate Expansion Drive“: Adresář nebo soubor neexistuje"

Davam sem vypis z lsblk, je to to sda:

Kód: [Vybrat]
[marek@ArchLinux ~]$ lsblk
NAME         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
sda            8:0    0 931,5G  0 disk
└─sda1         8:1    0 931,5G  0 part
mmcblk0      179:0    0  29,1G  0 disk
├─mmcblk0p1  179:1    0  11,6G  0 part /
├─mmcblk0p2  179:2    0    15G  0 part /home
├─mmcblk0p3  179:3    0   500M  0 part /boot
└─mmcblk0p4  179:4    0     2G  0 part [SWAP]
mmcblk0boot0 179:8    0     4M  1 disk
mmcblk0boot1 179:16   0     4M  1 disk

a davam sem vypis z lsusb

Kód: [Vybrat]
[marek@ArchLinux ~]$ lsusb
Bus 002 Device 022: ID 0bc2:231a Seagate RSS LLC Expansion Portable
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 004: ID 0bda:5627 Realtek Semiconductor Corp.
Bus 001 Device 003: ID 0cf3:e500 Qualcomm Atheros Communications
Bus 001 Device 002: ID 045e:07fd Microsoft Corp. Nano Transceiver 1.1
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Jak jsem psal, pouzivam Arch Linux s WM JWM, tudiz zadne desktopove prostredi a vsechno si musim doinstalovat.
Asi chybi nejaky ovladac, mozna by pomohlo disk znovu naformatovat, nevim.
Jinde jsem ten disk zatim nezkousel pripojit. Jinak kdyz pripojim flesku do tohoto USB , tak se hned pripoji, zobrazi se v PCManFM a hned s ni jde pracovat

Budu vdecny za kazdou radu. Predem diky.

P.S. a jeste doplnim, kdyz jsem dal v terminalu "umount /dev/sda /mnt " tak se disk odpojil, a kdyz jsem dal "mount /dev/sda /mnt", tak se zobrazilo hlaseni "mount: /mnt: /dev/sda není platným blokovým zařízením."
« Poslední změna: 07. 12. 2018, 10:47:48 od Petr Krčmář »

reklama


Kit

Re:externi disk nefunguje
« Odpověď #1 kdy: 07. 12. 2018, 00:45:17 »
Zkus připojit /dev/sda1.

Youda

Re:externi disk nefunguje
« Odpověď #2 kdy: 07. 12. 2018, 01:00:29 »
Tam budou nejake proprietarni wokenni srakance schvane v nejakych kouzelnych partisnach.

Normalne fdiskem vymaz vsechny partisny a rozdel si to podle sebe znova

Re:externi disk nefunguje
« Odpověď #3 kdy: 07. 12. 2018, 02:54:29 »
Tak jsem to zkousel tim fdiskem, smazani sda1 probehlo normalne, vytvoreni noveho oddilu taky ale po zadani zapisu "w" se objevilo toto hlaseni :

Tabulka rozdělení disku byla změněna.
Volám ioctl() pro znovunačtení tabulky rozdělení disku.
/dev/sda: uzavření zařízení selhalo: Chyba vstupu/výstupu

Je to nejake divne. :(

V.

Re:externi disk nefunguje
« Odpověď #4 kdy: 07. 12. 2018, 04:41:20 »
Zkuste jinej kabel / jinou napájecí větev kompu.


smok

Re:externi disk nefunguje
« Odpověď #5 kdy: 07. 12. 2018, 08:09:38 »
Mám dokonca dva takéto disky, riešením u nich bol čo najkratší usb kábel, a najlepšie fungujú ak je disk pripojený len cez redukciu klasické USB/mini USB.  Disk musím niečím podoprieť aby nevypadol z tej redukcie, ale funguje to.

Kit

Re:externi disk nefunguje
« Odpověď #6 kdy: 07. 12. 2018, 08:29:33 »
Mám dokonca dva takéto disky, riešením u nich bol čo najkratší usb kábel, a najlepšie fungujú ak je disk pripojený len cez redukciu klasické USB/mini USB.  Disk musím niečím podoprieť aby nevypadol z tej redukcie, ale funguje to.

Není třeba to přehánět, dobrý kabel do 50 cm je bez potíží.

Re:Externí disk nefunguje
« Odpověď #7 kdy: 07. 12. 2018, 11:01:17 »
To by me ani ve snu nenapadlo, ze na to muze mit vliv delka kabelu. Pouzivam kabel , ktery je k tomu disku dodany.
Ted jeste zkousim neco s fdisk a cfdisk ale chova se to opravdu nestandartne. Me to prijde, jako by ten disk mel nejak napevno nastavena uzivatelska prava a neslo to zmenit. Jednou jsem takhle resil jednu flesku a v Linuxu jsem s tim nedokazal nic udelat, potom jsem ji dal znovu naformatovat do compu s Windows a ten si s ni poradil a znovu ji naformatoval. Mozna to udelam s timhle diskem taky.

krl

Re:Externí disk nefunguje
« Odpověď #8 kdy: 07. 12. 2018, 12:53:52 »
Nemas nahodou starsi NB, v ktorom USB2.0 konektory nedokazali dodat viac ako 500mA? Vsetky externe disky ktore som rozobral mali na disku napisany prud minimalne 550mA, dalsi az 700mA. Jeden taky 550mA mam doma, niekedy funguje, niekedy sa nechce ani roztocit. Ale ak mas USB3.0, tak teba sa to netyka, tam je limit 900mA.
Ano aj kabel na to ma vplyv, ale ak je to original dodavany s diskom, tak kablom to nebude.

ByCzech

  • *****
  • 1 540
    • Zobrazit profil
    • E-mail
Re:Externí disk nefunguje
« Odpověď #9 kdy: 07. 12. 2018, 14:00:16 »
Kromě výše zmíněného (hlavně ohledně napájení, tam osobně vidím nejspíše problém), tak zkusit jak se to chová se notebookem na zdroji a na baterii. Pokud je na baterii může být napájení z úsporných důvodů omezeno.

Re:Externí disk nefunguje
« Odpověď #10 kdy: 07. 12. 2018, 20:26:14 »
Tak jsem udelal pokus na compu s Windows, do disku se stahnul automaticky ovladac, pote pruzkunik vyzadoval zformatovani disku, tak jsem zformatoval disk. Pote uz zacal disk v pohode fungovat ( kopirovani souboru, mazani, otevirani souboru vse OK ).
Takze tim se da asi vyloucit ta moznost se spatnym resp. dlouhym kabelem.

Pote jsem disk pripojil k memu notasu, disk uz se zacal chovat standartne, daji se z nej cist soubory, upravovat soubory, daji se znej kopirovat soubory, ale nejde kopirovat soubory na disk, a to ani pod rootem, co me tedy prijde divny. Asi bude chyba v nastaveni pristupovych prav. Tohle musim jeste doladit a vypada to ze bude disk fungovat.

Blby tedy je, ze jsem ten disk nebyl schopen rozchodit na Linuxu a musel jsem k tomu pouzit Windows. Ale zatim nejsem natolik linuxove zdatny a tak i tohle bylo zatim reseni.

Jeste dam potom vedet, jestli se mi podarilo doladit ty pristupova prava. Zatim diky za rady.

p.s. to napeti v USB by melo byt v pohode, je to novy notas kupovany letos a pripojuji to pres USB 3.0
« Poslední změna: 07. 12. 2018, 20:28:38 od sysel73 »

k3dAR

  • ****
  • 434
  • porad nemam telo, ale uz mam hlavu... nobody
    • Zobrazit profil
    • E-mail
Re:Externí disk nefunguje
« Odpověď #11 kdy: 08. 12. 2018, 17:59:16 »
Je v podstate nemozne aby si to pres fdisk nebo(pokud slo o gpt) pres parted (ci v grafice gparted) nemohl smazat (vcetne inicializace tabulky)... Tyhle nastroje s diskem pracuji na nizsi urovni nez umozni Windows (v grafice)...

MasoxCZ

Re:Externí disk nefunguje
« Odpověď #12 kdy: 08. 12. 2018, 20:38:34 »
p.s. to napeti v USB by melo byt v pohode, je to novy notas kupovany letos a pripojuji to pres USB 3.0

Pro informaci, mA jsou miliampéry a tedy jde o jednotku PROUDU. Jinými slovy, ten disk může mít takový odběr, že mu proud dodávaný portem nestačí. A pokud je vadný kabel (což být může) nemusí mu stačit ani proud z USB3, protože ho napětí 5V nemusí skrz vadný kabel / konektor protlačit.
Jako první zkus jiný, kvalitní, vyzkoušený kabel. Další možnost je to s kvalitním kabelem zkusit na napájeném hubu.
Další problém může být, že je blbě připájený konektor k desce v boxu.
Celkově bys měl asi o dost rychlejší, kdybys ho došel reklamovat a vzal si jiný. Pro mnohé možná překvapivě, ale i čas má nějakou hodnotu.

.

Re:Externí disk nefunguje
« Odpověď #13 kdy: 08. 12. 2018, 20:59:03 »
Celkově bys měl asi o dost rychlejší, kdybys ho došel reklamovat a vzal si jiný. Pro mnohé možná překvapivě, ale i čas má nějakou hodnotu.
A reklamovat to bude s tím, že na Widlích to chodí bez problému, ale v Linuxu nechodí...

k3dAR

  • ****
  • 434
  • porad nemam telo, ale uz mam hlavu... nobody
    • Zobrazit profil
    • E-mail
Re:Externí disk nefunguje
« Odpověď #14 kdy: 08. 12. 2018, 21:37:30 »
A reklamovat to bude s tím, že na Widlích to chodí bez problému, ale v Linuxu nechodí...
Pokud by to opravdu bylo smecko co vyzaduje nestandardni ovladac misto massstorage tak ano.

 

reklama