Nelze nainstalovat závislost libc6:i386

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Nelze nainstalovat závislost libc6:i386
« Odpověď #15 kdy: 25. 01. 2017, 11:39:04 »
P.S. Už se našlo využití pro dd:P

Ja bych zkusil:

dd if=/usr/lib/libstdc++-libc6.24-5.so.3  of=/usr/lib/libstdc++-libc6.19-18+deb8u7.so.3


Martin Levy

Re:Nelze nainstalovat závislost libc6:i386
« Odpověď #16 kdy: 25. 01. 2017, 11:39:11 »
verze libc6:i386 (>= 2.3.4-1) neni ani ve vetvi unstable nebo testing

https://packages.debian.org/search?keywords=libc6-i386&searchon=names&suite=all&section=all

takze jedine si to sehnat jinde pokud to zvladnete

Martin Levy

Re:Nelze nainstalovat závislost libc6:i386
« Odpověď #17 kdy: 25. 01. 2017, 11:49:38 »

Pavouk106

  • *****
  • 2 354
    • Zobrazit profil
    • Můj blog
    • E-mail
Re:Nelze nainstalovat závislost libc6:i386
« Odpověď #18 kdy: 25. 01. 2017, 13:59:26 »
Neříkám, že se nemůžu mýlit, ale chápu tohle libc6-i386 : Depends: libc6 (= 2.19-18+deb8u7) but 2.24-5 is to be installed správně tak, že libc6-i386 chce striktně libc6 2.19-18? A systém Ti chce instalovat 2.24-5?

Píšeš, že tu 2.24-5 přitáhl VirtualBox a Ty jsi ji přebil starší. Není to teda právě ten VirtualBox, kterej to teď chce zase tahat na 2.24-5? Přinejmenším to tak vypadá...

ZAJDAN

  • *****
  • 2 047
    • Zobrazit profil
    • E-mail
Re:Nelze nainstalovat závislost libc6:i386
« Odpověď #19 kdy: 25. 01. 2017, 14:23:14 »
Neříkám, že se nemůžu mýlit, ale chápu tohle libc6-i386 : Depends: libc6 (= 2.19-18+deb8u7) but 2.24-5 is to be installed správně tak, že libc6-i386 chce striktně libc6 2.19-18? A systém Ti chce instalovat 2.24-5?
Píšeš, že tu 2.24-5 přitáhl VirtualBox a Ty jsi ji přebil starší. Není to teda právě ten VirtualBox, kterej to teď chce zase tahat na 2.24-5? Přinejmenším to tak vypadá...
ještě před tím než jsem začal instalovat balíček pro tiskárnu jsem měl "defaultní" libc2.24-5 a ten si přitáhl Virtualbox...
protože baliček s ovladači pro tiskárnu brečel, že chce 2.19-18+deb8u7 - stáhl jsem tuto verzi a tu nainstaloval, ovšem za cenu toho, že přestal fungovat virtualbox a protože ten je pro mě důležitější než tiskárna, nasadil jsem zpět vyšší verzi libc6-2.24-9  a v tomto stavu jsem zůstal
Vesele, vesele do továrny dělník běží...vesele, vesele do továrny jde. Vesele se usmívá když mu soustruh zazpívá...vesele, vesele do továrny jde. Vesele si poskočí když se soustruh roztočí ...vesele, vesele do továrny jde.


Lol Phirae

Re:Nelze nainstalovat závislost libc6:i386
« Odpověď #20 kdy: 25. 01. 2017, 14:47:47 »
Řešení - přestaň si zasírat systém rozbitejma third-party sračkama.

ZAJDAN

  • *****
  • 2 047
    • Zobrazit profil
    • E-mail
Re:Nelze nainstalovat závislost libc6:i386
« Odpověď #21 kdy: 25. 01. 2017, 14:54:00 »
Řešení - přestaň si zasírat systém rozbitejma third-party sračkama.
ano, protože vidím, že to nemá čisté řešení, tak se na nějakýho Brothera mohu vyprdnout. nainstaloval jsem si tam Nashuatec MPC2800(krásně a ladně) a tisknu na něj.
Vesele, vesele do továrny dělník běží...vesele, vesele do továrny jde. Vesele se usmívá když mu soustruh zazpívá...vesele, vesele do továrny jde. Vesele si poskočí když se soustruh roztočí ...vesele, vesele do továrny jde.

Sten

Re:Nelze nainstalovat závislost libc6:i386
« Odpověď #22 kdy: 25. 01. 2017, 15:02:47 »
ještě před tím než jsem začal instalovat balíček pro tiskárnu jsem měl "defaultní" libc2.24-5 a ten si přitáhl Virtualbox...
protože baliček s ovladači pro tiskárnu brečel, že chce 2.19-18+deb8u7 - stáhl jsem tuto verzi a tu nainstaloval, ovšem za cenu toho, že přestal fungovat virtualbox a protože ten je pro mě důležitější než tiskárna, nasadil jsem zpět vyšší verzi libc6-2.24-9  a v tomto stavu jsem zůstal

Odkud vůbec ten balíček VirtualBoxu máte? V debianních repozitářích VirtualBox je a určitě bude fungovat s tou libc6, která tam je.

2. řešení: když jste si někde sehnal libc6 2.24-9, sežeňte si odtamtuď i libc6-i386 2.24-9.

Pavouk106

  • *****
  • 2 354
    • Zobrazit profil
    • Můj blog
    • E-mail
Re:Nelze nainstalovat závislost libc6:i386
« Odpověď #23 kdy: 26. 01. 2017, 12:41:53 »
Přesně, čistý řešení to nemá. Tiskárna vyžaduje konkrétní libc6-i386 a VirtualBox vyžaduje konkrétní (nebo minimální) libc6. Ovšem obojí chce knihovnu v jiné verzi.

Pokud nejde v Debianu nainstalovat jiná verze slotově, tak nevím, jak to řešit (Debian ani podobná distra nepoužívám).

Sten

Re:Nelze nainstalovat závislost libc6:i386
« Odpověď #24 kdy: 26. 01. 2017, 13:22:14 »
Přesně, čistý řešení to nemá. Tiskárna vyžaduje konkrétní libc6-i386 a VirtualBox vyžaduje konkrétní (nebo minimální) libc6. Ovšem obojí chce knihovnu v jiné verzi.

Tiskárna vyžaduje libovolnou verzi libc6-i386 ≥ 2.3.4-1, ale v repozitářích je jen verze, která není kompatibilní s tou nainstalovanou pro VirtualBox. Čistá řešení jsou dvě, nainstalovat VirtualBox z debianních repozitářů (kterému stačí starší libc6) nebo sehnat libc6-i386 ve stejné verzi, jakou má nainstalovaná libc6.