Fórum Root.cz

Hlavní témata => Distribuce => Téma založeno: ZAJDAN 24. 01. 2017, 18:25:09

Název: Nelze nainstalovat závislost libc6:i386
Přispěvatel: ZAJDAN 24. 01. 2017, 18:25:09
Ahoj,
snažím se nainstalovat network printer BROTHER DCP_7065-DN
stahl jsem si deb baliček a pokusil nainstalovat:

Kód: [Vybrat]
dpkg -i  Downloads/printers/brother/cupswrapperDCP7065DN-2.0.4-2.i386.deb
ale system brečí ohledně chybějící knihovny:

Kód: [Vybrat]
The following packages have unmet dependencies:
 cupswrapperdcp7065dn:i386 : Depends: libc6:i386 (>= 2.3.4-1) but it is not going to be installed
 libc6-i386 : Depends: libc6 (= 2.19-18+deb8u7) but 2.24-5 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

jako obvykle to vybízí k apt-get -f install , ktery by ovšem chtěl odstranit hromadu balíků - NE!
samostatně instalovat libc6-i386 se taky nedaří

díky za každou radu
Název: Re:libc6:i386 - dependencies problem
Přispěvatel: Sten 24. 01. 2017, 18:41:44
Vypadá to, že pro i386 máte jako zdroj jen stable, zatímco pro amd64 máte i testing.
Název: Re:libc6:i386 - dependencies problem
Přispěvatel: ZAJDAN 24. 01. 2017, 18:49:23
Vypadá to, že pro i386 máte jako zdroj jen stable, zatímco pro amd64 máte i testing.
mam pouze
jessie/updates main contrib
Název: Re:libc6:i386 - dependencies problem
Přispěvatel: Sten 24. 01. 2017, 19:03:13
mam pouze
jessie/updates main contrib

V jessie-updates je libc6 2.19-18+deb8u7, tu 2.24-5 jste musel sebrat někde jinde
Název: Re:libc6:i386 - dependencies problem
Přispěvatel: ZAJDAN 24. 01. 2017, 19:05:51
aktivní je ale ta defaultní:
Kód: [Vybrat]
:~$ dpkg -l libc6
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                               Version                        Architecture                   Description
+++-==================================================-==============================-==============================-==========================================================================================================
ii  libc6:amd64                                        2.19-18+deb8u7                 amd64                          GNU C Library: Shared libraries
zdenek@linux-desktop1:~$
Název: Re:libc6:i386 - dependencies problem
Přispěvatel: Petr Krčmář 24. 01. 2017, 19:22:46
Systém je 64bitový a balíček 32bitový. Je povolený multiarch?
Název: Re:libc6:i386 - dependencies problem
Přispěvatel: ZAJDAN 24. 01. 2017, 19:27:07
Systém je 64bitový a balíček 32bitový. Je povolený multiarch?
ano multiarch je povoleny (dpkg --add-architecture i386)
Název: Re:libc6:i386 - dependencies problem
Přispěvatel: ZAJDAN 24. 01. 2017, 19:28:20
mam pouze
jessie/updates main contrib

V jessie-updates je libc6 2.19-18+deb8u7, tu 2.24-5 jste musel sebrat někde jinde
tu 2.24.5 mi natahl VirtualBOx...pak jsem ju prebil tou starsi
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: ByCzech 24. 01. 2017, 23:46:03
Kód: [Vybrat]
but 2.24-5 is to be installed

Tohle jasně říká, že to z nějakého důvodu si to myslí, že když splní závislosti, že bude instalována 2.24. Jasně vám tu radili, ať to spravíte. Přiznal jste, že jste s tím blbnul a máte to v nekonzistentním stavu. Takže pokud vezmu, že je pravda co jste řekl. Udělal jste po tom, co jste vrátil správnou verzi knihovny "apt-get update"? A další věc, jste si jist, že s tou vyšší verzí libc se vám nedostalo do systému něco dalšího z testing/sid větve?
Srovnejte si to do kupy (raději ne ručně, očividně to neumíte a nevíte co děláte, využijte např. apt pinning) a až to bude v konzistentním stavu, pak instalujte další software (a pokud bude po správném nastavení apt pinning balíčkovací systém chtít i odinstalovávat, aby to srovnal, buďte mu po vůli, doinstalujete co chybí v dalším kroku se správnými verzemi).
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: ZAJDAN 25. 01. 2017, 09:27:17
to ByCzech
Tebe specialně prosím o jednu věc, nezapojuj se do mých problémů, děkuji !
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: ByCzech 25. 01. 2017, 09:45:28
to ByCzech
Tebe specialně prosím o jednu věc, nezapojuj se do mých problémů, děkuji !

Já si říkal, že ta tvoje patička bude jen rozmazlenost, arogance, sebestřednost, ješitnost..., ale dal jsem tomu šanci, poslal ti přesný návod jak si s tím poradit a ukázalo se co seš zač :D.

Neděkuj, já si dělám co chci a budu si dělat co chci. Veřejné diskuze jsou od toho, aby poradily i ostatním nejen sebestřednému ZAJDANovi, který si myslí, že když něco něco dělá špatným způsobem a ono se to rozbije, tak není dobrý nápad ostatní před takovým debilním jednáním varovat, aby to nedělali stejně. Tudíž - prosbě se nevyhovuje, nevím vůbec kde máš tu drzost tohle na veřejném fóru žádat.
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: Lol Phirae 25. 01. 2017, 09:55:16
Vy jste se v tom zase vrtal, pane doktore, že jo?  ;D

P.S. Už se našlo využití pro dd?  :P
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: ZAJDAN 25. 01. 2017, 10:00:08
nejlepší je si amatérů jako já nevšímat.....mi se sami vytrestáme
občas se najdou i ochotní lidé co umějí být konkrétní a poradit
obecné moudra a arogance a pocit mesiáše diskuze jen špiní
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: ByCzech 25. 01. 2017, 10:01:12
nejlepší je si amatérů jako já nevšímat.....mi se sami vytrestáme
občas se najdou i ochotní lidé co umějí být konkrétní a poradit
obecné moudra a arogance a pocit mesiáše diskuze jen špiní

Však ano, já ti poradil. To že se vytrestáváš mi nevadí. To že jednáš bezcharakterně už ano.
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: Danny 25. 01. 2017, 11:01:08
ja pro instalaci baliku, ktere jsem stahl a potrebuji nejake zavislosti, pouzivam gdebi

Kód: [Vybrat]
apt-get install gdebi-core
Kód: [Vybrat]
gdebi balicek.deb
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: JardaP . 25. 01. 2017, 11:39:04
P.S. Už se našlo využití pro dd?  :P

Ja bych zkusil:

dd if=/usr/lib/libstdc++-libc6.24-5.so.3  of=/usr/lib/libstdc++-libc6.19-18+deb8u7.so.3
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: Martin Levy 25. 01. 2017, 11:39:11
verze libc6:i386 (>= 2.3.4-1) neni ani ve vetvi unstable nebo testing

https://packages.debian.org/search?keywords=libc6-i386&searchon=names&suite=all&section=all

takze jedine si to sehnat jinde pokud to zvladnete
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: Martin Levy 25. 01. 2017, 11:49:38
mozna zkusit tuhle verzi

http://snapshot.debian.org/archive/debian/20090106T000000Z/pool/main/g/glibc/libc6_2.7-18_i386.deb

gdebi install libc6_2.7-18_i386.deb
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: Pavouk106 25. 01. 2017, 13:59:26
Neříkám, že se nemůžu mýlit, ale chápu tohle libc6-i386 : Depends: libc6 (= 2.19-18+deb8u7) but 2.24-5 is to be installed správně tak, že libc6-i386 chce striktně libc6 2.19-18? A systém Ti chce instalovat 2.24-5?

Píšeš, že tu 2.24-5 přitáhl VirtualBox a Ty jsi ji přebil starší. Není to teda právě ten VirtualBox, kterej to teď chce zase tahat na 2.24-5? Přinejmenším to tak vypadá...
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: ZAJDAN 25. 01. 2017, 14:23:14
Neříkám, že se nemůžu mýlit, ale chápu tohle libc6-i386 : Depends: libc6 (= 2.19-18+deb8u7) but 2.24-5 is to be installed správně tak, že libc6-i386 chce striktně libc6 2.19-18? A systém Ti chce instalovat 2.24-5?
Píšeš, že tu 2.24-5 přitáhl VirtualBox a Ty jsi ji přebil starší. Není to teda právě ten VirtualBox, kterej to teď chce zase tahat na 2.24-5? Přinejmenším to tak vypadá...
ještě před tím než jsem začal instalovat balíček pro tiskárnu jsem měl "defaultní" libc2.24-5 a ten si přitáhl Virtualbox...
protože baliček s ovladači pro tiskárnu brečel, že chce 2.19-18+deb8u7 - stáhl jsem tuto verzi a tu nainstaloval, ovšem za cenu toho, že přestal fungovat virtualbox a protože ten je pro mě důležitější než tiskárna, nasadil jsem zpět vyšší verzi libc6-2.24-9  a v tomto stavu jsem zůstal
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: Lol Phirae 25. 01. 2017, 14:47:47
Řešení - přestaň si zasírat systém rozbitejma third-party sračkama.
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: ZAJDAN 25. 01. 2017, 14:54:00
Řešení - přestaň si zasírat systém rozbitejma third-party sračkama.
ano, protože vidím, že to nemá čisté řešení, tak se na nějakýho Brothera mohu vyprdnout. nainstaloval jsem si tam Nashuatec MPC2800(krásně a ladně) a tisknu na něj.
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: Sten 25. 01. 2017, 15:02:47
ještě před tím než jsem začal instalovat balíček pro tiskárnu jsem měl "defaultní" libc2.24-5 a ten si přitáhl Virtualbox...
protože baliček s ovladači pro tiskárnu brečel, že chce 2.19-18+deb8u7 - stáhl jsem tuto verzi a tu nainstaloval, ovšem za cenu toho, že přestal fungovat virtualbox a protože ten je pro mě důležitější než tiskárna, nasadil jsem zpět vyšší verzi libc6-2.24-9  a v tomto stavu jsem zůstal

Odkud vůbec ten balíček VirtualBoxu máte? V debianních repozitářích VirtualBox je (https://packages.debian.org/jessie/virtualbox) a určitě bude fungovat s tou libc6, která tam je.

2. řešení: když jste si někde sehnal libc6 2.24-9, sežeňte si odtamtuď i libc6-i386 2.24-9.
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: Pavouk106 26. 01. 2017, 12:41:53
Přesně, čistý řešení to nemá. Tiskárna vyžaduje konkrétní libc6-i386 a VirtualBox vyžaduje konkrétní (nebo minimální) libc6. Ovšem obojí chce knihovnu v jiné verzi.

Pokud nejde v Debianu nainstalovat jiná verze slotově, tak nevím, jak to řešit (Debian ani podobná distra nepoužívám).
Název: Re:Nelze nainstalovat závislost libc6:i386
Přispěvatel: Sten 26. 01. 2017, 13:22:14
Přesně, čistý řešení to nemá. Tiskárna vyžaduje konkrétní libc6-i386 a VirtualBox vyžaduje konkrétní (nebo minimální) libc6. Ovšem obojí chce knihovnu v jiné verzi.

Tiskárna vyžaduje libovolnou verzi libc6-i386 ≥ 2.3.4-1, ale v repozitářích je jen verze, která není kompatibilní s tou nainstalovanou pro VirtualBox. Čistá řešení jsou dvě, nainstalovat VirtualBox z debianních repozitářů (kterému stačí starší libc6) nebo sehnat libc6-i386 ve stejné verzi, jakou má nainstalovaná libc6.