Vim píše písmena na numerické klávesnici

bagr

Vim píše písmena na numerické klávesnici
« kdy: 04. 08. 2014, 12:44:06 »
Ahojte,
mam nejaky problem s kodovanim a nemuzu psat ve vimu cisla na numericke klavesnici (shift + diakritika funguje).
Bez ohledu na to, kde jsem v aktualnim radku, se pri zmacknuti cisla vytvori radek nad aktualnim a na jeho zacatek se napise pismeno od 'p' (0) do 'y' (9). Numericke + napise 'l' (male L). '/', '*', '-' pisou <F2>, <F3>, <F4> (coz se potom musi smazat ctyrmi backspacy).
V Bashi funguji cisla normalne. V aptitude taky. (tzn. readline je zpracuje)
Vsechny ostatni veci v terminalu funguji taky normalne. htop kresli stromy a zobrazuji se spravne. Z /dev/urandom lezou i cinske/japonske znaky. (I kdyz i spousta typickych ▒▒.) Pouzivam PuTTY. Je v ni nastavene UTF-8.

LC_ALL=cs_CZ.UTF-8
LANG=cs_CZ.UTF-8
LANGUAGE=cz_CZ.UTF-8

Ve vimu je termencoding i encoding utf-8.
Kdyz pustim screen v UTF8 a tam vim, chova se to stejne.
Cygwinovska mintty a v ni pustene SSH na ten stroj a tam vim se chova korektne.
Co je spatne s nejakym nastavenim PuTTY, pekne prosim?
« Poslední změna: 04. 08. 2014, 13:23:05 od Petr Krčmář »


bagr

Re:Vim pise pismena misto cisel na numericke klavesnici
« Odpověď #1 kdy: 04. 08. 2014, 13:08:04 »
Nasel jsem cloveka, co ma stejny problem (vsem ostatnim to nepsalo vubec nebo jen otazniky).
Reseni je v Terminal > Features: Disable application keypad mode.
Ja si hral predtim jenom v Terminal>Keyboard s nastavenim numpadu a nic nepomahalo :(
Diky za vas cas pri cteni, muze se to tu zamknout a ponechat jako pomoc.