Jaký PIM / Groupware?

LKG

Re:Jaký PIM / Groupware?
« Odpověď #15 kdy: 09. 09. 2012, 19:58:56 »
Ideálně přes PEAR, pak se to dobře aktualizuje. Je potřeba jen nějaká minimální konfigurace http serveru - alias kvůli activesync atd. Největší magořina je stejně admin rozhraní.


Zopper

  • *****
  • 715
    • Zobrazit profil
Re:Jaký PIM / Groupware?
« Odpověď #16 kdy: 09. 09. 2012, 20:27:01 »
OK, dneska už to řešit nebudu, ale zítra zase horde 5 nainstaluju (pear install -a -B horde/horde-beta). Máš nějaké poznámky k http://www.horde.org/apps/horde/docs/INSTALL ?

retard

Re:Jaký PIM / Groupware?
« Odpověď #17 kdy: 10. 09. 2012, 01:38:01 »
Chápu, že to je trochu "rouhačství", ale řada zákazníků stále ještě běží na Exchange 2003 ve verzi SMB, dali za to původně 15-tisíc a mají to dobře deset let. Pokud to porovnám s tím (CO+S JAKÝMI PROBLÉMY+ZA KOLIK) nabízí řada výše uvedených firem, vyjde z toho Microsoft jako jasná hvězda.

Zimbra stojí například 1500$/3 roky za standardní edici a 25 mailboxů.
Nedej bože, abych chtěl třeba 30 mailboxů.

V takovém kontextu mi přijde obecně "OpenSource" řešení jako:
- méně spolehlivé
- více problematické
- náročnější na znalosti supportu
- dražší

Promiňte, ale takhle si spolehlivou službu nepředstavuju.
Jistě, pokud člověku stačí ComunityEdition, pak je to ok, ale nakonec mi může být jedno, jestli mám dát 1500$ Microsoftu nebo těm, kdo stojí za Zimbrou. Resp. jedno mi to není, protože Zibramanům bych to měl dávat každé tři roky a Microsoftu jen jednou.

Mam skor opacnu skusenost. Exchange 2003 i 2007 ma totalne tragicky webmail. Nepouzitelne na mobilnych zariadeniach, nepouzitelne na serioznu pracu aj na regulernych pocitatoch. Exchange vlastne bez Outlooku nema vobec zmysel - takze treba pocitat aj cenu Office licenci. Teraz co ak ma niekto nebodaj Mac - Outlook pre Mac je nepouzitelny s Exchange serverom (nepodprouje starsie verzie Exchange) a nepodporuje pravidla (epic MS fail).  Zimbra nepotrebuje desktopovehlo klienta, webrozhraniu staci slusny moderny browser a je vybavene - ziadne licencie, ziadne nocne mory s debugom nefungujuich otlakov. Ked chce niekto silou mocou desktop aplikaciu, Zimbra Desktop je zadarmo. A ked uz musi mat otlak  (uprimna sustrast), Zimbra Connector u klietnov funguje spolahlivejsie ako nativny Exchange... Mobilna verzia Zimbra webmailu je perfektne pouzitelna tiez, viaceri zakaznici ani necheli active sync... Cize ani toto nie je cierno biele.  A to uz radsej nejdem rozoberat HA riesenie pre Exchange... ;)

LKG

Re:Jaký PIM / Groupware?
« Odpověď #18 kdy: 10. 09. 2012, 07:24:35 »
K poznámkám jenom tolik, že je potřeba si dát pozor na změnu autentizačního backendu, ten prostě musí fungovat, jinak se s konfigurací Horde může začít od začátku. Já mám autentizaci nastavenou přes IMAP, t.j. nastavený dovecot, který funguje, lze se do něj přihlásit a pracovat s poštou. Pak je potřeba nezapomenout vyplnit, jaký IMAP uživatel v rámci Horde bude Administrator.

horde ve výchozím nastavení totiž automaticky přihlašuje uživatele Administrator bez hesla. Se změnou autentizace se Administrator už nepřihlásí, a je potřeba mít připraveného Administratora nového.

Nevím pro kolik je to uživatelů, tak nevím jestli potřebuješ LDAP nebo jak chceš autentizovat. V případě potřeby můžu dodat jak zkonfigurovat horde právě pro použití IMAP.

Před započetím jakékoliv práce doporučuju http://your-server/horde/test.php vyzkoušet tak, aby závislosti byly splněné a funkční, a byly tam potřebné optional komponenty.

Zopper

  • *****
  • 715
    • Zobrazit profil
Re:Jaký PIM / Groupware?
« Odpověď #19 kdy: 10. 09. 2012, 15:20:58 »
No tak jsem nainstaloval horde-beta - autentifikace funguje jak má... jenže nemůžu nainstalovat většinu aplikací, protože
Kód: [Vybrat]
pear install -a horde/imp
horde/imp requires package "horde/horde" (version >= 4.0.0, version <= 5.0.0alpha1, excluded versions: 5.0.0alpha1), installed version is 5.0.0beta5
horde/imp requires package "horde/Horde_Auth" (version >= 1.0.4, version <= 2.0.0alpha1, excluded versions: 2.0.0alpha1), installed version is 2.0.0beta1
horde/imp requires package "horde/Horde_Browser" (version >= 1.0.0, version <= 2.0.0alpha1, excluded versions: 2.0.0alpha1), installed version is 2.0.0beta2
...
No valid packages found
install failed

Když zkusím přidat -beta, tak se objeví zase jiné balíky ve špatných verzích.

A pokud zkusím použít to co nainstalovat šlo - tj kalendář (k filtrům se nedostanu, když nenainstaluju webmail), dostanu prázdnou stránku - a v logu žádná informace není.

Na tomhle jsem skončil i minule...

Pro jistotu - server je debian squeeze, aktuální verze php, mysql, apache ze stable.

Nějaký hint? :)
Jediné, co mě napdá, je šaráda s verzemi a každý problematický balík ručně upgradovat na -beta či -alpha, případně ještě povolit jejich automatickou instalaci, ale v manuálu o tom není ani slovo - bojím se, aby se to zapnutím testing verzí nerozbilo úplně.


Zopper

  • *****
  • 715
    • Zobrazit profil
Re:Jaký PIM / Groupware?
« Odpověď #20 kdy: 10. 09. 2012, 15:23:47 »
Ještě poznámka: test.php samozřejmě ověřen, jediné co nemám je PAM a PostgreSQL modul, protože to nepoužívám.

Zopper

  • *****
  • 715
    • Zobrazit profil
Re:Jaký PIM / Groupware?
« Odpověď #21 kdy: 10. 09. 2012, 18:25:54 »
Tak jsem zkusil všechny problémové balíčky posunout na betaverzi. Ne všechno šlo (třeba poznámky), ale kalendář i úkoly jo, stejně jako mail. Takže to vypadá, že všechno důležité funguje, jdu zkusit synchronizaci a takové věci.

Re:Jaký PIM / Groupware?
« Odpověď #22 kdy: 12. 09. 2012, 12:07:11 »
Pokud by to nevadilo, rád bych se přidal s podobný dotazem. Sháním něco co umí klasiku, takže kalendář, mail, TODO, poznámky, kontakty apod. Možnost synchronizace s Google službama. Rozhraní bych rád klasiku přes program, optimálně pro KDE, ať to nevypadá "vyblitě". Ne webové rozhraní. S tím související i integraci do systému, takže notifikace apod.  Nevěděl by někdo o něčem? Vyzkoušel jsem některé programy z diskuse výše ale vše web a nebo mi nejedou. Systém je x86_64. Díky moc.

Zopper

  • *****
  • 715
    • Zobrazit profil
Re:Jaký PIM / Groupware?
« Odpověď #23 kdy: 12. 09. 2012, 14:01:34 »
No já nakonec asi stejně skončím s využitím kombinace Google Kalendář pro události, memotoo.com pro úkoly a sjednocené v kOrganizeru.
Jen pro synchronizaci s androidem se ten memotoo musí synchronizovat s Toodledo.com (u něj jsem nenašel možnost oboustrané synchronizace s korganizerem), protože přímo to umí akorát drahá aplikace, ale memotoo na ten Toodledo má přímo funkci.

Na ten toodledo se ještě podívám hlouběji, v premium verzi umí i více úrovní, což je právě důvod, proč jsem trval na korganizeru - ten je umí udržovat minimálně lokálně. :) Ale taky pak bude klíčové, jestli umí i stromovou strukturu synchronizovat.

K těm groupware co jsem zkoušel nahoře - Horde by bylo fajn, kdyby bylo funkční řešení synchronizace s korganizerem (akonadi). Nějaké postupy sice jsou, ale vyžaduje to vždy nějaký třetí program a ten je buď vyloženě mrtvý projekt, nebo jsou na něj návody na X verzí zpět.
No a u Zambry mi synchronizace úkolů blbla.

LKG

Re:Jaký PIM / Groupware?
« Odpověď #24 kdy: 12. 09. 2012, 18:58:53 »
Tak to máš říct hned, že chceš synchronizovat s KOrganizerem/Akonadi. Necpal bych ti exchange-kompatibilní řešení. Jestli chceš pořád vlastní server a nechceš platit za licence, pak je volba jasná - na poštu nech IMAP + nějaký web frontend (roundcube), a na zbytek použij třeba OwnCloud (umí CalDAV i CardDAV, kompatibilní s KOrganizerem), navíc umí ukládat soubory/fotky/whatever.

Synchronizace s androidem sice nebude tak pohodlná, ale CalDAV/CardDAV/IMAP by měl taky umět. iOS tohle řešení umí.

Zopper

  • *****
  • 715
    • Zobrazit profil
Re:Jaký PIM / Groupware?
« Odpověď #25 kdy: 13. 09. 2012, 10:24:11 »
Fakt asi neexistuje jednoduché řešení... O_o
OwnCloud se mi líbí, instalace je úžasně jednoduchá (nakopírovat do www a vyplnit údaje pro databázi a jede), sync do korganizeru taky v pohodě, ale zase ten android... Tam umí caldav úkoly snad jen jediná aplikace (aCal) a ta má tři hvězdičky asi jen proto, že je jediná. Takže té zamotanosti s Memotoo+toodledo jsem se stejně nezbavil - nicméně po funkční stránce tohle vypadá zatím nejlépe.

Rád bych tu dvojici pro android zredukoval, nevíte někdo o úkolové službě, která by měla aplikaci pro android a uměla se připojovat na calDav server?

Synchronizace kalendářů přímo by měl zvládnout program co stojí šedesát korun, což, pokud u téhle varianty skončím, klidně vezmu, ale bohužel neumí úkoly.

Zopper

  • *****
  • 715
    • Zobrazit profil
Re:Jaký PIM / Groupware?
« Odpověď #26 kdy: 13. 09. 2012, 19:10:25 »
Tak ještě poznámka, nakonec stejně používám na úkoly aCal, protože synchronizace přes Memotoo fungovala jen někdy. Jinak to vypadá všechno v pořádku - uvidím během příštích dnů. :D

Jackie

Re:Jaký PIM / Groupware?
« Odpověď #27 kdy: 24. 03. 2015, 09:54:48 »
Upozornil bych na programek EVO Collaborator for Outlook, ktery se muze nekomu hodit, pokud hledate neco na synchronizaci kalendare, kontaktu, a ukolu s Outlookem. Podporuje standardni CalDAV a CardDAV, takze bezproblemova podpora OwnCloud, Zimbra, Baikal, a dalsich.
Na tomto blogu jsem nasel popis nastaveni: http://pocitace-a-internet.blogspot.com/2015/03/jak-synchronizovat-kalendare-kontakty.html