reklama

Problém s kompilací jádra Debian Lenny

Debian Lenny Kernel

Problém s kompilací jádra Debian Lenny
« kdy: 18. 04. 2010, 05:32:48 »
Stahl jsem si jadro, opatchoval ho pripravenym patchem, pripadal soucasnou konfiguraci a při spuštění "make menuconfig" mi to vyhodí nasledující chyby a nějak nevím co s tím :-( :

debian:/usr/src/linux-2.6.26.8# make menuconfig
  HOSTCC  scripts/basic/fixdep
scripts/basic/fixdep.c:107:23: error: sys/types.h: není souborem ani adresářem
scripts/basic/fixdep.c:108:22: error: sys/stat.h: není souborem ani adresářem
scripts/basic/fixdep.c:109:22: error: sys/mman.h: není souborem ani adresářem
scripts/basic/fixdep.c:110:20: error: unistd.h: není souborem ani adresářem
scripts/basic/fixdep.c:111:19: error: fcntl.h: není souborem ani adresářem
scripts/basic/fixdep.c:112:20: error: string.h: není souborem ani adresářem
scripts/basic/fixdep.c:113:20: error: stdlib.h: není souborem ani adresářem
scripts/basic/fixdep.c:114:19: error: stdio.h: není souborem ani adresářem
In file included from /usr/lib/gcc/i486-linux-gnu/4.3.2/include-fixed/syslimits.h:7,
                 from /usr/lib/gcc/i486-linux-gnu/4.3.2/include-fixed/limits.h:11,
                 from scripts/basic/fixdep.c:115:
/usr/lib/gcc/i486-linux-gnu/4.3.2/include-fixed/limits.h:122:61: error: limits.h: není souborem ani adresářem
scripts/basic/fixdep.c:116:19: error: ctype.h: není souborem ani adresářem
scripts/basic/fixdep.c:117:23: error: arpa/inet.h: není souborem ani adresářem
scripts/basic/fixdep.c: In function ‘usage’:
scripts/basic/fixdep.c:131: warning: implicit declaration of function ‘fprintf’
scripts/basic/fixdep.c:131: warning: incompatible implicit declaration of built-in function ‘fprintf’
scripts/basic/fixdep.c:131: error: ‘stderr’ undeclared (first use in this function)
scripts/basic/fixdep.c:131: error: (Each undeclared identifier is reported only once
scripts/basic/fixdep.c:131: error: for each function it appears in.)
scripts/basic/fixdep.c:132: warning: implicit declaration of function ‘exit’
scripts/basic/fixdep.c:132: warning: incompatible implicit declaration of built-in function ‘exit’
scripts/basic/fixdep.c: In function ‘print_cmdline’:
scripts/basic/fixdep.c:140: warning: implicit declaration of function ‘printf’
scripts/basic/fixdep.c:140: warning: incompatible implicit declaration of built-in function ‘printf’
scripts/basic/fixdep.c: At top level:
scripts/basic/fixdep.c:143: error: ‘NULL’ undeclared here (not in a function)
scripts/basic/fixdep.c: In function ‘grow_config’:
scripts/basic/fixdep.c:156: warning: implicit declaration of function ‘realloc’
scripts/basic/fixdep.c:156: warning: incompatible implicit declaration of built-in function ‘realloc’
scripts/basic/fixdep.c:158: warning: implicit declaration of function ‘perror’
scripts/basic/fixdep.c:158: warning: incompatible implicit declaration of built-in function ‘exit’
scripts/basic/fixdep.c: In function ‘is_defined_config’:
scripts/basic/fixdep.c:174: warning: implicit declaration of function ‘memcmp’
scripts/basic/fixdep.c: In function ‘define_config’:
scripts/basic/fixdep.c:187: warning: implicit declaration of function ‘memcpy’
scripts/basic/fixdep.c:187: warning: incompatible implicit declaration of built-in function ‘memcpy’
scripts/basic/fixdep.c: In function ‘use_config’:
scripts/basic/fixdep.c:206: error: ‘PATH_MAX’ undeclared (first use in this function)
scripts/basic/fixdep.c:214: warning: incompatible implicit declaration of built-in function ‘memcpy’
scripts/basic/fixdep.c:220: warning: implicit declaration of function ‘tolower’
scripts/basic/fixdep.c:222: warning: incompatible implicit declaration of built-in function ‘printf’
scripts/basic/fixdep.c:206: warning: unused variable ‘s’
scripts/basic/fixdep.c: At top level:
scripts/basic/fixdep.c:225: error: expected declaration specifiers or ‘...’ before ‘size_t’
scripts/basic/fixdep.c: In function ‘parse_config_file’:
scripts/basic/fixdep.c:227: error: ‘len’ undeclared (first use in this function)
scripts/basic/fixdep.c:233: warning: implicit declaration of function ‘ntohl’
scripts/basic/fixdep.c:244: warning: implicit declaration of function ‘isalnum’
scripts/basic/fixdep.c: In function ‘strrcmp’:
scripts/basic/fixdep.c:261: warning: implicit declaration of function ‘strlen’
scripts/basic/fixdep.c:261: warning: incompatible implicit declaration of built-in function ‘strlen’
scripts/basic/fixdep.c: In function ‘do_config_file’:
scripts/basic/fixdep.c:272: error: storage size of ‘st’ isn’t known
scripts/basic/fixdep.c:276: warning: implicit declaration of function ‘open’
scripts/basic/fixdep.c:276: error: ‘O_RDONLY’ undeclared (first use in this function)
scripts/basic/fixdep.c:278: warning: incompatible implicit declaration of built-in function ‘fprintf’
scripts/basic/fixdep.c:278: error: ‘stderr’ undeclared (first use in this function)
scripts/basic/fixdep.c:280: warning: incompatible implicit declaration of built-in function ‘exit’
scripts/basic/fixdep.c:282: warning: implicit declaration of function ‘fstat’
scripts/basic/fixdep.c:284: warning: implicit declaration of function ‘close’
scripts/basic/fixdep.c:287: warning: implicit declaration of function ‘mmap’
scripts/basic/fixdep.c:287: error: ‘PROT_READ’ undeclared (first use in this function)
scripts/basic/fixdep.c:287: error: ‘MAP_PRIVATE’ undeclared (first use in this function)
scripts/basic/fixdep.c:287: warning: assignment makes pointer from integer without a cast
scripts/basic/fixdep.c:294: error: too many arguments to function ‘parse_config_file’
scripts/basic/fixdep.c:296: warning: implicit declaration of function ‘munmap’
scripts/basic/fixdep.c:272: warning: unused variable ‘st’
scripts/basic/fixdep.c: At top level:
scripts/basic/fixdep.c:301: error: expected declaration specifiers or ‘...’ before ‘size_t’
scripts/basic/fixdep.c: In function ‘parse_dep_file’:
scripts/basic/fixdep.c:304: error: ‘len’ undeclared (first use in this function)
scripts/basic/fixdep.c:306: error: ‘PATH_MAX’ undeclared (first use in this function)
scripts/basic/fixdep.c:308: warning: implicit declaration of function ‘strchr’
scripts/basic/fixdep.c:308: warning: incompatible implicit declaration of built-in function ‘strchr’
scripts/basic/fixdep.c:310: warning: incompatible implicit declaration of built-in function ‘fprintf’
scripts/basic/fixdep.c:310: error: ‘stderr’ undeclared (first use in this function)
scripts/basic/fixdep.c:311: warning: incompatible implicit declaration of built-in function ‘exit’
scripts/basic/fixdep.c:313: warning: incompatible implicit declaration of built-in function ‘memcpy’
scripts/basic/fixdep.c:314: warning: incompatible implicit declaration of built-in function ‘printf’
scripts/basic/fixdep.c:306: warning: unused variable ‘s’
scripts/basic/fixdep.c: In function ‘print_deps’:
scripts/basic/fixdep.c:343: error: storage size of ‘st’ isn’t known
scripts/basic/fixdep.c:347: error: ‘O_RDONLY’ undeclared (first use in this function)
scripts/basic/fixdep.c:349: warning: incompatible implicit declaration of built-in function ‘fprintf’
scripts/basic/fixdep.c:349: error: ‘stderr’ undeclared (first use in this function)
scripts/basic/fixdep.c:351: warning: incompatible implicit declaration of built-in function ‘exit’
scripts/basic/fixdep.c:355: warning: incompatible implicit declaration of built-in function ‘fprintf’
scripts/basic/fixdep.c:359: error: ‘PROT_READ’ undeclared (first use in this function)
scripts/basic/fixdep.c:359: error: ‘MAP_PRIVATE’ undeclared (first use in this function)
scripts/basic/fixdep.c:359: warning: assignment makes pointer from integer without a cast
scripts/basic/fixdep.c:366: error: too many arguments to function ‘parse_dep_file’
scripts/basic/fixdep.c:343: warning: unused variable ‘st’
scripts/basic/fixdep.c: In function ‘traps’:
scripts/basic/fixdep.c:378: warning: incompatible implicit declaration of built-in function ‘fprintf’
scripts/basic/fixdep.c:378: error: ‘stderr’ undeclared (first use in this function)
scripts/basic/fixdep.c:380: warning: incompatible implicit declaration of built-in function ‘exit’
make[1]: *** [scripts/basic/fixdep] Error 1
make: *** [scripts_basic] Error 2
« Poslední změna: 18. 04. 2010, 11:58:44 od Petr Krčmář »

reklama


Re: Problém s kompilací jádra Debian Lenny
« Odpověď #1 kdy: 18. 04. 2010, 12:02:42 »
Pro menuconfig jsou potřeba knihovny ncurses včetně hlavičkových souborů. Podle toho výpisu to vypadá, že právě tohle vám chybí. Doinstalujte si balíček ncurses-dev.

Zarofka.cz

Re: Problém s kompilací jádra Debian Lenny
« Odpověď #2 kdy: 18. 04. 2010, 21:05:58 »
Dekuju, nasel jsem v googlu ze mi asi chybi nejak knihovna a tak jsem nainstaloval co bylo potreba. Tohle mi to vypsalo pri instalaci ncurses-dev a jsem z toho nejakej zmatenej. :-(

debian:~# apt-get install ncurses-dev
Čtu seznamy balíků... Hotovo
Vytvářím strom závislostí
Čtu stavové informace... Hotovo
Pozn: Vybírám libncurses5-dev místo ncurses-dev
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
  libncurses5-dev: Závisí na: libc-dev
E: Poškozené balíky
debian:~# apt-get install libncurses5-dev
Čtu seznamy balíků... Hotovo
Vytvářím strom závislostí
Čtu stavové informace... Hotovo
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
  libncurses5-dev: Závisí na: libc-dev
E: Poškozené balíky
debian:~# apt-get install libc-dev
Čtu seznamy balíků... Hotovo
Vytvářím strom závislostí
Čtu stavové informace... Hotovo
Pozn: Vybírám libc6-dev místo libc-dev
Některé balíky nemohly být instalovány. To může znamenat, že požadujete
nemožnou situaci, nebo, pokud používáte nestabilní distribuci, že
vyžadované balíky ještě nebyly vytvořeny nebo přesunuty z Příchozí fronty.
Následující informace vám mohou pomoci vyřešit tuto situaci:

Následující balíky mají nesplněné závislosti:
  libc6-dev: Závisí na: libc6 (= 2.7-18lenny1) ale 2.7-18lenny2 se bude instalovat
E: Poškozené balíky
debian:~# apt-get install libc6
Čtu seznamy balíků... Hotovo
Vytvářím strom závislostí
Čtu stavové informace... Hotovo
libc6 je již nejnovější verze.
0 aktualizováno, 0 nově instalováno, 0 k odstranění a 0 neaktualizováno.
debian:~#

Fantomas

Re: Problém s kompilací jádra Debian Lenny
« Odpověď #3 kdy: 18. 04. 2010, 21:48:14 »
Doufam, ze kdyz pouzivas lennyho, tak mas povolene repozitare pouze pro lennyho. Jestli sis povolil repozitar pro squeeze a nektere balicky jsi uz nainstaloval z teto vetve, muze to delat problemy. Pokud mas jen lennyho, tak zkus "apt-get update" a pak "apt-get dist-upgrade", ten ti zrovna verze vsech balicku, ktere mas nainstalovane na posledni stabilni verzi. Ke kompilaci potrebujes nainstalovat jen tri klicove balicky: kernel-package, libncurses5-dev a gcc, zbytek dostanes diky zavislostem.

Zarofka.cz

Re: Problém s kompilací jádra Debian Lenny
« Odpověď #4 kdy: 18. 04. 2010, 22:09:46 »
Mam pouze lennyho. Gcc jsem si vcetne kernel-package nainstaloval. Zjistuju, ze mi nejka zlobi virtual ve kterem to testuju. Ted mi to vyhodilo ze nemuze stahnout nejake balicky  libncurses5-dev ktere jsou potrebne ke stazeni. Budu pokracovat doma, tady ta sit je nejaka divna :-(.. Zatim děkuji vsem za rady...

reklama


Zarofka.cz

Re: Problém s kompilací jádra Debian Lenny
« Odpověď #5 kdy: 18. 04. 2010, 22:30:42 »
Tak vypada, ze mirror ze ktereho jsem tahal je nejaky podivny, nastavil jsem jiny a uz se mi postahovalo vse potrebne, doma zkusim zda to bezi, nemam sebou nabijecku :-(. Jeste jednou diky...dam vedet....

Zarofka.cz

Re: Problém s kompilací jádra Debian Lenny
« Odpověď #6 kdy: 19. 04. 2010, 00:17:24 »
Tak už se to kompiluje.... děkuji za rady.

 

reklama