Instalace AMP serveru, nefungují skripty

fotka

  • ***
  • 216
    • Zobrazit profil
    • Linux forum
    • E-mail
Instalace AMP serveru, nefungují skripty
« kdy: 14. 04. 2010, 12:46:11 »
Ahoj, mám drobný problém. Instaloval jsem na Linux Apache, PHP, Mysql a ještě nějaké součásti podle TOHOTO návodu.

Vše nějak fungovalo a pak to najednou přestalo :). Po odeslání formuláře, nebo třeba jak je na PHPBB foru při registraci souhlas s podmínkami tak to nic neudělá. Při odeslání přihlašovacího formuláře se jen načte stránka znovu. Jistě to znáte.. Zde je PHP info serveru.

Nevím co s tím, napadá mě aplikovat výchozí nastavení apache, mysql a php. Poradil by mi prosím někdo jak to udělat například ze shellu. CO odinstalovat, co smazat v shellu? Mám CentOS 5.x

Yum reinstalace php, mysql, apache a těch přidružených programů nepomohla

Mám CentOS Linux 5.4 s Webmin.

Prosím poraďte jak na to.. Udělám cokoliv. Je to Unmanaged VPS.
« Poslední změna: 15. 04. 2010, 21:57:08 od fotka »
Linux nováček - CeskeForum.com


soyo

Re: Instalace AMP serveru, nefungují skripty
« Odpověď #1 kdy: 15. 04. 2010, 21:15:45 »
Ako prvy krok by som doporucoval zapnut display_errors = On v php.ini. Subor php.ini by sa mal povalovat niekde v /etc/php?... Potom by sa malo zobrazit nieco zmysluplne, ak dojde k chybe.. pripadne, ak to nebude vidno, moze to byt utopene vo vyslednom html.

fotka

  • ***
  • 216
    • Zobrazit profil
    • Linux forum
    • E-mail
Re: Instalace AMP serveru, nefungují skripty
« Odpověď #2 kdy: 15. 04. 2010, 21:53:37 »
Ako prvy krok by som doporucoval zapnut display_errors = On v php.ini. Subor php.ini by sa mal povalovat niekde v /etc/php?... Potom by sa malo zobrazit nieco zmysluplne, ak dojde k chybe.. pripadne, ak to nebude vidno, moze to byt utopene vo vyslednom html.
Děkuji za doporučení. V /etc/php.ini

je nastaveno:
error_reporting  =  E_ALL
display_errors = On

k tomu je tam ještě nápověda:
; possible values for display_errors:
;
; Off          - Do not display any errors
; stderr       - Display errors to STDERR (affects only CGI/CLI binaries!)   
; On or stdout - Display errors to STDOUT (default)

; To output errors to STDERR with CGI/CLI:             
;display_errors = "stderr"


ale stejnak to na tom PHPBB nic nezobrazuje. Jen se obnoví ten přihlašovací formulář. Je to tak u všech formulářů i u jiných skriptů.  :o Jako kdyby tam nebylo něco nainstalováno nebo co. Tohle se mi stávalo u starých skriptů když nebyla zapnuta register_globals.

Děkuji, 
F.
« Poslední změna: 15. 04. 2010, 21:55:44 od fotka »
Linux nováček - CeskeForum.com

PCnity

  • *****
  • 680
    • Zobrazit profil
    • E-mail
Re: Instalace AMP serveru, nefungují skripty
« Odpověď #3 kdy: 16. 04. 2010, 22:59:55 »
Edituj priamo index.php toho phpBB a vloz uplne hore pod <?php tento riadok:

error_reporting(E_ALL);

Samotne php.ini nic nepomoze pokial je zobrzovanie v kode vypnute.

PCnity

  • *****
  • 680
    • Zobrazit profil
    • E-mail
Re: Instalace AMP serveru, nefungují skripty
« Odpověď #4 kdy: 16. 04. 2010, 23:03:47 »
Este jednu vec sprav... Nahod si niekde "diagnostiku" a daj si cez prin_r vypisat cely obsah $_REQUEST... Priklad:

<?php
  print_r($_REQUEST);
?>

Potom na ten skript nieco posli POST metodou a pozri sa ci ti to zobrazi... Ako priklad co asi by si mal vidiet zavolaj ten skript GET metodou:

nazovskriptu.php?premenna1=hodnota1&premennaxy=r1234

Este som sa nestretol s prikladom ze by POST globalbalne nefungoval... Ale tak presvedcit sa nie je nikdy na skodu.