Přestal fungovat internet na Linuxu

Přestal fungovat internet na Linuxu
« kdy: 10. 03. 2023, 17:07:13 »
Posílám screenshot a mám dotaz. Na Windows mi internet jede a číslo brány mám 198.168.10.1 a ping z linuxu mi fungoval. Ale nemělo by to IP na bránu být jiné jako běžné IP?


« Poslední změna: 10. 03. 2023, 17:42:10 od Petr Krčmář »


Re:Přestal fungovat internet na Linuxu
« Odpověď #1 kdy: 10. 03. 2023, 19:31:25 »
Posílám screenshot a mám dotaz. Na Windows mi internet jede a číslo brány mám 198.168.10.1 a ping z linuxu mi fungoval. Ale nemělo by to IP na bránu být jiné jako běžné IP?

Takto je docela složité říct. Jestli funguje ping, tak se podívej do /etc/resolv.conf možná tam chybí nameserver, nebo nameserver ukazuje pouze na DNS servery, které nejsou přístupné.

Napadlo mě to, protože toto mi dělá VPN, když mi spadne počítač a musím ho resetovat. Do /etc/resolv.com pak dám na první řádek (dns Google)

nameserver 8.8.8.8



 

Re:Přestal fungovat internet na Linuxu
« Odpověď #2 kdy: 10. 03. 2023, 20:53:29 »
Vyřešil jsem. Zkusil jsem několik příkazů a asi zabral ten iptables -F
Nevím co přesně to dělá.
Ale je možné že to bylo tím náhlým restartováním. Jak mi na FreeSpire nefunguje pořádně grafika tak občas místo vypnout zmáčknu reset anebo to dělám násilím před VMPlayer, protože to tlačítko vypnout tam nikde nevidím.

Re:Přestal fungovat internet na Linuxu
« Odpověď #3 kdy: 11. 03. 2023, 13:03:43 »
Citace
                 --flush   -F [chain]          Delete all rules in  chain or all chains
pouze odhaduju:
TIpl bych še sis nainstaloval nějaký firewall a  ho nastavil že blokuje
Je to divné,  přidaná pravidla(příkazem) do iptables nepřežijí restart


chtělo by to udělat inventář firewallů, ufw,iptables, nftables, a tak

Re:Přestal fungovat internet na Linuxu
« Odpověď #4 kdy: 23. 03. 2023, 17:58:07 »
Citace
                 --flush   -F [chain]          Delete all rules in  chain or all chains
pouze odhaduju:
TIpl bych še sis nainstaloval nějaký firewall a  ho nastavil že blokuje
Je to divné,  přidaná pravidla(příkazem) do iptables nepřežijí restart


chtělo by to udělat inventář firewallů, ufw,iptables, nftables, a tak

Nejsem ajťák, takže těmto věcem ani nerozumím. Firewall vím co je. Na tom FreeSpiru Ubuntu asi 21 nebo 22 zabíral příkaz
Kód: [Vybrat]
dhclient -r
dhclient
iptables -F

někdy bez iptables a najelo to hned. Jenže teď mám Mint 20 a tam to nefunguje. Nejprve nejel internet, ale ping na bránu jo. Divné. Pak zkouším i restart PC a nic.

nakonec zkouším i
Kód: [Vybrat]
sudo service network-manager restarta ping na bránu není úspěšný. Nevidím bránu.

Kód: [Vybrat]
ifconfig -a
ens33: flags=4098<BROADCAST,MULTICAST>  mtu 1500
        ether 00:**:**:**:**:0*  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Místní smyčka)
        RX packets 788  bytes 59962 (59.9 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 788  bytes 59962 (59.9 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

Ještě se podívám na ten soubor jak jste psal.

Name server je 127.0.0.53

Na netu nacházím: "127.0.0.53 is the address of the local caching stub resolver. It forwards DNS requests to whatever upstream DNS servers you specify."
GT: "127.0.0.53 je adresa místního stub resolveru pro ukládání do mezipaměti. Předává požadavky DNS na jakékoli upstream servery DNS, které určíte."
co to je stub resolver?

A options edns0
« Poslední změna: 23. 03. 2023, 18:05:07 od exkalibr »


Re:Přestal fungovat internet na Linuxu
« Odpověď #5 kdy: 23. 03. 2023, 22:14:31 »
Po vypnutí VM a spuštění VMWare jako správce jsem zjistil, že brána je pod interfacem ens33. A ping funguje, internet funguje. Tak ale nechápu proč ikona "Síťové připojení" ukazuje, že internet není připojen... Ve VMWare je nastaveno přímé připojení přes Bridge, zažízení Realtec. Ale v linuxu je to zařízení vidět jako Intel. A

Kód: [Vybrat]
sudo inxi -Nn
ukáže:
Kód: [Vybrat]
$ sudo inxi -Nn
Network:
  Device-1: Intel 82371AB/EB/MB PIIX4 ACPI type: network bridge
  driver: N/A
  Device-2: Intel 82545EM Gigabit Ethernet driver: e1000
  IF: ens33 state: up speed: 1000 Mbps duplex: full
  mac:

k3dAR

  • *****
  • 2 830
  • porad nemam telo, ale uz mam hlavu... nobody
    • Zobrazit profil
    • E-mail
Re:Přestal fungovat internet na Linuxu
« Odpověď #6 kdy: 24. 03. 2023, 04:58:03 »
na zeleze mas Realtek, ale VMWare dava virtualu "imaginarni" Intel...
to ze mas "přímé připojení přes Bridge" neznamena ze priradit realnej HW virtualu, ale ze se ty 2 sitovky spoji pres most, misto aby je routoval/natoval...
prirazeni realneho HW by sice znamenalo ze virtual by videl primo hw ze zeleza, ale zaroven to zelezo by pri behu virtualu o ten hw prislo...

Re:Přestal fungovat internet na Linuxu
« Odpověď #7 kdy: 24. 03. 2023, 14:17:21 »
na zeleze mas Realtek, ale VMWare dava virtualu "imaginarni" Intel...
to ze mas "přímé připojení přes Bridge" neznamena ze priradit realnej HW virtualu, ale ze se ty 2 sitovky spoji pres most, misto aby je routoval/natoval...
prirazeni realneho HW by sice znamenalo ze virtual by videl primo hw ze zeleza, ale zaroven to zelezo by pri behu virtualu o ten hw prislo...

Co z toho, prosím, pro mě plyne? BTW: Zkoušel jsem to i přes ten NAT. V obou případech ikona neukáže spojení, ani když dám dhclient -r && sudo dhclient ... A mimochodem ten posledni dhclient vypisuje nejakou hlasku EOL v docasnem souboru. Zrovna si nepamatuju co presne, ale reálně internet funguje, i když se to nezobrazuje na ikoně. A nejde to ale nakonfigurovat. Zkoušel jsem přidat síťové nastavení přes to odborný dialogový okno pro přidání, kde jsem zadal název interfacu a na konfiguroval IPv4 ale to je zbytečný, to je furt to samý.

Hledal jsem konfigurační soubor pod /etc/network/?/ a není tam ani jeden konfigurák, tudíž předpokládám že příkaz sudo service network-manager restart taky nepomůže. Já že bych to tam natvrdo nakonfiguroval, kdybych věděl co napsat, ale myslím si že bránu by měl systém znát nebo být schopen zjistit automaticky. Nerozumím tedy tomu proč tomu tak není? Neměl by toto zajišťovat VMWare Tool software na straně linuxu? VMWare z Windowsu taky hlásí různé chyby na straně linuxu, jako že se nepodařilo nainstalovat podporu pro 3D akceleraci GPU, zvukovku atd. Tolik chyb to dříve nepsalo, až na Windows 8.1. Takže úplně to nechápu. Scházející podpora 3D akcelerace GPU to ano, to bylo i na XP. Ale u zvukovky ne. Na druhou stranu repráky jsou vypnutý a do dírek na předním panelu jsem žádné vstupy nezapojil... Já jen jestli toto všechno spolu nesouvisí. Nenašel jsem na Minutu kde je nějaký konfigurační prostředek. Podle článku na stránce VMWare se některé věci musí konfigurovat nebo doinstalovat ručně, jenže kde to jsem nezjistil. A to mě taky dost štve, protože vše jde nakonfigurovat, ale tady u VMWare nevidím žádný nainstalovaný manager pro správu ovladačů.

Díky moc k3dAR za snahu pomoci.  :)