QoS na 250M DSL lince

QoS na 250M DSL lince
« kdy: 20. 12. 2021, 16:46:04 »
Ahojte všichni, řeším QoS na naší 250/25 DSL lince a zatím se mi moc nedaří. Problém je, že mi routery při aktivování a nastavení této funkce „žerou" poměrně dost z rychlosti netu. Potřebuji trochu srazit a udržet nízké odezvy, kvůli on-line hraní Google Stadia, ale nechce se mi kvůli tomu obětovat 50-70 Mb/s z rychlosti. Mám Terminátora a za ním Tp-Link VR2100 a při aktivaci QoS dosahuje jen nějakých 170M, tak jsem zkusil Mikrotika RB750GR3 a při globálním QoS na celou síť je maximální rychlost ještě horší. Problém je zřejmě ve slabém HW routerů. Nechci kupovat nějaké předražené krámy s wifinou, protože mám bezdrát vyřešen několika Unifi APčkama. Máte někdo nějaký nápad, co pořídit, aby to uroutovalo s QoS 250M download bez zásadní ztráty rychlosti? Ještě se dá postavit výkonný router z Rpi4 s Openwrt, ale nevím, jestli je to dobrý nápad.


David

  • ***
  • 105
    • Zobrazit profil
Re:QoS na 250M DSL lince
« Odpověď #1 kdy: 20. 12. 2021, 17:36:20 »
Čeho konkrétně chcete dosáhnout tím QoS, co to má řešit?

Re:QoS na 250M DSL lince
« Odpověď #2 kdy: 20. 12. 2021, 18:30:10 »
Dobrý den,
myslím si že to co hledáte je qos např přes DSCP, mam podobné potřeby řešeny přes Mikrotik jako bránu která vytáčí ppoe O2 VDSL a s GforceNow (cloud gaming) stramem.
Aplikace generuje ve streamu packety s DSCP číslem, na Mikrotik má tento provoz přednost před ostatním.

Nevím jak Stádia, muselo by se okoukat ve wiresharku jestli pakety značkuje, pak by to takhle šlo.
Ale nenapsal jste co máte na bráně takže těžko radit.

Re:QoS na 250M DSL lince
« Odpověď #3 kdy: 20. 12. 2021, 19:27:43 »
Chtěl bych dosáhnou minimální latence kvůli hraní online her a celkově mít možnost různým klientům přiřadit různou šířku pásma. Ping bez zatížení je 9-10ms, ale při zátěži stoupá a pro hraní to není ideální. Teď testuji Mikrotika RB750G3, který je za terminátorem od Cetinu. Stadia jede na portech 44700-44899, tak se je snažím prioritizovat a snížil jsem maximální rychlost, abych dosáhl nižší latence. Teď to mám takto a zdá se, že je to funkční. Rychlost internetu se v tomto připadě snížila jen nepatrně cca na 220M. QoS na celé síti moc tímto Mikrotikem řídit nelze, protože pak rychlost padne někam ke 140M, i když k internetu přistupuje jen jeden klient.

/ip firewall mangle
add action=mark-packet chain=prerouting dst-port="" new-packet-mark=stadia \
    passthrough=no port=44700-44899 protocol=udp
add action=mark-packet chain=prerouting new-packet-mark=stadia1 passthrough=\
    no port=44700-44899 protocol=tcp
/queue simple
add max-limit=20M/80M name="stadia googleTV" packet-marks=stadia,stadia1 \
    queue="QOS fq codel/QOS fq codel" target=bridge

Re:QoS na 250M DSL lince
« Odpověď #4 kdy: 20. 12. 2021, 20:04:00 »
Chtěl bych dosáhnou minimální latence kvůli hraní online her a celkově mít možnost různým klientům přiřadit různou šířku pásma. Ping bez zatížení je 9-10ms, ale při zátěži stoupá a pro hraní to není ideální. Teď testuji Mikrotika RB750G3, který je za terminátorem od Cetinu. Stadia jede na portech 44700-44899, tak se je snažím prioritizovat a snížil jsem maximální rychlost, abych dosáhl nižší latence. Teď to mám takto a zdá se, že je to funkční. Rychlost internetu se v tomto připadě snížila jen nepatrně cca na 220M. QoS na celé síti moc tímto Mikrotikem řídit nelze, protože pak rychlost padne někam ke 140M, i když k internetu přistupuje jen jeden klient.

/ip firewall mangle
add action=mark-packet chain=prerouting dst-port="" new-packet-mark=stadia \
    passthrough=no port=44700-44899 protocol=udp
add action=mark-packet chain=prerouting new-packet-mark=stadia1 passthrough=\
    no port=44700-44899 protocol=tcp
/queue simple
add max-limit=20M/80M name="stadia googleTV" packet-marks=stadia,stadia1 \
    queue="QOS fq codel/QOS fq codel" target=bridge

Myslím že to máte v principu správně, jen máte tu frontu na bridge ale měla by být na odchozí interface timhle si zpomalujete provoz v LAN, problém ale je že DSL nemáte symetrické. Download upload..
Vyřešíte tím jen provoz který jde od Vás ven, ale u asymetrické linky se snižuje download když někdo cokoli odesílá což muže způsobit, že i tak vylítnou latence když bude stadia v prioritě.

Pokud jde o nesymetrickou linku tak myslím že nic lepšího nevymyslíte.
Já to řeším přes DSCP v rámci sitě a měnim DSCP u paketů odchozích a doufám že něco dál tento mechanizmus respektuje. Mohu ale jen doufat. Každopádně to funguje určitě lepe než když tam nic takového nebylo.


Re:QoS na 250M DSL lince
« Odpověď #5 kdy: 21. 12. 2021, 11:34:49 »
Jediné "levné QoS" je v podobě switche se 100 Mbps porty.

Re:QoS na 250M DSL lince
« Odpověď #6 kdy: 21. 12. 2021, 14:12:14 »
Ahojte všichni, řeším QoS na naší 250/25 DSL lince a zatím se mi moc nedaří. Problém je, že mi routery při aktivování a nastavení této funkce „žerou" poměrně dost z rychlosti netu. Potřebuji trochu srazit a udržet nízké odezvy, kvůli on-line hraní Google Stadia, ale nechce se mi kvůli tomu obětovat 50-70 Mb/s z rychlosti. Mám Terminátora a za ním Tp-Link VR2100 a při aktivaci QoS dosahuje jen nějakých 170M, tak jsem zkusil Mikrotika RB750GR3 a při globálním QoS na celou síť je maximální rychlost ještě horší. Problém je zřejmě ve slabém HW routerů. Nechci kupovat nějaké předražené krámy s wifinou, protože mám bezdrát vyřešen několika Unifi APčkama. Máte někdo nějaký nápad, co pořídit, aby to uroutovalo s QoS 250M download bez zásadní ztráty rychlosti? Ještě se dá postavit výkonný router z Rpi4 s Openwrt, ale nevím, jestli je to dobrý nápad.

QoS jako takový je dost náročný na CPU. U Mikrotiku je QoS pocitany na CPU, proto tak špatné výsledky. Mikrotik RB750GR3 má 2x880Mhz MIPS cpu s hardware NAT supportem, nic dalšího od toho nečekejte. Pokud to s QoSem myslíte vážně a chcete třeba u Mikrotiku zůstat, kupte nějakou x86 krabičku atom/celeron, kupte do toho licenci mikrotiku a je to. Dlouho do budoucna nemusíte nic řešit.

Re:QoS na 250M DSL lince
« Odpověď #7 kdy: 21. 12. 2021, 17:00:50 »
Mikrotik na tuto rychlost opravdu nestačí. Ještě jsem s tím včera laboroval a vrátil jsem se zatím k Tp-Linku, protože to řízení provozu zvládá mnohem lépe. Naházel jsem klienty do třech různých priorit a zkusil při hraní na Stadii z jiného zařízení měřit rychlost na speedtest, a žádné rozpadání a záseky obrazu se už nekonají. Přitom VR2100 nemá asi také žádný zázračný chipset. Kouknu ještě na tu možnost Intelu + RoterOS, nebo ještě testnu to Rpi4 + Openwrt.

Medo77

  • ***
  • 212
    • Zobrazit profil
    • E-mail
Re:QoS na 250M DSL lince
« Odpověď #8 kdy: 21. 12. 2021, 20:11:06 »
K takymto vysokym rychlostiam sa nevyjadrim ani praxou ani vykom cipu v MKT.
Simple sme nikdy jaksi uspokojivo neodladili, presli sme na queue tree.
Nikdy nesmies vyzrat celu dostupnu sirku pasma (v sucte), nechaj tam malicku rezervu na reziu. Plati zvlast pre asymetriu, cize citlivy je viac upload. Ak mas napr. 80/20, nech je global queue 79/19,5 (vytiahol som z brucha). Skusenosti hovoria, ze na nie biznis linkach je rezerva na reziu citelna.

Re:QoS na 250M DSL lince
« Odpověď #9 kdy: 22. 12. 2021, 21:03:42 »
Vyssi odezva pri zatizeni %dsl linky neni dana routingem ani v modemu ani mikrotiku a ani jinde. Je to jen a pouze vlastnost teto technologie. Technologicky limit. Muzes qosovat jak chces...

Medo77

  • ***
  • 212
    • Zobrazit profil
    • E-mail
Re:QoS na 250M DSL lince
« Odpověď #10 kdy: 23. 12. 2021, 09:41:14 »
Rad sa poucim, ak to rozvedies.
Ako to vidim z praxe ja.
Linka ma svoje nazvem to limity, a pokial neatakujes 100% toho, co ukazuje modem (Alebo toho, co dokazes namerat) a pocitas s nejakou chybovostou (to je ta rezia), tak to chodi celkom uspokojivo. Je pravda, ze sme neskusali hry, ale primarne a vyhradne RDP (a na to naviazane periferie ako citacky ciarovych kodov, tlaciarne, pl.terminaly).  Dslko si zije svojim zivotom v realnom case, musis tu reziu suplovat zanho, kedze kvalita linky sa moze menit. Potom ti to lieta hore-dolu. Ak zalimitujes svoj strop na jeho spodnej dosiahnutelnej hranici, tak je jedno ako linka poskakuje, proste drzi. (nepocitame vyraznu chybovost na linke prekracujucu povedzme 10%, alebo nebodaj uplny signal lost).
(preto nedosiahnes max linky, ale zmieris sa s par percentami dolu na ukor stability).
Bolo uplne jedno, ze dovtedy napr sync Onedrivu vyzral pasmo, a RDP islo do kytek, po nasadeni si RDP chrumkalo, a Onedrive dostal len tolko, co ostalo ...
A ako vravim, na rezervu je viac citlivy Upload. Neposles dostatocne rychlo potvrdenie paketu druhej strane, nedostanes dalsie data - lag ...

Ale mozno sa uplne a celkom mylim ... :-)

Re:QoS na 250M DSL lince
« Odpověď #11 kdy: 23. 12. 2021, 16:25:45 »
Na upload na DSLku VELMI pomaha nasadit Codel nebo Cake. V pripade zatizeni linky pak dochazi k rovnomernejsimu rozdeleni provozu i bez shapingu rychlosti. Shaping rychlosti lze nasadit navic k tomu codelu/caku, cimz dosahnete jeste lepsich parametru (nedojde k uplne saturaci upstreamu).

armyk

Re:QoS na 250M DSL lince
« Odpověď #12 kdy: 24. 12. 2021, 11:08:27 »
QoS je docela hit na vykon. Dost zalezi co zarizeni zvladne, mam ERX ktere mi na 100mbit staci, na vyssi je potreba vykonejsi zarizeni. Taky bych doporucil fqcodel. Bohuzel si nemysoim, ze je “levny” router co zvladne QoS s 200mbit plus.

Re:QoS na 250M DSL lince
« Odpověď #13 kdy: 27. 12. 2021, 15:15:51 »
Čekám na Rpi4 4GB, která by s Openwrt měla mé požadavky hravě zvládat. Adaptér USB 3.0 na ethernet se mi už válí doma, tak dám pak vědět jak to funguje.

Re:QoS na 250M DSL lince
« Odpověď #14 kdy: 29. 12. 2021, 10:16:50 »
Tak od včerejšího večera malina nakonfigurována a jede opravdu skvěle. Použil jsem Openwrt build od wulfy23, ve kterém je spousta dalších příjemných fičur. Driver rtl8152 již obsažen, takže adaptér stačilo jen zapojit a přidat WAN rozhraní s PPPoE a na eth1 přidat VLAN ID 848. Dále jsem aktivoval SQM, nastavil DL a UL, a rychlost se snížila jen o cca 10/1 na 240/24 Mbps. Odezva je i při zátěži stále pěkně nízká, takže pecka! Je to možná trochu overkill, ale alespoň je rezerva do budoucnosti.