Problém s audiem Xubuntu, samovolné přepínání výstupu, zavazbení

Mám otravný problém se zvukem na svém počítači.
Jedu na Xubuntu 20.04, nyní čerstvě přeinstalovaném. Možná se jedná o dva problémy, nevím zda to spolu souvisí  :)

Hardware:
MB ASROCK B450M PRO4 .
Zvuková karta je integrovaná na základní desce, jedná se o Realtek ALC892 Audio Codec.
CPU AMD Ryzen 5 2600, 3,9 GHz (AM4)
VGA AMD Sapphire PULSE RADEON RX 550

1. Stává se mi, že zvuk začne chytat vazbu, nevím jak to lépe popsat. Vše funguje jak má, a k tomuto jevu dochází když spustím některé aplikace (jen někdy) například dosovou hru. Také k tomu dochází, když ve Firefoxu zobrazím některé webové stránky (tipuji že se spustí nějáký skript co dělá něco s audiem). Pomůže pouze restart alsy (sudo alsa force-reload).
Zdá se mi, že tento problém se začíná vyskytovat čím dál tím častěji, několikrát za den. Dříve bylo potřeba resetovat alsu jen v jednom z deseti případů, v nastavení bylo vidět, že jsou obě zvukovky vypnuté. Případně bylo potřeba přepnout audio výstup (analog stereo output /analog stereo duplex). Mám pocit, že tento problém jsem měl už od začátku, počítač mám cca rok a půl. Jen se to vyskytuje čím dál tím častěji, a mám pocit že se to zhoršilo po nějaké aktualizaci.

2. Audio chci pouštět pouze přes jack. Zároveň mám jeden z monitorů připojený přes HDMI. Když zapnu monitor připojený přes HDMI, dojde ve volume control k vypnutí integrované zvukové karty, a zapnutí zvukovky která je součástí grafické karty. Aby zvuk opět fungoval, musím je ručně přepnout. Dochází k tomu i při uspání a probuzení monitoru.

Nevím jestli jsem to správně popsal, chová se to zvláštně. Na internetu jsem k tomu nic moc nedohledal, možná kladu špatné dotazy...


k3dAR

  • *****
  • 2 147
  • porad nemam telo, ale uz mam hlavu... nobody
    • Zobrazit profil
    • E-mail
ad 2. leva mys nad repro ikonkou na liste, Smesovac zvuku, Nastaveni, "blabla HDMI" - Profil=Vypnuto

ad 2. leva mys nad repro ikonkou na liste, Smesovac zvuku, Nastaveni, "blabla HDMI" - Profil=Vypnuto

Problém je že se sám pokaždé znovu zapne s rozsvícením monitoru. Taky to neřeší problém se zpětnou vazbou. Ale díky.