Copy failed with: fopen() failed

Copy failed with: fopen() failed
« kdy: 17. 08. 2021, 14:57:28 »
I have an issue with copying big files (size between 100GB ~ 2TB) to the external USB storage. It's directly connected to a USB3 port and mounted via /etc/fstab as XFS with rw, auto, user, sync options. Drive sleep is disabled and put also a refresh script to prevent drives to go to sleep mode. As I mentioned is XFS formatted partition, enabled for anyone to write/read/execute. It's running on Ubuntu Server 20.04 LTS fully patched. I tried also a manual copy file to the drive with cp and also rsync, it stops around 50~75% of the process and the drive gets disconnected. I can't find the reason for this behavior. Drives are inside IcyBox with 4 bays and are connected via USB3 cable to USB3 port. Other drives inside the box are accessible, just that one, where I tried to copy the plot is out of the system. After restart is the drive back, but without any changes, nothing is copied onto. I also tried other formats like XFS, NTFS, BRTFS... no effect. I disabled also caching (just for try), but is has no effect on the copy process (exept it took very long time). Source drives are NVMe's with XFS partition, the destination is SATA drive with XFS partition inside external USB IcyBox.

Any idea?

Source drives: 1 TB NVMe, single XFS partition
Destination drives: 14 TB Wester Digital SATA Red, single XFS partition


  • *****
  • 2 538
    • Zobrazit profil
    • E-mail
Re:Copy failed with: fopen() failed
« Odpověď #1 kdy: 17. 08. 2021, 15:22:33 »
0) what does dmesg say before disconnect?
1) disable (blacklist) UASP for your usb-sata bridge
2) don't use USB