Exchange 2016 - IMAP/SMTP Auth port 587

Gufo

Exchange 2016 - IMAP/SMTP Auth port 587
« kdy: 04. 08. 2021, 21:43:48 »
Ahoj,

nedari si mi autentifikovat uzivatela na porte 587 (Client Frontend Connector) pre IMAP/SMTP.

opravnenia na connector su nasledovne:

Kód: [Vybrat]
User                             ExtendedRights                                   
----                             --------------                                   
NT AUTHORITY\ANONYMOUS LOGON                                                       
NT AUTHORITY\ANONYMOUS LOGON                                                     
NT AUTHORITY\ANONYMOUS LOGON     {ms-Exch-Create-Public-Folder}                   
NT AUTHORITY\ANONYMOUS LOGON     {ms-Exch-Store-Create-Named-Properties}           
NT AUTHORITY\Authenticated Users                                                 
NT AUTHORITY\Authenticated Users      {ms-Exch-Accept-Headers-Routing}                 
NT AUTHORITY\Authenticated Users      {ms-Exch-SMTP-Accept-Any-Recipient}               
NT AUTHORITY\Authenticated Users      {ms-Exch-Bypass-Anti-Spam}                       
NT AUTHORITY\Authenticated Users      {ms-Exch-SMTP-Accept-Authoritative-Domain-Sender}
NT AUTHORITY\Authenticated Users      {ms-Exch-SMTP-Submit}                           
NT AUTHORITY\NETWORK SERVICE      {ms-Exch-EPI-Token-Serialization}                 
NT AUTHORITY\NETWORK SERVICE                                                     
NT AUTHORITY\SYSTEM                                                               
NT AUTHORITY\SYSTEM                       {ms-Exch-Recipient-Update-Access}                 
NT AUTHORITY\SYSTEM

SMTP Client vyhodi chybu:  Your email server rejected your login name.

Certifikat pre connector je prideleny spravne.

Client Frontend Connector log je v prilohe.

Ked prehodim autentifikaciu na port 465 (Client Proxy connector), authentifikacia funguje.
Je na to prosim nejake racionalne vysvetlenie?

Vdaka za kazdu rozumnu radu :)
« Poslední změna: 04. 08. 2021, 21:59:28 od Petr Krčmář »


Dadko

Re:Exchange 2016 - IMAP/SMTP Auth port 587
« Odpověď #1 kdy: 05. 08. 2021, 09:08:36 »
V tych cervenych zvyraznenych riadkoch by som asi hladal odpoved. Je to tam napisane, ze je chybna konfiguracia serveru a ziada to nejake opravnenie. Pomocou AUTH LOGIN sa predsa uzivatelovi podari prihlasit, aspon ako to tam vyplyva.

5nik

Re:Exchange 2016 - IMAP/SMTP Auth port 587
« Odpověď #2 kdy: 05. 08. 2021, 09:30:55 »
Co ti vrátí
Kód: [Vybrat]
Get-ReceiveConnector -Identity 'Client Frontend Connector' | select AuthMechanism,PermissionGroups ? V PermissionsGroups by měl být ExchangeUsers, máš je tam?

Gufo

Re:Exchange 2016 - IMAP/SMTP Auth port 587
« Odpověď #3 kdy: 05. 08. 2021, 13:29:03 »
Ano, ExchangeUsers tam samozrejme su. To vypliva uz z prveho prispevku.
NT AUTHORITY\Authenticated Users  patria do skupiny Exchange Users.

Kód: [Vybrat]
Get-ReceiveConnector -Identity 'Client Frontend Connector' | FL AuthMechanism,PermissionGroups
AuthMechanism    : Tls, Integrated, BasicAuth, BasicAuthRequireTLS
PermissionGroups : ExchangeUsers, Custom

Co je ale velka sranda, ze na porte 465 (Client Proxy - Transport Service (Obodoba Hub-u)) AUTH funguje. Pritom v doc MS je napisane, ze SMTP client nekominukuje s konektorom.

Citace
The TransportRole property value on theses connectors is HubTransport. Clients don't directly connect to these connectors.