RPi Zero W s RetroPie nefunguje dobře a zamrzá

Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #15 kdy: 17. 02. 2021, 16:54:42 »
Pavouk106:
Příkaz less /dev/shm/runcommand.log mi nefunguje. Nejdřív mi to psalo No such file or directory: http://imgway.cz/v/1AS1.jpg Teď toto: http://imgway.cz/v/1AS2.jpg


Cpu před spuštěním hry: http://imgway.cz/v/2qTL.jpg
Cpu po spuštění hry: http://imgway.cz/v/2qTM.jpg
State: http://imgway.cz/v/2qTN.jpg
PID: http://imgway.cz/v/1AS0.jpg


Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #16 kdy: 17. 02. 2021, 17:09:21 »
Michal Šiman:
Pi3+ jsem nechtěl kvůli spotřebě, chci ho napájet z usb v tv. Jasně výrobce doporučuje zdroj 1.2A ale nezdá se že by to bylo zdrojem. Žádný dvě usb zařízení připojené nemám. Ovladače jedou přes BT jak jsem už psal a proto také Zero W a ne jen Zero. A wifi abych ho mohl ovládat přes ssh a ne usb klávesnicí, stahovat aktualizace… Karty jsem zkoušel dvě a 16GB Adata je na cestě ale jestli bude origo nevím. Zero by prý po přetaktování mělo v pohodě utáhnout 16bit hry (video v prvním příspěvku) a ty novější už mě moc nezajímají takže další důvod pro Zero.

Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #17 kdy: 17. 02. 2021, 17:18:48 »
IDontCare:
Pořád nechápu potřebuji vysvětlit podrobněji jsem dost nechápaví. Nezatížený cpu (4%) má 63, po spuštění hry (100%) klesne teplota na 53. Vždycky když na něčem zvýším zátěž (motor, tranzistor, tělo…), zvedne se i teplota. Tady je to obráceně.

Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #18 kdy: 18. 02. 2021, 09:14:23 »
Michal Šiman:
Pi3+ jsem nechtěl kvůli spotřebě, chci ho napájet z usb v tv. Jasně výrobce doporučuje zdroj 1.2A

Pokud nejste schopny akceptovat ze kazde zarizeni potrebuje svuj zdroj spravny, pak vam neni pomoci. USB v TV je na flasku, ma maximalni zatizitelnost 500mA (stejne jako vetsina USB poprtu vsude). Pokud k tomu rpi pripojujete dalsi periferie, tak sa mu samozrejme zveda odber staly, nehlede na ten spickovy. Zdroj musi byt hlavne silny, problem je, ze se vzrustajicim proudovym odberem klesa u tech mekym zdroju napeti a to ma proste vliv na SD kartu a nasledne na chod celeho ekosystemu. Ano, bude to fungovat, ale je to cesta do pekel. RPI se nenapaji ani nabijeckou ani z TV. Ale delejte jak chcete. Ta volba je na vas samozrejme.

k3dAR

  • *****
  • 1 845
  • porad nemam telo, ale uz mam hlavu... nobody
    • Zobrazit profil
    • E-mail
Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #19 kdy: 18. 02. 2021, 14:43:51 »
kdyz nepomahaji rady, tak zkusime doporuceni vyrobce ;-)
pro "Raspberry Pi Zero W/WH" zdroj 5.1V a >=1.2A

obecne je to tak, ze pokud jakekoliv RPi s horsim nez doporucovanym zdrojem funguje OK, tak OK, pokud ale je jakejkoliv problem VZDY je v prvni rade potreba zkusit to z >=doporucenym_zdrojem...


Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #20 kdy: 19. 02. 2021, 08:09:48 »
kdyz nepomahaji rady, tak zkusime doporuceni vyrobce ;-)
pro "Raspberry Pi Zero W/WH" zdroj 5.1V a >=1.2A

obecne je to tak, ze pokud jakekoliv RPi s horsim nez doporucovanym zdrojem funguje OK, tak OK, pokud ale je jakejkoliv problem VZDY je v prvni rade potreba zkusit to z >=doporucenym_zdrojem...

 :) pozor, jeste je treba pripocitat +500 mA na kazde pripojene zarizeni (idealne) - a ano, joypad je pripojene zarizeni (i kdyz samozrejme nemusi brat a pravdepodobne nebere tolik).

SB

  • ***
  • 193
    • Zobrazit profil
    • E-mail
Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #21 kdy: 19. 02. 2021, 10:27:05 »
...RPI se nenapaji ani nabijeckou ani z TV...

Vy jste nikdy neslyšel o dvouampérových nabíječkách?

Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #22 kdy: 20. 02. 2021, 07:16:13 »
Vy jste nikdy neslyšel o dvouampérových nabíječkách?

Jasně že jsem slyšel o nabíječkách a ne jen dvou ampérových, ale jak správně píšete, o nabíječkách - to je něco trošku jinačího než napáječ, resp. napájecí zdroj. Nabíječky v sobě mohou mít nějakou další logiku (například CCCV) kdy prostě z principu se chovají jinak než zdroje. Pro napájení jakéhokoliv zařízení, doporučuji zdroj, nikoliv nabíječku. Ale ano, za jistých okolností může nabíječka být zdrojem, a zdroj nabíječkou, to máte pravdu, do auta taky občas někdo leje vyjetej olej a ono to na to jede.

Pavouk106

  • *****
  • 2 337
    • Zobrazit profil
    • Můj blog
    • E-mail
Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #23 kdy: 20. 02. 2021, 10:12:49 »
Netřeba se dohadovat... "Nabíječka" je v tomto kontextu myšleno napájecí zdroj k mobilu s výstupem USB. Tj. 5V a nějaký maximální proud.

RPi Zero (ne W) si bere do 250mA s připojeným 3,5" LCD. Ale pro klid bych to rozhodně zkusil z dobré powerbanky nebo ještě lépe z pořádného zdroje ("nabíječky").

K těm výpisům - Genesis vytěžuje CPU naplno. Zkus ještě poslat výpis s htop (CPU%) ve chvíli, kdy to zamrzne. Zajímá nás, jestli tam bude nahoře vidět genesis nebo emulationstation.

Pokud tam nebude ani genesis, ani emulationstation, zkus poslat výpis příkazů ps -ef |grep genesis a ps -ef |grep emulationstation

Ten runcommand.log musís zkusit ve chvíli, kdy běží nějakej emulátor nebo poté, co jsi ho vypnul (než zapneš další). Je to dočasnej log, kterej existuje jen v době, kdy hraješ/dohrál jsi.

Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #24 kdy: 22. 02. 2021, 20:34:50 »
Powerbanka 10000mAh, kterou bez problémů krmím 10“ tablet a nic. Vyzkoušel jsem i několik nabíjecích kabelů, nic. Pak přišel na řadu ATX zdroj 5V/25A a kupodivu zase nic.

Chlazení: http://imgway.cz/v/1B5u.jpg Mezi chladičem a cpu je měděná destička + MX2, teplota po hodině hraní nevylezla přes 35 stupňů. Ale na funkci Rpi se to nijak neprojevilo = ZDROJEM A CHLAZENÍM TO NENÍ TAK UŽ TO NEŘEŠTE!!

Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #25 kdy: 22. 02. 2021, 20:36:25 »
Pavouk106:
Genesis už nepoužívám právě protože cpu vytěžuje na 100%. Jako default emulátor jsem nastavil picodrive a sega už chodí stejně jako SNES = dá se to hrát ale seká se zvuk.

Takže potřebuji vyřešit to sekání zvuku a nesnesitelně dlouhé spouštění hry (kolem 20s).


Ono to nezamrzne během hry ale už při spuštění RPi když config upravím takto:
arm_freq=1085
gpu_freq=530
over_voltage=2
core_freq=515
sdram_freq=533
over_voltage_sdram=1

Potom:
htop: http://imgway.cz/v/1B5z.jpg
ps -ef: http://imgway.cz/v/1B5A.jpg

Re:RPi Zero W s RetroPie nefunguje dobře a zamrzá
« Odpověď #26 kdy: 22. 02. 2021, 20:56:03 »
Po chvilce zamrze i když config upravím podle toho videa z úvodu:
arm_freq=1050
gpu_freq=500
core_freq=500
sdram_freq=500
sdram_schmoo=0x02000020
over_voltage=2
sdram_over_voltage=2


V Htop a ps -ef |grep emulationstation v podstatě to samé jako jsem posílal v předchozím příspěvku.

Ještě jsem zkoušel něco najít na zahr. fórech a někdo taky psal že se to prostě musí přetaktovat jinak se ten zvuk bude sekat. Jestli se zrychlí načítání her nikde nepsali.

Takže bych se zaměřil na to přetaktování. Jak na to? Jak je vidět pouhé přepsání řádku 43 v config nestačí.