WvDial funguje až po připojení USB

WvDial funguje až po připojení USB
« kdy: 31. 05. 2011, 10:55:26 »
Zdravim.

Na internet sa pripajam pomocou mobilu SE k550i. Po pripojeni k systemu cez USB kabel sa za chvilu zobrazi v networkmanager-i nova siet (O2 internet), ktoru ked vyberiem, pripojim sa k internetu a vsetko funguje.
Ak sparujem zariadenie cez Blueman (Seriove porty -> sluzba vytacane spojenie), Blueman oznami, ze sa mozem pripojit teraz cez networkmanager, ale v networkmanager-i sa nezobrazi ziadna siet. V niektorej z mojich tem bola odpoved, ze to je bug networkmanager-u. Tak som pripojenie cez bluetooth rozbehal cez wvdial, avsak je tu jeden zadrhel.

1. otvorim blueman
2. vyberiem seriove porty -> sluzba vytacanie spojenie, tym sa sparuje zariadenie s notebookom
3. do terminalu napisem "wvdial blue" (ako root) a spojenie sa vytoci, nacitaju sa ip adresy, ale nefunguje internet (ani ping, ani ziadna stranka, nic).

Avsak, ak sa pripojim najprv cez USB kabel cez networkmanager, nasledne spojenie odpojim a potom vykonam kroky 1-3, spojenie funguje.
Skusal som wvdial aj cez USB-kabel, ale deje sa to iste, ako v pripade bluetooth, teda spojenie sa vytoci, nacitaju sa IP adresy, ale internet nefunguje, dokial sa nepripojim cez NM.
Cize, na to, aby internet fungoval cez wvdial (USB, Bluetooth), musim sa predtym pripojit a odpojit cez networkmanager, inak internet cez wvdial nefunguje.

Postupoval som podla tohto navodu: http://www.abclinuxu.cz/hardware/pripojeni-na-sit/gprs-gsm/samsung-sgh-j700

Konfiguracny subor wvdial.conf
Kód: [Vybrat]
[Dialer Defaults]
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,"IP","o2internet"
Modem Type = USB Modem
Baud = 460800
Modem = /dev/ttyACM0
ISDN = 0
Phone = *99#
Password = ''
Username = ''
Stupid Mode = yes

[Dialer blue]
Modem = /dev/rfcomm1
« Poslední změna: 31. 05. 2011, 11:11:23 od Petr Krčmář »
OS: Debian Testing 64bit, Kernel 3.16, GNOME 3.14/3.16
NB: Lenovo G550, Intel Pentium Dual-Core T4200 2.0GHz, RAM 3GB 1066MHz, Samsung SSD 250GB, Intel GMA X4500 256MB