reklama

VPN na routeru - připojení přes místní raspberry pomocí ssh tunelu

Ahoj,

snažím se zřídit domácí vpn pomocí openvp

na routeru TPLINK Archer C6 jsem spustil openvpn server, toto funguje, z počítače v místní síti se na portu 1194 můžu do VPN připojit

potřebuji ovšem zřídit přístup "z venku", nemám veřejnou IP, napadlo mě pomocí SSH přesměrovat porty na mém VPS přes domácí raspberry na router, toto jsem provedl takto (tady už si nejsem jistý jestli je to správně):

/usr/bin/autossh -f -N -M 20020 -R *:9494:ROUTER_IP:1194 VPS_USER@VPS_IP

na VPS se port 9494 jeví jako otevřený

jakékoli pokusy se do vpn přes VPS_IP na portu 9494 připojit ovšem nefungují, openvpn client neustále restartuje pokus o připojení

konfigurace klienta:

client
dev tun
proto tcp-client
float
nobind
cipher AES-128-CBC
comp-lzo adaptive
resolv-retry infinite
remote-cert-tls server
persist-key
persist-tun
socks-proxy-retry
remote VPS_IP 9494

 
ukázka logu openvpn klienta:

Sun Mar 15 10:41:21 2020 us=185713 I/O WAIT T?|T?|SR|Sw [1/219458]
Sun Mar 15 10:41:21 2020 us=185728 PO_WAIT[0,0] fd=3 rev=0x00000001 rwflags=0x0001 arg=0x55a675082168
Sun Mar 15 10:41:21 2020 us=185739  event_wait returned 1
Sun Mar 15 10:41:21 2020 us=185750 I/O WAIT status=0x0001
Sun Mar 15 10:41:21 2020 us=185761 STREAM: GET NEXT len=1627
Sun Mar 15 10:41:21 2020 us=185778 Connection reset, restarting  [\0]
Sun Mar 15 10:41:21 2020 us=185826 PID packet_id_free
Sun Mar 15 10:41:21 2020 us=185839 PID packet_id_free
Sun Mar 15 10:41:21 2020 us=185850 PID packet_id_free
Sun Mar 15 10:41:21 2020 us=185870 PID packet_id_free
Sun Mar 15 10:41:21 2020 us=185882 PID packet_id_free
Sun Mar 15 10:41:21 2020 us=185892 PID packet_id_free
Sun Mar 15 10:41:21 2020 us=185903 PID packet_id_free
Sun Mar 15 10:41:21 2020 us=185914 TCP/UDP: Closing socket
Sun Mar 15 10:41:21 2020 us=185941 PID packet_id_free
Sun Mar 15 10:41:21 2020 us=185957 SIGUSR1[soft,connection-reset] received, process restarting
Sun Mar 15 10:41:21 2020 us=185980 Restart pause, 5 second(s)



díky za pomoc


reklama


zjistil jsem že mám v příspěvku špatnou konfiguraci kilenta, správně má být:

client
dev tun
proto tcp
float
nobind
cipher AES-128-CBC
comp-lzo adaptive
resolv-retry infinite
remote-cert-tls server
persist-key
persist-tun
remote 31.31.78.135 9494

vyřešeno

na routeru byl nesprávně nastavený protokol UDP, přepnutím na TCP začalo vše fungovat

crown

  • ***
  • 117
    • Zobrazit profil
Muzes si na serveru zapnout oba protokoly tcp i udp.

U klienta pak budes mit na vyber. U vytizenejsiho spoje muze byt UDP o dost rychlejsi kvuli rizeni provozu.

 

reklama