reklama

Ansible - update baličků z backportu

Ansible - update baličků z backportu
« kdy: 22. 10. 2019, 11:40:43 »
Caus,

mam tyhle konfigy:

server:
Kód: [Vybrat]
/etc/apt/preferences.d/preferences
Package: *
Pin: release a=buster-backports
Pin-Priority: 450

ansible:
Kód: [Vybrat]
---
- name: Install haproxy packages
  apt:
   name: "{{ haproxy_packages }}"
   state: present
   update_cache: true
  tags: haproxy_packages

Pri spusteni tohoto tasku doslo k upgradu stable verze haproxy v Deb 10 z 1.8.x na 2.0.x z backportu. Pritom podle priority by mel byt preferovan stable. V host_vars pro dany server bylo:
Kód: [Vybrat]
haproxy_version="*"Je mozny, ze to prebilo prioritu v aptu a proc? Cekal jsem, ze to bude drzet maximalni stable verzi (aneb, priprava, pokud by to muselo byt v presne dane verzi).

Diky.
« Poslední změna: 22. 10. 2019, 12:03:06 od Petr Krčmář »

reklama


Re:Ansible - update balicku z backportu
« Odpověď #1 kdy: 22. 10. 2019, 11:53:32 »
Tak me jeste napada, koukam na jeden z poslednich serveru, co mely mit stable. A ony maji verzi haproxy misto Deb9 stable maji Deb9 z backportu. Pri upgradu na Deb10 se to mohlo zohlednit?

 

reklama