reklama

Zoneminder - přihlašování.

Zoneminder - přihlašování.
« kdy: 15. 08. 2019, 13:58:21 »
Pro monitoring a nahrávání záznamu z kamer jsem na Ubuntu 18.04 serveru nainstaloval Zoneminder. Nakonfiguroval kamery a vše funguje jak má. Nicméně potřebuji určité kamery poskytnout uživateli.
Pro přihlášování uživatelů jsem zaškrtnul Options -> System -> OPT_USE_AUTH (Authenticate user logins to ZoneMinder). To také funguje, mohu se už přihlásit a nastavení uživatelé také.
A teď k problému. V okamžiku, když zaškrtnu OPT_USE_AUTH, přestane fungovat náhled na kamery. V Montage Review vidím jen Camera offline a jinak všude, kde se zobrazuje online náhled na kameru problikává ikona "přetrženého" obrázku .

V logu Zoneminderu je stále dokola vypisována hláška:
Citace
getStreamCmdResponse stream error: Socket /var/run/zm/zms-711379s.sock does not exist. This file is created by zms, and since it does not exist, either zms did not run, or zms exited early. Please check your zms logs and ensure that CGI is enabled in apache and check that the PATH_ZMS is set correctly. Make sure that ZM is actually recording. If you are trying to view a live stream and the capture process (zmc) is not running then zms will exit. Please go to http://zoneminder.readthedocs.io/en/latest/faq.html#why-can-t-i-see-streamed-images-when-i-can-see-stills-in-the-zone-window-etc for more information. - checkStreamForErrors()

Pokud zase OPT_USE_AUTH odškrtnu, tak se náhled na kamery obnoví.

Neřešil jste to někdo ?

reklama


Re:Zoneminder - přihlašování.
« Odpověď #1 kdy: 16. 08. 2019, 07:53:57 »
Tak už jsem našel řešení. Řešení jsem našel tady: https://forums.zoneminder.com/viewtopic.php?t=26813 .

Pro případ že by stránka nebyla někdy dostupná, dovolím si uvézt citát odpovědi z fóra:

Citace
Re: Streams Don't work when OPT_USE_AUTH is enabled
Post by rockedge » Mon Dec 11, 2017 11:13 pm

you must set Options->System->AUTH_RELAY to "None" when you have OPT_USE_AUTH enabled......see if that works. There is something going on with Hash creation and authorization ....have you set AUTH_HASH_SECRET to something?

 

reklama