reklama

Nemôžem si prihlásit do GUI na Raspberry Pi

Nemôžem si prihlásit do GUI na Raspberry Pi
« kdy: 07. 05. 2019, 19:03:48 »
Dobrý deň,mám problém nemôžem sa prihlásiť do GUI Raspbian na Pi. Cez SSH prihlásenie funguje. Všetky internety píše že sa jedná o problém s Xauthority. To nie je môj prípad :

Kód: [Vybrat]
-rw-------  1 pi   pi     56 May  7 18:37 .Xauthority
namiesto toho som tam našiel takéto:

Kód: [Vybrat]
pi@raspberrypi:~ $ ls  -lah
total 208K
drwxr-xr-x  3 root root 4.0K May  4 22:35 ..

Vedel by mi niekto pomocť?
« Poslední změna: 07. 05. 2019, 21:41:18 od Petr Krčmář »

reklama


k3dAR

  • *****
  • 1 109
  • porad nemam telo, ale uz mam hlavu... nobody
    • Zobrazit profil
    • E-mail
Re:Nemôžem si prihlási do GUI
« Odpověď #1 kdy: 07. 05. 2019, 20:26:29 »
".." znamenaji nadrazeny adresar, to ze /home vlastni root:root je naprosto v poradku ;-) nedoslo ti misto na karte?
Kód: [Vybrat]
df -h /co mas v /var/log/Xorg.0.log ?

Re:Nemôžem si prihlásit do GUI na Raspberry Pi
« Odpověď #2 kdy: 08. 05. 2019, 07:25:29 »
Jak se nemůžeš přihlásit? Co to dělá/hlásí? A fungovalo to předtím?

Re:Nemôžem si prihlásit do GUI na Raspberry Pi
« Odpověď #3 kdy: 10. 05. 2019, 20:40:52 »
Súvisí to že sa sem môžem prihlásiť a odpovedať tým že som vymazal data prehliadača?

K veci. Miesto určite nedošlo.
Kód: [Vybrat]
Filesystem      Size  Used Avail Use% Mounted on
/dev/root        13G  6.0G  6.4G  49% /
Toto je log
Kód: [Vybrat]
[151737.706]
X.Org X Server 1.19.2
Release Date: 2017-03-02
[151737.707] X Protocol Version 11, Revision 0
[151737.707] Build Operating System: Linux 4.9.41-v7+ armv7l Raspbian
[151737.707] Current Operating System: Linux raspberrypi 4.14.98+ #1200 Tue Feb 12 20:11:02 GMT 2019 armv6l
[151737.707] Kernel command line: 8250.nr_uarts=0 bcm2708_fb.fbwidth=640 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 smsc95xx.macaddr=B8:27:EB:93:88:06 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  dwc_otg.lpm_enable=0 console=ttyS0,115200 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
[151737.708] Build Date: 18 October 2017  04:55:30PM
[151737.708] xorg-server 2:1.19.2-1+rpt1+deb9u2 (https://www.debian.org/support)
[151737.708] Current version of pixman: 0.34.0
[151737.708] Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
[151737.708] Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[151737.710] (==) Log file: "/var/log/Xorg.0.log", Time: Fri May 10 12:49:42 2019
[151737.712] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[151737.713] (==) No Layout section.  Using the first Screen section.
[151737.713] (==) No screen section available. Using defaults.
[151737.713] (**) |-->Screen "Default Screen Section" (0)
[151737.713] (**) |   |-->Monitor "<default monitor>"
[151737.715] (==) No device specified for screen "Default Screen Section".
Using the first device section listed.
[151737.715] (**) |   |-->Device "Allwinner A10/A13 FBDEV"
[151737.715] (==) No monitor specified for screen "Default Screen Section".
Using a default monitor configuration.
[151737.715] (==) Automatically adding devices
[151737.715] (==) Automatically enabling devices
[151737.715] (==) Automatically adding GPU devices
[151737.716] (==) Max clients allowed: 256, resource mask: 0x1fffff
[151737.716] (WW) The directory "/usr/share/fonts/X11/misc" does not exist.
[151737.716] Entry deleted from font path.
[151737.716] (WW) The directory "/usr/share/fonts/X11/cyrillic" does not exist.
[151737.716] Entry deleted from font path.
[151737.716] (WW) The directory "/usr/share/fonts/X11/75dpi/" does not exist.
[151737.716] Entry deleted from font path.
[151737.717] (WW) The directory "/usr/share/fonts/X11/75dpi" does not exist.
[151737.717] Entry deleted from font path.
[151737.717] (==) FontPath set to:
/usr/share/fonts/X11/100dpi/:unscaled,
/usr/share/fonts/X11/Type1,
/usr/share/fonts/X11/100dpi,
built-ins
[151737.717] (==) ModulePath set to "/usr/lib/xorg/modules"
[151737.717] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
[151737.717] (II) Loader magic: 0x1fbf40
[151737.717] (II) Module ABI versions:
[151737.717] X.Org ANSI C Emulation: 0.4
[151737.717] X.Org Video Driver: 23.0
[151737.718] X.Org XInput driver : 24.1
[151737.718] X.Org Server Extension : 10.0
[151737.725] (++) using VT number 7

[151737.725] (II) systemd-logind: logind integration requires -keeptty and -keeptty was not provided, disabling logind integration
[151737.726] (II) no primary bus or device found
[151737.726] (II) LoadModule: "glx"
[151737.728] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[151737.752] (II) Module glx: vendor="X.Org Foundation"
[151737.752] compiled for 1.19.2, module version = 1.0.0
[151737.752] ABI class: X.Org Server Extension, version 10.0
[151737.752] (II) LoadModule: "fbturbo"
[151737.753] (II) Loading /usr/lib/xorg/modules/drivers/fbturbo_drv.so
[151737.754] (II) Module fbturbo: vendor="X.Org Foundation"
[151737.755] compiled for 1.19.2, module version = 0.5.1
[151737.755] Module class: X.Org Video Driver
[151737.755] ABI class: X.Org Video Driver, version 23.0
[151737.755] (II) FBTURBO: driver for framebuffer: fbturbo
[151737.756] (WW) Falling back to old probe method for fbturbo
[151737.756] (II) Loading sub module "fbdevhw"
[151737.756] (II) LoadModule: "fbdevhw"
[151737.757] (II) Loading /usr/lib/xorg/modules/libfbdevhw.so
[151737.758] (II) Module fbdevhw: vendor="X.Org Foundation"
[151737.758] compiled for 1.19.2, module version = 0.0.2
[151737.758] ABI class: X.Org Video Driver, version 23.0
[151737.759] (II) FBTURBO(0): using /dev/fb0
[151737.759] (WW) VGA arbiter: cannot open kernel arbiter, no multi-card support
[151737.759] (II) FBTURBO(0): Creating default Display subsection in Screen section
"Default Screen Section" for depth/fbbpp 24/32
[151737.759] (==) FBTURBO(0): Depth 24, (==) framebuffer bpp 32
[151737.759] (==) FBTURBO(0): RGB weight 888
[151737.759] (==) FBTURBO(0): Default visual is TrueColor
[151737.760] (==) FBTURBO(0): Using gamma correction (1.0, 1.0, 1.0)
[151737.760] (II) FBTURBO(0): hardware: BCM2708 FB (video memory: 1200kB)
[151737.760] (**) FBTURBO(0): Option "fbdev" "/dev/fb0"
[151737.761] (**) FBTURBO(0): Option "SwapbuffersWait" "true"
[151737.762] (II) FBTURBO(0): processor: ARM1176
[151737.762] (II) FBTURBO(0): checking modes against framebuffer device...
[151737.762] (II) FBTURBO(0): checking modes against monitor...
[151737.763] (--) FBTURBO(0): Virtual size is 640x480 (pitch 640)
[151737.763] (**) FBTURBO(0):  Built-in mode "current"
[151737.763] (==) FBTURBO(0): DPI set to (96, 96)
[151737.763] (II) Loading sub module "fb"
[151737.763] (II) LoadModule: "fb"
[151737.764] (II) Loading /usr/lib/xorg/modules/libfb.so
[151737.765] (II) Module fb: vendor="X.Org Foundation"
[151737.765] compiled for 1.19.2, module version = 1.0.0
[151737.765] ABI class: X.Org ANSI C Emulation, version 0.4
[151737.766] (==) Depth 24 pixmap format is 32 bpp
[151737.768] (II) FBTURBO(0): using backing store heuristics
[151737.781] (II) FBTURBO(0): can't load 'g2d_23' kernel module
[151737.783] (II) FBTURBO(0): failed to enable the use of sunxi display controller
[151737.783] (II) FBTURBO(0): No sunxi-g2d hardware detected (check /dev/disp and /dev/g2d)
[151737.783] (II) FBTURBO(0): G2D hardware acceleration can't be enabled
[151737.783] (II) FBTURBO(0): enabled fbdev copyarea acceleration
[151737.784] (==) FBTURBO(0): Backing store enabled
[151737.785] (==) FBTURBO(0): DPMS enabled
[151737.786] (II) FBTURBO(0): failed to enable hardware cursor
[151737.786] (II) FBTURBO(0): no 3D acceleration because the driver has been compiled without libUMP
[151737.786] (II) FBTURBO(0): if this is wrong and needs to be fixed, please check ./configure log
[151737.786] (==) RandR enabled
[151737.836] (II) SELinux: Disabled on system
[151737.843] (II) AIGLX: Screen 0 is not DRI2 capable
[151737.843] (EE) AIGLX: reverting to software rendering
[151738.401] (II) IGLX: enabled GLX_MESA_copy_sub_buffer
[151738.407] (II) IGLX: Loaded and initialized swrast
[151738.407] (II) GLX: Initialized DRISWRAST GL provider for screen 0
Takto to vyzerá cez VNC
https://www.youtube.com/watch?v=v1Ia0l89pMM&list=UUZtXTLVZrjMplqMja5d-Ycw&index=1
« Poslední změna: 10. 05. 2019, 20:45:17 od QSKONE »

k3dAR

  • *****
  • 1 109
  • porad nemam telo, ale uz mam hlavu... nobody
    • Zobrazit profil
    • E-mail
Re:Nemôžem si prihlásit do GUI na Raspberry Pi
« Odpověď #4 kdy: 10. 05. 2019, 20:59:32 »
tohle neni tvoje vlakno? pokud ne, nepridaval si take deb-multimedia repositar? ;-)

edit: tak nic, uz vidim ze v logu problem s fbturbo nemas i ze log mas v normalnim umisteni /var/log

edi2: tvuj log vypada normalne, zadnej error (krome AIGLX coz mam take), konci tak jam ma (resp. jak konci me)

edit3: posli logy z /var/log/lightdm/
« Poslední změna: 10. 05. 2019, 21:05:39 od k3dAR »

reklama


Re:Nemôžem si prihlásit do GUI na Raspberry Pi
« Odpověď #5 kdy: 10. 05. 2019, 21:20:45 »
Toto by malo byť ono

Kód: [Vybrat]
/var/log/lightdm/
cat: /var/log/lightdm/: Is a directory
root@raspberrypi:~# cat /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Logging to /var/log/lightdm/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.18.3, UID=0 PID=351
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.01s] DEBUG: Loading configuration from /usr/share/lightdm/lightdm.conf.d/01_debian.conf
[+0.01s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.01s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.01s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.01s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.05s] DEBUG: Registered seat module xlocal
[+0.07s] DEBUG: Registered seat module xremote
[+0.07s] DEBUG: Registered seat module unity
[+0.53s] DEBUG: Monitoring logind for seats
[+0.53s] DEBUG: New seat added from logind: seat0
[+0.53s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.54s] DEBUG: Seat seat0: Starting
[+0.54s] DEBUG: Seat seat0: Creating user session
[+0.59s] WARNING: Error getting user list from org.freedesktop.Accounts: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Accounts was not provided by any .service files
[+0.63s] DEBUG: Loading user config from /etc/lightdm/users.conf
[+0.65s] DEBUG: User pi added
[+0.68s] DEBUG: Seat seat0: Creating display server of type x
[+0.77s] DEBUG: Using VT 7
[+0.77s] DEBUG: Seat seat0: Starting local X display on VT 7
[+0.77s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+0.77s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+0.77s] DEBUG: DisplayServer x-0: Launching X Server
[+0.79s] DEBUG: Launching process 378: /usr/bin/X :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+0.79s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+0.81s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.82s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+6.25s] DEBUG: Got signal 10 from process 378
[+6.25s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+6.25s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+6.27s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+6.27s] DEBUG: Session pid=451: Started with service 'lightdm-autologin', username 'pi'
[+6.45s] DEBUG: Session pid=451: Authentication complete with return value 0: Success
[+6.45s] DEBUG: Seat seat0: Session authenticated, running command
[+6.45s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session0
[+6.46s] DEBUG: Session pid=451: Running command /etc/X11/Xsession default
[+6.46s] DEBUG: Creating shared data directory /var/lib/lightdm/data/pi
[+6.47s] DEBUG: Session pid=451: Logging to .xsession-errors
[+7.21s] DEBUG: Activating VT 7
[+7.21s] DEBUG: Activating login1 session c1
[+7.21s] DEBUG: Seat seat0 changes active session to c1
[+7.21s] DEBUG: Session c1 is already active
[+10.97s] DEBUG: Session pid=451: Exited with return value 0
[+10.97s] DEBUG: Seat seat0: Session stopped
[+10.97s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+10.97s] DEBUG: Sending signal 15 to process 378
[+11.03s] DEBUG: Process 378 exited with return value 0
[+11.03s] DEBUG: DisplayServer x-0: X server stopped
[+11.03s] DEBUG: Releasing VT 7
[+11.03s] DEBUG: DisplayServer x-0: Removing X server authority /var/run/lightdm/root/:0
[+11.03s] DEBUG: Seat seat0: Display server stopped
[+11.03s] DEBUG: Seat seat0: Active display server stopped, starting greeter
[+11.03s] DEBUG: Seat seat0: Creating greeter session
[+11.04s] DEBUG: Seat seat0: Creating display server of type x
[+11.04s] DEBUG: Using VT 7
[+11.04s] DEBUG: Seat seat0: Starting local X display on VT 7
[+11.04s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+11.04s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+11.04s] DEBUG: DisplayServer x-0: Launching X Server
[+11.04s] DEBUG: Launching process 574: /usr/bin/X :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+11.04s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+12.13s] DEBUG: Got signal 10 from process 574
[+12.13s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+12.13s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+12.14s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+12.14s] DEBUG: Session pid=581: Started with service 'lightdm-greeter', username 'lightdm'
[+12.26s] DEBUG: Session pid=581: Authentication complete with return value 0: Success
[+12.26s] DEBUG: Seat seat0: Session authenticated, running command
[+12.26s] DEBUG: Session pid=581: Running command /usr/sbin/pi-greeter
[+12.26s] DEBUG: Creating shared data directory /var/lib/lightdm/data/lightdm
[+12.26s] DEBUG: Session pid=581: Logging to /var/log/lightdm/seat0-greeter.log
[+13.16s] DEBUG: Activating VT 7
[+13.16s] DEBUG: Activating login1 session c2
[+13.17s] DEBUG: Seat seat0 changes active session to c2
[+13.17s] DEBUG: Session c2 is already active
[+13.87s] DEBUG: Greeter connected version=1.18.3 resettable=false
[+18.58s] DEBUG: Greeter start authentication for pi
[+18.58s] DEBUG: Session pid=627: Started with service 'lightdm', username 'pi'
[+18.76s] DEBUG: Session pid=627: Got 1 message(s) from PAM
[+18.76s] DEBUG: Prompt greeter with 1 message(s)
[+151713.26s] DEBUG: Continue authentication
[+151713.61s] DEBUG: Session pid=627: Authentication complete with return value 0: Success
[+151713.61s] DEBUG: Authenticate result for user pi: Success
[+151713.61s] DEBUG: User pi authorized
[+151713.62s] DEBUG: Greeter requests session lightdm-xsession
[+151713.62s] DEBUG: Seat seat0: Stopping greeter; display server will be re-used for user session
[+151713.62s] DEBUG: Session pid=581: Sending SIGTERM
[+151713.75s] DEBUG: Greeter closed communication channel
[+151713.76s] DEBUG: Session pid=581: Exited with return value 0
[+151713.76s] DEBUG: Seat seat0: Session stopped
[+151713.76s] DEBUG: Seat seat0: Greeter stopped, running session
[+151713.76s] DEBUG: Registering session with bus path /org/freedesktop/DisplayManager/Session1
[+151713.82s] DEBUG: Session pid=627: Running command /etc/X11/Xsession default
[+151713.82s] DEBUG: Creating shared data directory /var/lib/lightdm/data/pi
[+151713.84s] DEBUG: Session pid=627: Logging to .xsession-errors
[+151715.27s] DEBUG: Activating VT 7
[+151715.27s] DEBUG: Activating login1 session c4
[+151715.28s] DEBUG: Seat seat0 changes active session to
[+151715.28s] DEBUG: Seat seat0 changes active session to c4
[+151715.28s] DEBUG: Session c4 is already active
[+151718.25s] DEBUG: Session pid=627: Exited with return value 0
[+151718.25s] DEBUG: Seat seat0: Session stopped
[+151718.25s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+151718.25s] DEBUG: Sending signal 15 to process 574
[+151718.34s] DEBUG: Process 574 exited with return value 0
[+151718.34s] DEBUG: DisplayServer x-0: X server stopped
[+151718.34s] DEBUG: Releasing VT 7
[+151718.34s] DEBUG: DisplayServer x-0: Removing X server authority /var/run/lightdm/root/:0
[+151718.34s] DEBUG: Seat seat0: Display server stopped
[+151718.34s] DEBUG: Seat seat0: Active display server stopped, starting greeter
[+151718.34s] DEBUG: Seat seat0: Creating greeter session
[+151718.34s] DEBUG: Seat seat0: Creating display server of type x
[+151718.34s] DEBUG: Using VT 7
[+151718.34s] DEBUG: Seat seat0: Starting local X display on VT 7
[+151718.34s] DEBUG: DisplayServer x-0: Logging to /var/log/lightdm/x-0.log
[+151718.34s] DEBUG: DisplayServer x-0: Writing X server authority to /var/run/lightdm/root/:0
[+151718.35s] DEBUG: DisplayServer x-0: Launching X Server
[+151718.35s] DEBUG: Launching process 32565: /usr/bin/X :0 -seat seat0 -auth /var/run/lightdm/root/:0 -nolisten tcp vt7 -novtswitch
[+151718.35s] DEBUG: DisplayServer x-0: Waiting for ready signal from X server :0
[+151719.79s] DEBUG: Got signal 10 from process 32565
[+151719.79s] DEBUG: DisplayServer x-0: Got signal from X server :0
[+151719.79s] DEBUG: DisplayServer x-0: Connecting to XServer :0
[+151719.82s] DEBUG: Seat seat0: Display server ready, starting session authentication
[+151719.82s] DEBUG: Session pid=32577: Started with service 'lightdm-greeter', username 'lightdm'
[+151720.03s] DEBUG: Session pid=32577: Authentication complete with return value 0: Success
[+151720.03s] DEBUG: Seat seat0: Session authenticated, running command
[+151720.03s] DEBUG: Session pid=32577: Running command /usr/sbin/pi-greeter
[+151720.03s] DEBUG: Creating shared data directory /var/lib/lightdm/data/lightdm
[+151720.03s] DEBUG: Session pid=32577: Logging to /var/log/lightdm/seat0-greeter.log
[+151720.99s] DEBUG: Activating VT 7
[+151720.99s] DEBUG: Activating login1 session c5
[+151721.00s] DEBUG: Seat seat0 changes active session to c5
[+151721.00s] DEBUG: Session c5 is already active
[+151721.35s] DEBUG: Greeter connected version=1.18.3 resettable=false
[+151723.86s] DEBUG: Greeter start authentication for pi
[+151723.86s] DEBUG: Session pid=32610: Started with service 'lightdm', username 'pi'
[+151724.03s] DEBUG: Session pid=32610: Got 1 message(s) from PAM
[+151724.03s] DEBUG: Prompt greeter with 1 message(s)

Kód: [Vybrat]
/var/log/lightdm/x-0.log

X.Org X Server 1.19.2
Release Date: 2017-03-02
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.41-v7+ armv7l Raspbian
Current Operating System: Linux raspberrypi 4.14.98+ #1200 Tue Feb 12 20:11:02 GMT 2019 armv6l
Kernel command line: 8250.nr_uarts=0 bcm2708_fb.fbwidth=640 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 smsc95xx.macaddr=B8:27:EB:93:88:06 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  dwc_otg.lpm_enable=0 console=ttyS0,115200 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
Build Date: 18 October 2017  04:55:30PM
xorg-server 2:1.19.2-1+rpt1+deb9u2 (https://www.debian.org/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri May 10 12:49:42 2019
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
modprobe: FATAL: Module g2d_23 not found in directory /lib/modules/4.14.98+

Kód: [Vybrat]
/var/log/lightdm/x-0.log

X.Org X Server 1.19.2
Release Date: 2017-03-02
X Protocol Version 11, Revision 0
Build Operating System: Linux 4.9.41-v7+ armv7l Raspbian
Current Operating System: Linux raspberrypi 4.14.98+ #1200 Tue Feb 12 20:11:02 GMT 2019 armv6l
Kernel command line: 8250.nr_uarts=0 bcm2708_fb.fbwidth=640 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 smsc95xx.macaddr=B8:27:EB:93:88:06 vc_mem.mem_base=0x1ec00000 vc_mem.mem_size=0x20000000  dwc_otg.lpm_enable=0 console=ttyS0,115200 console=tty1 root=/dev/mmcblk0p7 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
Build Date: 18 October 2017  04:55:30PM
xorg-server 2:1.19.2-1+rpt1+deb9u2 (https://www.debian.org/support)
Current version of pixman: 0.34.0
Before reporting problems, check http://wiki.x.org
to make sure that you have the latest version.
Markers: (--) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: "/var/log/Xorg.0.log", Time: Fri May 10 12:49:42 2019
(==) Using system config directory "/usr/share/X11/xorg.conf.d"
modprobe: FATAL: Module g2d_23 not found in directory /lib/modules/4.14.98+
root@raspberrypi:~# cat /var/log/lightdm/x-0-greeter.log
cat: /var/log/lightdm/x-0-greeter.log: No such file or directory
root@raspberrypi:~# cat /var/log/lightdm/x-0-greeter.log
cat: /var/log/lightdm/x-0-greeter.log: No such file or directory




k3dAR

  • *****
  • 1 109
  • porad nemam telo, ale uz mam hlavu... nobody
    • Zobrazit profil
    • E-mail
Re:Nemôžem si prihlásit do GUI na Raspberry Pi
« Odpověď #6 kdy: 10. 05. 2019, 23:15:22 »
v x-0.log problem nevidim (btw: si dal 2x ;-), lightdm.log mam z pocatku stejnej, ale konci mi pred tvojim radkem:
"[+151713.26s] DEBUG: Continue authentication"
kterej mas po 40h od bootu, takze pujde o tve znovupokusy o prihlaseni, kde dale take nevidim zadnej problem...
tzn. ze neni problem v systemu/X.Org/lightdm, ale problem bude v souborech uzivatele pi, o .Xauthority coz byva problem v takove situaci si zkontroloval a prava jsou ok, ale muzes mit spatne prava (diky spatne pouzitemu sudo) v $HOME...
Kód: [Vybrat]
# zjisti zda v tvem home neco nevlastni root (tedy umyslne pustene bez sudo nebo ne v root shellu)
$ chown pi:pi /home/

# pokud to u neceho zarve error, uloz si info o tech souborech do poznamek a pust zmenu prav tentokrat ze sudo aby se prevedli i vlastnene rootem
$ sudo chown pi:pi /home/
dalsi moznost je zkusit vytvorit jineho uzivatele a prihlasit se na nej:
Kód: [Vybrat]
# vytvoreni uzivatele pi3
sudo adduser pi3

# pridani do skupiny sudo
sudo adduser pi3 sudo

Re:Nemôžem si prihlásit do GUI na Raspberry Pi
« Odpověď #7 kdy: 11. 05. 2019, 07:21:59 »
Tie change owner príkazy som skúšal ešte pred tým než som tu žiadal o radu.
Kód: [Vybrat]
chown pi:pi /home/
chown: changing ownership of '/home/': Operation not permitted

Príkaz
Kód: [Vybrat]
sudo chown pi:pi /home/hovorí že plocha má patriť užívateľovi pi a prebehne bez chýb ,ale do pi sa stále nemôžem prihlásiť

k3dAR

  • *****
  • 1 109
  • porad nemam telo, ale uz mam hlavu... nobody
    • Zobrazit profil
    • E-mail
Re:Nemôžem si prihlásit do GUI na Raspberry Pi
« Odpověď #8 kdy: 11. 05. 2019, 08:32:50 »
Promin, vypadlo mi pi(melo se menit /home/pi), vlastnictvi samotneho /home vrat na root:
Kód: [Vybrat]
sudo chown root:root /homePrihlaseni na noveho usera si zkousel?

Re:Nemôžem si prihlásit do GUI na Raspberry Pi
« Odpověď #9 kdy: 17. 05. 2019, 21:43:45 »
Nie, vzdal som to. Na tom Pi bežal len Domoticz tak som preinštaloval a spravil čistú inštaláciu.

 

reklama