reklama

Nefunguje IPv6 v Debianu 9 pod KVM

noob

Nefunguje IPv6 v Debianu 9 pod KVM
« kdy: 19. 02. 2019, 20:16:21 »
Marně se snažím rozchodit ipv6 na debianu 9 pod KVM. Všechno vypadá normálně, ale nepingnu si na IP na lokálním rozhraní. A dokonce ani na ipv6 loopback, což mě zaráží nejvíc. Nemáte někdo představu co mám prověřit?

Kód: [Vybrat]
root@server:~# sysctl -a|grep disable_ipv6
net.ipv6.conf.all.disable_ipv6 = 0
sysctl: reading key "net.ipv6.conf.all.stable_secret"
sysctl: reading key "net.ipv6.conf.default.stable_secret"
net.ipv6.conf.default.disable_ipv6 = 0
sysctl: reading key "net.ipv6.conf.eth0.stable_secret"
net.ipv6.conf.eth0.disable_ipv6 = 0
sysctl: reading key "net.ipv6.conf.lo.stable_secret"
net.ipv6.conf.lo.disable_ipv6 = 0

Kód: [Vybrat]
$ ip -6 address

 1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 state UNKNOWN qlen 1
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 state UP qlen 1000
    inet6 2a02:c205:2024:XXXX::1/64 scope global
       valid_lft forever preferred_lft forever
    inet6 fe80::250:56ff:fe3e:263b/64 scope link
       valid_lft forever preferred_lft forever

Kód: [Vybrat]
$ ip -6 route

2a02:c205:2024:XXXX::/64 dev eth0 proto kernel metric 256  pref medium
fe80::/64 dev eth0 proto kernel metric 256  pref medium
default via fe80::1 dev eth0 metric 1024  pref medium

Kód: [Vybrat]
root@server:~# ping6 ::1
PING ::1(::1) 56 data bytes

...nic se neděje a po ^C ...

Kód: [Vybrat]
--- ::1 ping statistics ---
6 packets transmitted, 0 received, 100% packet loss, time 5113ms
« Poslední změna: 19. 02. 2019, 21:29:18 od Petr Krčmář »

reklama


Re:Nefunguje IPv6 v Debianu 9 pod KVM
« Odpověď #1 kdy: 21. 02. 2019, 17:14:31 »
Pro loopback vam chybi routa:

::1 dev lo proto kernel metric 256 pref medium

proc by nemelo zit eth0 je otazka, stretch  + KVM + IPv6 zcela jiste funguje. Stane se to i cerstve instalovanemu virtualu? Konfigurujete to pres /etc/network/interafces se statickou IP nebo nejak rucne?

Vilith

  • *****
  • 517
    • Zobrazit profil
Re:Nefunguje IPv6 v Debianu 9 pod KVM
« Odpověď #2 kdy: 21. 02. 2019, 17:33:14 »
1/ je to stroj doma nebo nekde na hostingu? - kazdy hosting ma sva "specifika"

2/ IPv6 na fyzickem zeleze chodi?

3/ na virtualce
Kód: [Vybrat]
ip -6 nei co napise?

noob

Re:Nefunguje IPv6 v Debianu 9 pod KVM
« Odpověď #3 kdy: 21. 02. 2019, 18:38:37 »
VPS mám na německém hostingu Contabo. Poskytovatel IPv6 nabízí a na hostujícím stroji by mělo IPv6 fungovat (to ale neumím ověřit).

Kód: [Vybrat]
ip -6 nei
fe80::1 dev eth0  FAILED

Používám /etc/network/interfaces nastavený už při instalaci poskytovatelem.

Kód: [Vybrat]
iface eth0 inet6 static
    address 2a02:c205:2024:XXXX:0000:0000:0000:0001
    netmask 64
    gateway fe80::1
    accept_ra 0
    autoconf 0
    privext 0

Problém byl pravděpodobně už na čerstvě nainstalovaném virtuálu, ale nevím to s jistotou, potřeboval jsem rychle rozchodit mailserver a ipv6 nebyla priorita. Poskytovatele jsem kontaktoval a support si řekl o root přístup a to mi přijde trochu přes čáru :)
« Poslední změna: 21. 02. 2019, 18:47:01 od noob »

Vilith

  • *****
  • 517
    • Zobrazit profil
Re:Nefunguje IPv6 v Debianu 9 pod KVM
« Odpověď #4 kdy: 21. 02. 2019, 19:42:39 »
https://blog.contabo.com/tutorials/adding-ipv6-connectivity-to-your-server/

Tam nic nemam, abych ti zkopiroval svoje nastaveni :(

To, ze potrebuji roota chapu - je to nejkratsi cesta k oprave z jejich pohledu


 

reklama