reklama

Debian a starší verze jádra

KLFMANiK

Debian a starší verze jádra
« kdy: 24. 01. 2018, 13:41:32 »
Zdravim,

donedavna Debian pri aktualizacii noveho kernelu ten stary prepisal, takze na serveri bol vzdy iba jeden
kernel (ak neratame bpo kernel a pod.)

ale teraz mam po nedavnych aktualizaciach napr.:

Kód: [Vybrat]
ii  linux-image-3.16.0-4-amd64     3.16.51-3                    amd64        Linux 3.16 for 64-bit PCs
ii  linux-image-3.16.0-5-amd64     3.16.51-3+deb8u1             amd64        Linux 3.16 for 64-bit PCs
ii  linux-image-amd64              3.16+63+deb8u1               amd64        Linux for 64-bit PCs (meta-package)

alebo

Kód: [Vybrat]
ii  linux-image-4.9.0-4-amd64      4.9.65-3+deb9u1              amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-4.9.0-5-amd64      4.9.65-3+deb9u2              amd64        Linux 4.9 for 64-bit PCs
ii  linux-image-amd64              4.9+80+deb9u3                amd64        Linux for 64-bit PCs (meta-package)

predtym sa kernel vzdy prepisal, ostal iba jeden ... teraz je to podla mna pozitivna zmena a kernely su dva ...
zrejme kvoli tomu, aby sa dal lahko bootnut aj ten starsi kernel priamo cez grub

hladal som vsade, ale ani v changelogu som nenasiel nic, preco stary kernel ostal a ci to tak bude aj nadalej

podobnu otazku som nasiel akurat na:
https://www.reddit.com/r/debian/comments/7p8id8/kernels_v31604amd64_files_left_behind_after/

mate o tom nejake informacie?

DAKUJEM
« Poslední změna: 24. 01. 2018, 14:01:32 od Petr Krčmář »

reklama


KLFMANiK

Re:Debian a starší verze jádra
« Odpověď #1 kdy: 24. 01. 2018, 14:27:18 »
este som sa pozrel do /var/log/apt/history.log*

vsimnite si, ze:
  • najprv sa nainstaloval balik linux-image-4.9.0-4-amd64 - 4.9.51-1
  • potom sa urobila aktualizacia toho isteho balika linux-image-4.9.0-4-amd64 - 4.9.65-3
  • potom dalsia aktualizacia toho isteho balika linux-image-4.9.0-4-amd64 - 4.9.65-3+deb9u1
  • a potom sa nainstaloval novy balik linux-image-4.9.0-5-amd64 - 4.9.65-3+deb9u2 a pritom linux-image-4.9.0-4-amd64 ostal nezmeny, zmenil sa len metabalik, ktory zavisi na novsej verzii balika kernelu
 

takze k nejakej zmene sposobu aktualizacii kernelu naozaj prislo, len neviem zistit, preco to zmenili - ani som nenasiel nic podstatne v preinst, postint skriptoch - mozno zmenili iba Depends v metabaliku linux-image-amd64 a neponechali tam stare cislo kernel balika


Start-Date: 2017-10-24  04:31:41
Commandline: apt-get -o APT::Status-Fd=4 -o APT::Keep-Fds::=5 -o APT::Keep-Fds::=6 -q -y --no-remove install linux-image-amd64
Install: linux-image-4.9.0-4-amd64:amd64 (4.9.51-1, automatic), linux-image-amd64:amd64 (4.9+80+deb9u2)
End-Date: 2017-10-24  04:31:58

Start-Date: 2017-12-10  20:34:36
Commandline: apt-get dist-upgrade
Upgrade: libdbus-1-3:amd64 (1.10.22-0+deb9u1, 1.10.24-0+deb9u1), dbus:amd64 (1.10.22-0+deb9u1, 1.10.24-0+deb9u1), python2.7-minimal:amd64 (2.7.13-2, 2.7.13-2+deb9u2), libsqlite3-0:amd64 (3.16.2-5, 3.16.2-5+deb9u1), libicu57:amd64 (57.1-6, 57.1-6+deb9u1), linux-image-4.9.0-4-amd64:amd64 (4.9.51-1, 4.9.65-3), libpython2.7:amd64 (2.7.13-2, 2.7.13-2+deb9u2), python2.7:amd64 (2.7.13-2, 2.7.13-2+deb9u2), openssh-sftp-server:amd64 (1:7.4p1-10+deb9u1, 1:7.4p1-10+deb9u2), openssh-server:amd64 (1:7.4p1-10+deb9u1, 1:7.4p1-10+deb9u2), iproute2:amd64 (4.9.0-1, 4.9.0-1+deb9u1), openssh-client:amd64 (1:7.4p1-10+deb9u1, 1:7.4p1-10+deb9u2), zsh:amd64 (5.3.1-4+b1, 5.3.1-4+b2), libpython2.7-minimal:amd64 (2.7.13-2, 2.7.13-2+deb9u2), libpython2.7-stdlib:amd64 (2.7.13-2, 2.7.13-2+deb9u2), base-files:amd64 (9.9+deb9u2, 9.9+deb9u3)
End-Date: 2017-12-10  20:35:39

Start-Date: 2017-12-27  11:12:09
Commandline: apt-get dist-upgrade
Upgrade: linux-image-4.9.0-4-amd64:amd64 (4.9.65-3, 4.9.65-3+deb9u1), sensible-utils:amd64 (0.0.9, 0.0.9+deb9u1)
End-Date: 2017-12-27  11:12:31

Start-Date: 2018-01-14  20:23:00
Commandline: apt-get dist-upgrade
Install: irqbalance:amd64 (1.1.0-2.3, automatic), libnuma1:amd64 (2.0.11-2.1, automatic), linux-image-4.9.0-5-amd64:amd64 (4.9.65-3+deb9u2, automatic), firmware-linux-free:amd64 (3.4, automatic)
Upgrade: linux-image-amd64:amd64 (4.9+80+deb9u2, 4.9+80+deb9u3), libxml2:amd64 (2.9.4+dfsg1-2.2+deb9u1, 2.9.4+dfsg1-2.2+deb9u2)
End-Date: 2018-01-14  20:23:30

Štefan

Re:Debian a starší verze jádra
« Odpověď #2 kdy: 24. 01. 2018, 15:40:01 »
Podle mně je to tím, že už nemáte nainstalovaný virtuální balíček debian-image-... , který způsobí, že se při aktualizaci nainstaluje vždy poslední verze jádra. Pokud se tento balíček smaže, další verze jádra se přidá a předchozí (starší) se nesmaže. Aspoň na mé instalaci to tak funguje ;)

 

reklama