reklama

Česká klavesnice nefunguje v Xterm (Debian Stretch)

hnedy vlk

Česká klavesnice nefunguje v Xterm (Debian Stretch)
« kdy: 26. 10. 2017, 16:36:22 »
Ahoj,
mam debian stretch a nechodi mi ceska klavesnice v terminalu (napr. xterm, ale nejen).

Nastavil jsem prepinani mezi us/cz pomoci
setxkbmap -model pc105 -layout "us,cz_qwerty"  -option "grp:alt_shift_toggle"
a v okynkovych aplikacich (firefox,libreoffice,atp) to normalne funguje.
Muze mi nekdo s debian-stretchem potvrdit problem, prip. poradit reseni?
Nepouzivam KDE/GNOME, takze bych preferoval command-line reseni.
Dikes!

« Poslední změna: 26. 10. 2017, 18:16:40 od Petr Krčmář »

reklama


Fantomas

Re:xterm & ceska klavesnice (debian stretch)
« Odpověď #1 kdy: 26. 10. 2017, 17:54:11 »
Dříve jsem to též používal, ale od příchodu lv3 mě to příjde zbytečné. Navíc mám pocit a je to pár let zpátky, že ten přepínač od verze wheezy funguje jinak. Ty ho dáváš do /etc/default/keyboard, ale on asi má být v /etc/X11/xorg.conf, popř. v /etc/X11/xorg.conf.d, možná ti pomůže tohle: https://forums.freebsd.org/threads/48412/#post-270733

Kada

Re:Česká klavesnice nefunguje v Xterm (Debian Stretch)
« Odpověď #2 kdy: 26. 10. 2017, 19:58:03 »
"nechodi mi ceska klavesnice":
- s preplou ceskou klavesnici to pise paznaky -> spatnej font
- s preplou ceskou klavesnici to nepise -> spatne locales

Pouzivate-li stale latin2 locales pro cestinu, zkusil bych pro xterm nastavit:
XTerm*renderFont: false

Naopak pro utf8 locales napr "en_US.UTF-8":
XTerm*faceName: Fixed
XTerm*faceSize: 12

hnedy vlk

Re:Česká klavesnice nefunguje v Xterm (Debian Stretch)
« Odpověď #3 kdy: 30. 10. 2017, 12:18:06 »
Ahoj, diky za odpoved.
"nechodi mi ceska klavesnice" znamena "s preplou ceskou klavesnici to nepise".

Znovu jsem zkontroloval /etc/locale.gen (a pro jistotu znova nageneroval), ale zda se mi to na prvni pohled v poradku:
en_US.UTF-8 UTF-8
cs_CZ.UTF-8 UTF-8
cs_CZ ISO-8859-2
en_US ISO-8859-1

latin2 stale pouzivam, "XTerm*renderFont: false" pro xterm v .Xresources nepomohl.

Dalsi nalez je, ze kdyz se na inkriminovany debian ssh-cknu (-Y) z jineho stroje, kde to s takovymito locales chodi (gentoo), a spustim xterm, ceske klavesy zacnou chodit.

Jeste jiny napad?

Skid

Re:Česká klavesnice nefunguje v Xterm (Debian Stretch)
« Odpověď #4 kdy: 30. 10. 2017, 12:23:12 »
Pouzivam toto a chodi mi to na tom debianu v pohode...

setxkbmap -option grp:switch,grp:alt_shift_toggle,grp_led:scroll us,cz
-----BEGIN GEEK CODE BLOCK-----
Version: 3.12
G! d- a s: C++ BAHSL++ P+ L++
E--- W+ N-- K- w-- O- M- V- PE Y
PGP- t--- !tv b+ DI- D+ e++ h--
------END GEEK CODE BLOCK-----


hnedy vlk

Re:Česká klavesnice nefunguje v Xterm (Debian Stretch)
« Odpověď #5 kdy: 30. 10. 2017, 12:33:08 »
Muzu se zeptat, co mate nastavene v LC_CTYPE?

Nakonec se mi problem podarilo rozchodit nastavenim LC_CTYPE=cs_CZ ale nechce se mi verit, ze to potrebuju jako default pro svoje terminaly.

Skid

Re:Česká klavesnice nefunguje v Xterm (Debian Stretch)
« Odpověď #6 kdy: 30. 10. 2017, 12:48:00 »
LC_CTYPE="en_US.UTF-8"
-----BEGIN GEEK CODE BLOCK-----
Version: 3.12
G! d- a s: C++ BAHSL++ P+ L++
E--- W+ N-- K- w-- O- M- V- PE Y
PGP- t--- !tv b+ DI- D+ e++ h--
------END GEEK CODE BLOCK-----

hnedy vlk

Re:Česká klavesnice nefunguje v Xterm (Debian Stretch)
« Odpověď #7 kdy: 30. 10. 2017, 13:06:52 »
Jasne, diky.

shnilylinux

Re:Česká klavesnice nefunguje v Xterm (Debian Stretch)
« Odpověď #8 kdy: 09. 11. 2017, 21:41:58 »
mě zase v terminálu  některé jiné než znaky qwerty  (například ž) píše něco jako \U+00FF\U+00DC, nevíte, kdy bude linux provozuchopný?

nobody(ten pravej)

Re:Česká klavesnice nefunguje v Xterm (Debian Stretch)
« Odpověď #9 kdy: 09. 11. 2017, 23:39:55 »
mě zase v terminálu  některé jiné než znaky qwerty  (například ž) píše něco jako \U+00FF\U+00DC, nevíte, kdy bude linux provozuchopný?
upravim tvoju otazku: "nevíte, kdy bude linux pro tebe provozuchopný?"
ano, az budes schopnej si to nastavit kdyz sis zvolil distribuci pro powerusera co to neudela za tebe ;-)

 

reklama