reklama

Nastavení hdparm při bootu

drobaxis

Nastavení hdparm při bootu
« kdy: 16. 02. 2017, 22:53:56 »
Zdravím nedaří se mi nastavit hdparm při bootu. Parametry jsou nejspíše ignorovány. Nenapadá mi jak to vyřešit. Debian Stretch.

reklama


Matěj

Re:Nastavení hdparm při bootu
« Odpověď #1 kdy: 16. 02. 2017, 23:50:41 »
Co máte v /etc/hdparm.conf a nemáte čistě náhodou v kernel command line volbu nohdparm?
Konfigurák sem samozřejmě nemusíte dávat celý, stačí bez komentářů a bez prázdných řádků:
Kód: [Vybrat]
egrep -v '^#|^$' /etc/hdparm.conf

drobaxis

Re:Nastavení hdparm při bootu
« Odpověď #2 kdy: 16. 02. 2017, 23:56:46 »
Kód: [Vybrat]
/dev/sda {
apm = 200
apm_battery = 200
}
Citace
/dev/sda:
 APM_level   = 128

drobaxis

Re:Nastavení hdparm při bootu
« Odpověď #3 kdy: 17. 02. 2017, 00:02:26 »
Nee. V /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

Lol Phirae

Re:Nastavení hdparm při bootu
« Odpověď #4 kdy: 17. 02. 2017, 00:05:53 »
Nee. V /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

Heeeeeeeee???


drobaxis

Re:Nastavení hdparm při bootu
« Odpověď #5 kdy: 17. 02. 2017, 00:21:56 »
Nee. V /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

Heeeeeeeee???
Kód: [Vybrat]
linux /boot/vmlinuz-4.9.0-1-amd64 root=UUID=f4a8e3f7-468b-4c5a-b7d9-ca3df2dc57b4 ro  quiet

Re:Nastavení hdparm při bootu
« Odpověď #6 kdy: 17. 02. 2017, 01:40:13 »
Hm, zkoušel jste to dát do /etc/rc.local ?
Případně bych zkusil ve skriptu /lib/udev/hdparm přesměrovat výstup někam do logu.
Kód: [Vybrat]
# nahraďte řádek
/sbin/hdparm $OPTIONS $DEVNAME 2>/dev/null
# třeba tímto
/sbin/hdparm $OPTIONS $DEVNAME 2>/var/log/hdparm.log
restartovat a log zkontrolovat zda nebudete moudřejší.
Případně zkontrolujte co vypíše toto:
Kód: [Vybrat]
udevadm test /sys/class/block/sdaBohužel vařím z vody, protože nemám debian ani disk který by podporoval apm.

Lol Phirae

Re:Nastavení hdparm při bootu
« Odpověď #7 kdy: 17. 02. 2017, 02:25:36 »
Nee. V /etc/default/grub:
GRUB_CMDLINE_LINUX_DEFAULT="quiet"
GRUB_CMDLINE_LINUX=""

Heeeeeeeee???
Kód: [Vybrat]
linux /boot/vmlinuz-4.9.0-1-amd64 root=UUID=f4a8e3f7-468b-4c5a-b7d9-ca3df2dc57b4 ro  quiet

A co jako????

Lol Phirae

Re:Nastavení hdparm při bootu
« Odpověď #8 kdy: 17. 02. 2017, 02:33:06 »
Hm, zkoušel jste to dát do /etc/rc.local ?

To by to soudruh LP nesměl rozmrdat...

http://forums.debian.net/viewtopic.php?f=5&t=124740

JardaP .

  • *****
  • 7 854
    • Zobrazit profil
    • E-mail
Re:Nastavení hdparm při bootu
« Odpověď #9 kdy: 17. 02. 2017, 18:35:17 »
To by to soudruh LP nesměl rozmrdat...

Jestli soudruhovi LP nekdo co nejdrive neurazi pracky az u p​r​d​e​le, tak za chvili nepujdou uz ani piskvorky. :-(

 

reklama