reklama

DansGuardian Centos7 dependency issue

TomasPe

DansGuardian Centos7 dependency issue
« kdy: 14. 10. 2015, 15:25:39 »
Snazim se na Centos7 rozchodit Dansguardian, ale nemuzu prejit pres dependency issue.

Kód: [Vybrat]
error: Failed dependencies:
        libpcre.so.0 is needed by dansguardian-2.10.1.1-1.el6.rf.i686
        libz.so.1 is needed by dansguardian-2.10.1.1-1.el6.rf.i686

Kód: [Vybrat]
/usr/lib/libpcre.so.1.2.0
/usr/lib/libpcre16.so.0
/usr/lib/libpcre16.so.0.2.0
/usr/lib/libpcre32.so.0
/usr/lib/libpcre32.so.0.0.0
/usr/lib/libpcrecpp.so.0
/usr/lib/libpcrecpp.so.0.0.0
/usr/lib/libpcreposix.so.0
/usr/lib/libpcreposix.so.0.0.1
/usr/lib/libpcre.so.1


Kód: [Vybrat]
rpm -qa | grep pcre
pcre-8.32-14.el7.i686
pcre-8.32-14.el7.x86_64
pcre-devel-8.32-14.el7.x86_64


Kód: [Vybrat]
yum repolist all  | grep enabled
base/7/x86_64                 CentOS-7 - Base                    enabled:  8,652
*epel/x86_64                  Extra Packages for Enterprise Linu enabled: 11,780
*epel-source/x86_64           Extra Packages for Enterprise Linu enabled:      0
extras/7/x86_64               CentOS-7 - Extras                  enabled:    214
glusterfs-epel/7/x86_64       GlusterFS is a clustered file-syst enabled:     14
glusterfs-noarch-epel/7       GlusterFS is a clustered file-syst enabled:      2
updates/7/x86_64              CentOS-7 - Updates                 enabled:  1,505

yum clean all apod. nepomaha

reklama


Danny

Re:DansGuardian Centos7 dependency issue
« Odpověď #1 kdy: 14. 10. 2015, 15:41:39 »
co takhle takovahle prasarnicka:

Kód: [Vybrat]
ln -s /usr/lib/libpcre.so.1 /usr/lib/libpcre.so.0
ln -s /usr/lib/libz.kterou.tam.mas /usr/lib/libz.so.1
ldconfig

a pak instalovat dansguardian s --nodeps

TomasPe

Re:DansGuardian Centos7 dependency issue
« Odpověď #2 kdy: 14. 10. 2015, 16:32:15 »
Nevim jestli obchazet zavislosti je uplne nejlepsi reseni. Prece jenom nevim k cemu ty libky pouziva

 

reklama