Síť funguje jen ve vnitřní síti

Síť funguje jen ve vnitřní síti
« kdy: 03. 11. 2010, 08:32:29 »
Ahojte

Mám v práci Ubuntu. Včera aj dnes ráno sa mi stalo to isté: po nakopnutí mi išla iba vnútorná sieť (192.168.*.*), ale von som sa nedostal, až do reštartu.
Čo to kua je?

// veľmi som váhal, do ktorej kategórie to hodiť, pretože neviem, s čím mám vlastne problém
« Poslední změna: 03. 11. 2010, 13:49:47 od Petr Krčmář »


trubicoid2

Re: sieť funguje riadne až po reboote
« Odpověď #1 kdy: 03. 11. 2010, 10:28:13 »
no a neni to problem s DNS? co to udela, kdyz das ping www.google.com? a ping pocitac.ve.vnitrni.siti?

Re: sieť funguje riadne až po reboote
« Odpověď #2 kdy: 03. 11. 2010, 10:47:46 »
vnútorné pingám, vonkajšie nepingám, ale nepingám ich ani keď dám priamo ipčku, píše unknown host [ipčka]

aaa

Re: sieť funguje riadne až po reboote
« Odpověď #3 kdy: 03. 11. 2010, 11:01:50 »
co ti da ipconfig na vsetkych interfacoch a "route -ne" (ak tieto prikazy funguju na Ubuntu..)
vyzera ze si "stratil" interface / route na vonkajsiu siet

Re: sieť funguje riadne až po reboote
« Odpověď #4 kdy: 03. 11. 2010, 11:13:42 »
toto budem musieť skúsiť zase až zajtra ráno, potom dám vedieť


Re: Síť funguje jen ve vnitřní síti
« Odpověď #5 kdy: 03. 11. 2010, 16:01:45 »
Tak, a stalo sa mi to znova. Nachvílu som vypol a zapol sieť (čiže teraz to nebolo hneď po nabootovaní). route -ne dáva rovnaký výsledok keď to funguje aj keď nefunguje

PCnity

  • *****
  • 680
    • Zobrazit profil
    • E-mail
Re: Síť funguje jen ve vnitřní síti
« Odpověď #6 kdy: 03. 11. 2010, 16:31:12 »
Pusti toto a NAPIS NAM SEM VYSTUP:

clear && ping -c3 google.sk && ping -c3 74.125.39.105 && route -n && ip a && mii-tool

Kaštan

Re: Síť funguje jen ve vnitřní síti
« Odpověď #7 kdy: 03. 11. 2010, 17:31:31 »
Já jsem měl něco podobného.
Ubuntu 10.10.
Všechno fungovalo a pak bez příčiny nešel internet. Lokální síť fungovala beze změny.
Zkusil jsem DNS. Příkaz dig odpovídal po dlouhé době, asi 1-2 sekundy, ale vypisoval odezvu v ms. Takže DNS fungovaly, ale divně. To byla záhada. Dokonce jsem i restartoval počítač. Ani to nepomohlo. A pak jsem si všiml ve výpisu ip r, že mi chybí brána. Zvláštní je že DNS-ka stále fungovaly. Bránu jsem znovu zadal a najednou začal chodit internet.
Potom jsem raději nastavil přidělování adres podle DHCP a počítači jsem nastavil fixní IP.
« Poslední změna: 05. 11. 2010, 09:02:04 od Petr Krčmář »

maestrx

Re: Síť funguje jen ve vnitřní síti
« Odpověď #8 kdy: 04. 11. 2010, 09:58:01 »
Nemas nastavenou vychozi branu. "ip r a default via <IP>"

PCnity

  • *****
  • 680
    • Zobrazit profil
    • E-mail
Re: Síť funguje jen ve vnitřní síti
« Odpověď #9 kdy: 04. 11. 2010, 11:42:59 »
Presne preto chceme vidiet vystupy z toho hore! Podla toho sa da zistit ci ma gw nastaveny.

Re: Síť funguje jen ve vnitřní síti
« Odpověď #10 kdy: 04. 11. 2010, 14:09:06 »
Fiha, teraz pozerám do nm-connection-editor a on hovorí, že mám dve spojenia - jedno Auto Ethernet bez MAC adresy a druhé Auto eth0 s MAC adresou.
Dnes ráno tá chyba nenastala =-o

PCnity

  • *****
  • 680
    • Zobrazit profil
    • E-mail
Re: Síť funguje jen ve vnitřní síti
« Odpověď #11 kdy: 04. 11. 2010, 16:37:47 »
Pozeraj radsej na "ip a"...

Re: Síť funguje jen ve vnitřní síti
« Odpověď #12 kdy: 05. 11. 2010, 08:23:17 »
Ha a som tu zas, dnes ráno to isté
Kód: [Vybrat]
$ ping -c3 google.sk
PING google.sk (74.125.43.99) 56(84) bytes of data.

--- google.sk ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2014ms

$ ping -c3 74.125.39.105
PING 74.125.39.105 (74.125.39.105) 56(84) bytes of data.

--- 74.125.39.105 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2015ms

$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.0.0.0        0.0.0.0         255.255.0.0     U     1      0        0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 eth0
0.0.0.0         10.0.ano.nym    0.0.0.0         UG    0      0        0 eth0

$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
    dnet 1.10/16 scope host lo
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether aa:00:04:00:0a:04 brd ff:ff:ff:ff:ff:ff
    inet 10.0.ano.nym2/16 brd 10.0.255.255 scope global eth0
    inet6 fe80::a800:4ff:fe00:a04/64 scope link
       valid_lft forever preferred_lft forever
    dnet 1.10/16 scope global eth0

$ sudo mii-tool
eth0: negotiated 100baseTx-FD flow-control, link ok

// Porovnal som si tieto výstupy s tými po reštarte a je rozdiel v "ip a" - inet a inet6 sú úplne iné ipčky
« Poslední změna: 05. 11. 2010, 08:29:20 od rooobertek »

PCnity

  • *****
  • 680
    • Zobrazit profil
    • E-mail
Re: Síť funguje jen ve vnitřní síti
« Odpověď #13 kdy: 05. 11. 2010, 12:56:11 »
Skus este toto:

ping -c5 10.0.ano.nym

Inak cudna "naming convention" 10.0.ano.nym je gw a 10.0.ano.nym2 je tvoja host adresa... Ked ti net ide tak mas inet adresu inu ako ked nejde? Zeby DHCP issue? Vypni sluzbu network manager a nastav si adresy fix.
« Poslední změna: 05. 11. 2010, 12:58:17 od PCnity »

Re: Síť funguje jen ve vnitřní síti
« Odpověď #14 kdy: 05. 11. 2010, 13:10:27 »
jednu pingujem, druhu nie
« Poslední změna: 05. 11. 2010, 13:25:11 od rooobertek »