reklama

Nesplněné závislosti php5-gd

Crash

Nesplněné závislosti php5-gd
« kdy: 10. 02. 2015, 22:20:36 »
Zdravím,
 pokouším se nainstalovat php5-gd, ale hází mi to chybu:
Kód: [Vybrat]
Následující balíky mají nesplněné závislosti:
 php5-gd : Závisí na: php5-common (= 5.5.9+dfsg-1ubuntu4.5) ale 5.5.19+dfsg-1+deb.sury.org~precise+1 se bude instalovat
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.
Je nějaký jednoduchý způsob jak to opravit ? Nechci tu knihovnu instalovat ručně. Díky
« Poslední změna: 10. 02. 2015, 22:54:03 od Petr Krčmář »

reklama


JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Nesplněné závislosti
« Odpověď #1 kdy: 10. 02. 2015, 22:39:51 »
Zkuste znovu apt-get update. Pokud nepomuze, zkuste zitra, treba si to zatim opravi. Pokud ne, prejdete na Debian, protoze v Blbuntu takovychto problemu je docela dost a nikdo je zretelne neresi. I kdyz u PHP by mohli, protoze hodne lidi bude nadavat.

Crash

Re:Nesplněné závislosti
« Odpověď #2 kdy: 10. 02. 2015, 23:05:40 »
Zkuste znovu apt-get update. Pokud nepomuze, zkuste zitra, treba si to zatim opravi. Pokud ne, prejdete na Debian, protoze v Blbuntu takovychto problemu je docela dost a nikdo je zretelne neresi. I kdyz u PHP by mohli, protoze hodne lidi bude nadavat.
:D :D :D
No něco jistějšího by nebylo ?

Lol Phirae

Re:Nesplněné závislosti php5-gd
« Odpověď #3 kdy: 10. 02. 2015, 23:20:07 »
Prosimtě, co sis to tam narval za repo? 5.5.19+dfsg-1+deb.sury.org~precise+1  :o

Jimm

Re:Nesplněné závislosti php5-gd
« Odpověď #4 kdy: 10. 02. 2015, 23:25:01 »
Jarda řeší problém se závislostmi změnou distribuce? Tak to jsou zase pecky.  :)

Btw, ta čeština v shellu je boží, to musí být žrádlo s tím pracovat.

reklama


Lol Phirae

Re:Nesplněné závislosti php5-gd
« Odpověď #5 kdy: 10. 02. 2015, 23:32:51 »
Btw, ta čeština v shellu je boží, to musí být žrádlo s tím pracovat.

Jo, nekonečná lábuž... Tohle nikdy nepochopím.

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Nesplněné závislosti php5-gd
« Odpověď #6 kdy: 11. 02. 2015, 00:46:01 »
Jarda řeší problém se závislostmi změnou distribuce? Tak to jsou zase pecky.  :)

Hele, par verzi tomu nazad byl v Blbuntu Claws Mail a k tomu pluginy pro jinou verzi. V Canonicalu to nikomu nevadilo a tak to tak zustalo az do pristi verze. Co s tim jako chces delat? Kompilovat ze zdrojaku a delat si vlastni .deb? Na to se muzu vysrat, kdyz v Debianu se mi to pravdepodobne nestane a pokud ano, dlouho to tam tak nezustane. V Debianu se takove veci stavaji tak leda v testingu, obvykle to tam vydrzi nejdele par dni a je to opravene. Blbuntu je pak postavene na unstable, coz je jeste horsi zaklad pro stabilni distro, nez testing. Hlavne, ze mame ten bleading edge software s nejmodernejsimi bugy. Dospel jsem k zaveru, ze Blbuntu neni distro, ale sracka, takze nemenim distro, ale menim sracku za distro. Na Blbuntu je dobre leda tak to, ze ma snazsi instalator a ma update manager, ktery cloveku porad pripomina, ze nema zanebavat updaty. Na druhou stranu i v LTS je tech updatu kazdou chvili hafo, mnohem vice, nez v Debianu stable. S Blbuntu LTS ma clovek nekolikrat do roka pocit, ze dela distupgrade.

Jimm

Re:Nesplněné závislosti php5-gd
« Odpověď #7 kdy: 11. 02. 2015, 03:04:00 »
Nic proti, já mám na desktopu Ubuntu a jsem absolutně spokojený, s tím že přecházím na nejnovější distro už tak dva měsíce před vydáním. Občas je problém se závislostí, ale ne často a obvykle je to za pár minut vyřešené. Ovšem mluvím jen o desktopu, například to zmiňované php tady nemám, od toho je server a tam nemá Ubuntu co dělat. :) Tedy je na Ubuntu pár věcí které mě štvou, ale na jiných distrech jsou zase jiné problémy. :)

Kolemjdoucí

Re:Nesplněné závislosti php5-gd
« Odpověď #8 kdy: 11. 02. 2015, 08:04:22 »
Je nějaký jednoduchý způsob jak to opravit ? Nechci tu knihovnu instalovat ručně. Díky

Šťoural jsi se v tom a pokazil jsi to. Je nutno opravit /etc/apt/sources.list a pak třeba celé php odinstalovat a nainstalovat znovu.

robin martinez

  • *****
  • 855
  • Have you hugged your toilet today?
    • Zobrazit profil
    • Null Storage
    • E-mail
Re:Nesplněné závislosti php5-gd
« Odpověď #9 kdy: 11. 02. 2015, 08:25:04 »
Prosimtě, co sis to tam narval za repo? 5.5.19+dfsg-1+deb.sury.org~precise+1  :o

PHP balíčky od Ondry Surého jsou v pohodě, je to repo pro poslední verze PHP.

ad problém - co na to místo apt-get zkusit vzít aptitude, občas mi nabídne možnosti, jak problém vyřešit. Ale problém bude asi v tom, že jsi tam měl nějaký php, pak si tam narval repozitáře od Surého, dal instalovat něco dalšího a balíčky se teď mlátí. Takže celý PHP odinstalovat a nainstalovat znova
One machine can do the work of fifty ordinary men. No machine can do the work of one extraordinary man.

I do Linux, Hardware and spaghetti code in PHP, Python and JavaScript

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Nesplněné závislosti php5-gd
« Odpověď #10 kdy: 11. 02. 2015, 10:23:32 »
Tedy je na Ubuntu pár věcí které mě štvou, ale na jiných distrech jsou zase jiné problémy. :)

Zkuste Kanotix. Zalozeno na Debianu stable. Instalace je ponekud drevni, ale po instalaci to zatim vypada, ze me na tom nic nestve. Uvidime.

Lol Phirae

Re:Nesplněné závislosti php5-gd
« Odpověď #11 kdy: 11. 02. 2015, 12:02:42 »
Prosimtě, co sis to tam narval za repo? 5.5.19+dfsg-1+deb.sury.org~precise+1  :o

PHP balíčky od Ondry Surého jsou v pohodě, je to repo pro poslední verze PHP.

Evidentně v daném případě ne  :D

Takže celý PHP odinstalovat a nainstalovat znova

No, asi tak nějak nejrychlejší řešení.

robin martinez

  • *****
  • 855
  • Have you hugged your toilet today?
    • Zobrazit profil
    • Null Storage
    • E-mail
Re:Nesplněné závislosti php5-gd
« Odpověď #12 kdy: 11. 02. 2015, 12:14:40 »

Evidentně v daném případě ne  :D



já s nima teda nikdy problém neměl :D
One machine can do the work of fifty ordinary men. No machine can do the work of one extraordinary man.

I do Linux, Hardware and spaghetti code in PHP, Python and JavaScript

 

reklama