reklama

Síť nefunguje přes Wi-Fi

beda

Síť nefunguje přes Wi-Fi
« kdy: 19. 09. 2014, 15:01:00 »
Ahoj, nefunguje mi pripojeni na internet pres Wifi. Mam doma router, pokud se k nemu pripojim dratem, tak to funguje, stejne tak bezdratove pripojeni z ostatnich pocitacu. NetworkManager mi ukazuje, ze jsem na domaci sit pripojen pres Wifi. Wifi jsem zkousel jeste na jedne siti a ani tam nefungovala. Operacni system je Debian. Zkousel jsem 'ping 8.8.8.8', coz mi pise 'Destination Host Unreachable'. Dal jsem zkousel 'traceroute 8.8.8.8', coz mi vraci same hvezdicky.   
Vystup prikazu 'route':
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default            *                     0.0.0.0              U     1002   0        0 eth0
default            192.168.0.1     0.0.0.0             UG    1024   0        0 wlan0
link-local         *                    255.255.0.0        U      0       0        0 eth0
192.168.0.0     *                    255.255.255.0    U      0        0        0 wlan0

Nevite nekdo, jak by se to dalo vyresit? Dekuju za odpovedi
 
« Poslední změna: 19. 09. 2014, 22:25:07 od Petr Krčmář »

reklama


JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Nefunkcni Wifi
« Odpověď #1 kdy: 19. 09. 2014, 15:45:51 »
Muzete pingnout gateway?

Dzavy

Re:Nefunkcni Wifi
« Odpověď #2 kdy: 19. 09. 2014, 15:58:02 »
Podle je me bude problem v tomhle radku:

default            *                     0.0.0.0              U     1002   0        0 eth0

To skoro vypada, ze defaultni gw je primo eth0 - ktere je porad up (U), tj. se nikdy nevyuzije dalsi routa v poradi, pres wifi.
Kdyz tuhle routu via eth0 smazes a nechas si jenom tu od DHCP, melo by to byt OK.

beda

Re:Nefunkcni Wifi
« Odpověď #3 kdy: 19. 09. 2014, 16:37:03 »
Jarda:
Ping 192.168.0.1 (to je predpokladam gateway) nepise nic, respektive 100% packet loss.

Dzavy:
Radku jsem odstranil, ale porad to nefunguje. Chova se to v podstate stejne, akorat ping 8.8.8.8 nepise uz vubec nic, jenom 100% packet loss.

Dzavy

Re:Nefunkcni Wifi
« Odpověď #4 kdy: 19. 09. 2014, 17:12:24 »
A jak ted vypada Tvoje routovaci tabulka? A prihod i to, jak vypada, kdyz jsi k tomu samymu routeru pripojen kabelem a funguje to.

reklama


beda

Re:Nefunkcni Wifi
« Odpověď #5 kdy: 19. 09. 2014, 17:44:16 »
Kdyz jsem pripojeny pres drat:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default           192.168.0.1     0.0.0.0          UG        0        0        0 eth0
default           192.168.0.1     0.0.0.0          UG        1024   0        0 wlan0
link-local           *               255.255.0.0       U         1000   0        0 eth0
192.168.0.0       *               255.255.255.0   U         0        0        0 eth0
192.168.0.0       *               255.255.255.0   U         0        0        0 wlan0

Po vymazani radky, kdyz nejsem pripojen pres drat a Wifi nefunguje:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default           192.168.0.1     0.0.0.0                 UG    1024     0        0 wlan0
link-local           *                 255.255.0.0           U      0          0        0 eth0
link-local           *                 255.255.0.0           U      1000     0        0 wlan0
192.168.0.0       *                 255.255.255.0       U      0          0        0 wlan0


Dzavy

Re:Nefunkcni Wifi
« Odpověď #6 kdy: 19. 09. 2014, 17:59:55 »
A jeste ukaz vypis "ifconfig", "iwconfig" a "iptables --list". Zatim me nic nenapada...

beda

Re:Nefunkcni Wifi
« Odpověď #7 kdy: 19. 09. 2014, 18:20:26 »
ifconfig:
eth0      Link encap:Ethernet  HWaddr 44:1e:a1:79:c1:24 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:123388 errors:0 dropped:0 overruns:0 frame:0
          TX packets:84056 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:155668489 (148.4 MiB)  TX bytes:8754046 (8.3 MiB)

eth0:avahi Link encap:Ethernet  HWaddr 44:1e:a1:79:c1:24 
          inet addr:169.254.7.132  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:1153 errors:0 dropped:0 overruns:0 frame:0
          TX packets:1153 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:91200 (89.0 KiB)  TX bytes:91200 (89.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 44:6d:57:9b:a9:de 
          inet addr:192.168.0.101  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::466d:57ff:fe9b:a9de/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:503 errors:0 dropped:0 overruns:0 frame:0
          TX packets:3796 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:58080 (56.7 KiB)  TX bytes:418875 (409.0 KiB)



iwconfig:
eth0      no wireless extensions.

lo        no wireless extensions.

wlan0     IEEE 802.11bgn  ESSID:"Brambora" 
          Mode:Managed  Frequency:2.472 GHz  Access Point: 6C:19:8F:BA:67:EA   
          Bit Rate=72.2 Mb/s   Tx-Power=16 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=50/70  Signal level=-60 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:1   Missed beacon:0



iptables --list:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         

Vsechno kdyz nejsem pripojeny kabelem.

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Síť nefunguje přes Wi-Fi
« Odpověď #8 kdy: 19. 09. 2014, 23:14:50 »
Ja mam u sebe jen tohle:

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.1.1     0.0.0.0         UG    0      0        0 wlan0
192.168.1.0     *               255.255.255.0   U     9      0        0 wlan0
 
Zkuste u sebe vymazat ty dva radky s link-local, zejmena ten s eth0 na konci.

beda

Re:Síť nefunguje přes Wi-Fi
« Odpověď #9 kdy: 20. 09. 2014, 13:39:28 »
Radek s eth0 na konci jsem vymazal, ten druhy jsem vymazat neumel. Stejne to nefungovalo. Zda se mi, ze problem bude nekde jinde.

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Síť nefunguje přes Wi-Fi
« Odpověď #10 kdy: 20. 09. 2014, 18:58:10 »
Jde ten stroj pingnout ze site? Jde pingnout z gatewaye? Nekde na to byva opicka ve webovem rozhrani.

beda

Re:Síť nefunguje přes Wi-Fi
« Odpověď #11 kdy: 23. 09. 2014, 11:49:04 »
Dekuju za pomoc, uz to nejak funguje, alespon obcas. Zacalo to fungovat, kdyz jsem nainstaloval Wicd Network Manager, coz moc nechapu, ale je to tak.

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Síť nefunguje přes Wi-Fi
« Odpověď #12 kdy: 23. 09. 2014, 12:54:02 »
@beda: To je docela mozne. Ja kdysi na Buntu take jel s Wicd, protoze mi Network Manager s jednou z wifin, ktere jsem pouzival, nechtel fungovat. BTW, ve Wicd se da zapnout logovani. Takze pokud to funguje pouze "nejak", tak by mozna stalo za to to zapnout a mrknout do logu, co se deje.

 

reklama