reklama

Špatná grafika forum.root.cz v prohlížeči Opera

Špatná grafika forum.root.cz v prohlížeči Opera
« kdy: 14. 05. 2010, 12:42:07 »
Zdravim,

za posledni 2 tydny se mi uz par krat stalo, ze se v podstate nezobrazuje zadna gafika.
Bile pozadi, zakladni fonty a vsechno nahazene na leve strane.
Zajimavosti je, ze se stranka nekdy zobrazi spatne a kdyz se po mem prihlaseni prepne do tmaveho skinu, tak se vsechno zobrazi jak ma. Dnes to bylo ale obracene, po nacteni v pohode a po prihlaseni spatne. Smaznul jsem vsechny cookies, restartoval Operu a od te doby je forum zobrazuje spatne bez ohledu na to jestli jsem prihlasen.
Nevite co s tim? Pripadne chcete neco poslat nebo upresnit?
Problem je jenom v konfiguraci WinXP SP3 a Opera 10.50-3. U IE8 jsem se s tim nesetkal.
Diki...

reklama


Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #1 kdy: 14. 05. 2010, 12:49:48 »
Takové záhadné chyby jsou nejhorší, protože pokud se to nestává nikomu z nás (jakože nestává), tak nejsme schopni to vyzkoušet a zjistit, kde přesně je problém. Dají se udělat alespoň screenshoty? Nebo zkusit stránku uložit a z disku ji otevřít v jiném prohlížeči, abychom vyloučili, že něco nezapomněl podat server? Pokud je problém skutečně jen v Opeře a jen někdy, pak bych prosil tu stránku uložit (i se vším okolo), zabalit a přiložit tady do fóra. Aby bylo co zkoumat.

Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #2 kdy: 14. 05. 2010, 14:01:04 »
Pokud stranku ulozim v Opere jako .htm a otevru v IE tak vsechno vypada jak ma. Primarne mi vsak Opera nabizi straknu ulozit jako .mht (web archive) ktery kdyz otevru v IE tak zobrazi jenom text s kodem.
Pripajim .zip s obema verzema a screenshot pak k dalsi reakci jakozto se sem uz nevleze.

Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #3 kdy: 14. 05. 2010, 14:02:02 »
A Obrazek jak hezky to vypada :)

Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #4 kdy: 14. 05. 2010, 14:04:44 »
Aha, to vypadá, že prohlížeč nedostane od serveru CSS. V jiných prohlížečích se to opravdu nestává?

reklama


Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #5 kdy: 14. 05. 2010, 14:16:41 »
Mam instalovane jenom IE8 a Operu. IE8 s tim potize nema. Pokud je problem v CSS tak zkusim obejit proxynu, jestli to pomuze.

Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #6 kdy: 14. 05. 2010, 14:20:35 »
Mimo proxy se to chova stejne, takze tam to nebude :(

sheeryjay

Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #7 kdy: 14. 05. 2010, 14:23:48 »
U mě se podobný problém stává občas také, ač častěji spíše na Abíčku a ve Firefoxu. Co jsem odpozoroval bývá to zejména když otevírám session prohlížeče ve kterém před vypnutím bylo otevřeno třeba 100 tabů (a ten je tedy začne znovu otevírat) a z nějakého důvodu zapomene načíst (nenačte) CSS (případně jiné soubory). Problém následně přetrvává protože FF má v cachi uloženo že dané CSS má přece délku 0 a již jej nestahuje.
I pokud u původního tazatele nejde o podobný problém, mohlo by pomoci znovunačíst stránku s přepsáním cache (ve Firefoxu např. ctrl+shift+R či ctrl+F5, v Opeře možná default jak asi plyne z http://en.wikipedia.org/wiki/Bypass_your_cache#Opera  ).

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #8 kdy: 14. 05. 2010, 14:31:24 »
Tohle uz jsem parkrat videl ve FF i v Chrome nebo Konqueroru. Typicky to resi reload. Ve FF mi to root obcas delal jiz pred lety.

Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #9 kdy: 14. 05. 2010, 14:38:43 »
Ja uz jsem reloadoval, redirectoval, recashoval a furt nic :(

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #10 kdy: 14. 05. 2010, 16:30:20 »
Ja uz jsem reloadoval, redirectoval, recashoval a furt nic :(

Zkousel jste Opere rucne vybilit disk cache?

Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #11 kdy: 14. 05. 2010, 16:49:23 »
Jardo nevykej mi nebo ti flaknu jednu pres to forum  ;)

A diki za radu. Povedlo se mi to opravit, ale porad je to bud alebo.
Teda kdyz jsem prihlasen tak je vsecho ok, ale jak dam odhlasit tak je to zase v zadeki. Tim cistenim cashky se to da alespon konfigurovat (zmenit na tu druhou variantu) a to mi zatim k tomu aby se to tady dalo cist a odepisovat staci.
Díki taky panu Krčmářovi za spolupráci...

.

Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #12 kdy: 14. 05. 2010, 23:50:39 »
Používáš blokování obsahu, nebo vlastní stylování (ne nutně pro root.cz) ?

Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #13 kdy: 17. 05. 2010, 16:51:58 »
To s blokováním obsahu mě nenapadlo, ale je to dobrá připomínka. V minulosti se stávalo, že občas něco nefungovalo a pak se ukázalo, že si čtenář přeblokoval obsah tak, že se odřízl od našich důležitých domén, ze kterých distribuujeme CSS nebo třeba obrázky.

Re: Špatná grafika forum.root.cz v prohlížeči Opera
« Odpověď #14 kdy: 18. 05. 2010, 10:55:52 »
Obcas zablokuju neaky obsah jako treba reklamy ktere prudi, ale na root.cz jsem zatim nic neblokoval. Je mozne, ze to prece jenom dela ta proxyna ktera obcas neco blokne a za par vterin na ten samej pozadavek reaguje bez problemu. Pokazde kdyz se to stane, coz je temer kazdy den, tak pomaha vyklidit celou cache. Zajimave je, ze kdyz dam stranku nacist znovu ale ne z cache tak se nacte spatne, ale kdyz cache vyklidim a dam jakykoliv reload, tak se stranka nacte spravne (ne po kazde - proxy?). Az mam tuseni ze jde o bug v Opere, protoze ma stranku nacist bez ohledu na cache a nedela to.

 

reklama