Vhodný Raspberry Pi OS pro RPi 5 4GB

Vhodný Raspberry Pi OS pro RPi 5 4GB
« kdy: 20. 02. 2024, 15:05:18 »
Zdravím.
Tak mi to nedalo a koupil Raspberry Pi 5 4GB a jsem ve stavu očekavaní.

O vanocich jsem si chtěl po dlouhem čase udělat update meho raspi 4B a nacpal na SD kartu Raspios-bookworm 64 bit 2023-12-05
Byla to hruza. Disky se mi samy odpojovaly a DVB-T2 tuner se mi ztracel. Furt jsem jen restartoval raspi.
Po týdnu jsem to vzdal a nacpal tam raspios-bullseye-armhf 32 bit 2023-05-03 a od te doby jede bez problemu bez restartu raspi.

Tak by mně zajimalo, co mohu očekavat na tom pi 5 a co za raspios použit ?

Raspios-bookworm 64 bit 2023-12-05 už asi ne.
Tak uvažují zda zkusit 64 bit bullseye, nebo zustat na 32 bit bullseye.
O kolik pomalejši to bude, když zustanu u 32 bit systemu?
Děkují.
« Poslední změna: 20. 02. 2024, 15:48:44 od Petr Krčmář »


Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #1 kdy: 20. 02. 2024, 17:54:12 »
Chápu tvé nadšení, ale Raspberry je hlavně univerzální vývojová deska.
Ano, dá se použít na koncové projekty, ale pak máš odlazené na to aplikace, a nebo použij Raspbian (PI OS).

Já jsem na tom chtěl používat Zabbix, a monitorovat LAN sítě atd.
Nějak jsem z toho vychladl a pořídil za stejnou cenu NUCy.
Ale snaha z mé strany byla.

Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #2 kdy: 20. 02. 2024, 18:06:32 »
Promin, ale ja nechapu, proč tu někdo vždy muj dotaz změní tak, že nedava smysl.
Nikdy jsem nepoužival nic jineho než ten Raspbian (PI OS).
https://www.raspberrypi.com/software/operating-systems/

Takže mi jde o to, zda použit ten nej Debian version: 12 (bookworm)?
Nebo radějí jit do něčeho staršiho Debian version: 11 (bullseye)?

A zda ma cenu jít do 64-bit verze.
O kolik je rychlejši, než 32-bit verze.

Zopper

  • *****
  • 665
    • Zobrazit profil
Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #3 kdy: 20. 02. 2024, 18:54:39 »
Ve většině případů je 64bit systém na 64bitovém železe o něco rychlejší, pro rpi nějaké testy například tady: https://www.phoronix.com/review/raspberrypi-os-64bit/2

Pokud ti v tom nebrání nějaké časové omezení, tak klidně zkus Debian 12. Debian 11 má podporu do léta, takže za tři, čtyři měsíce bys stejně začal řešit přechod na 12.

Le_Ze

  • ***
  • 113
    • Zobrazit profil
    • E-mail
Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #4 kdy: 22. 02. 2024, 09:46:31 »
Jsem zkoušel 32 bit raspios-bookworm a mam problemy.
Co obconf?
Nic jsem neinstaloval, takže je už předinstalovany.

« Poslední změna: 22. 02. 2024, 09:49:32 od Le_Ze »


Le_Ze

  • ***
  • 113
    • Zobrazit profil
    • E-mail
Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #5 kdy: 22. 02. 2024, 10:06:56 »
Jsem ten obconf začal řešit, protože vím, že se tam da nastavit i vlastnosti myši.
https://youtu.be/opHC7zMD1r4

Děla to jen přes vzdalenou plochu přes vncviewer jak v počitači s win, tak i na tabletu.

Proč moje šipka nemuže dohonít tu tečku?
Mi to docela vadi. Da se to nějak pořešit?
Děkují.

Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #6 kdy: 22. 02. 2024, 14:06:16 »
Zdravím.
Tak mi to nedalo a koupil Raspberry Pi 5 4GB a jsem ve stavu očekavaní.

O vanocich jsem si chtěl po dlouhem čase udělat update meho raspi 4B a nacpal na SD kartu Raspios-bookworm 64 bit 2023-12-05
Byla to hruza. Disky se mi samy odpojovaly a DVB-T2 tuner se mi ztracel. Furt jsem jen restartoval raspi.
Po týdnu jsem to vzdal a nacpal tam raspios-bullseye-armhf 32 bit 2023-05-03 a od te doby jede bez problemu bez restartu raspi.

Tak by mně zajimalo, co mohu očekavat na tom pi 5 a co za raspios použit ?

Raspios-bookworm 64 bit 2023-12-05 už asi ne.
Tak uvažují zda zkusit 64 bit bullseye, nebo zustat na 32 bit bullseye.
O kolik pomalejši to bude, když zustanu u 32 bit systemu?
Děkují.

zkoušel jsi něco jiného, třeba xfce4-terminal?

v mc ctrl-0 používám bez problémů i na 22.04

Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #7 kdy: 22. 02. 2024, 20:31:11 »
Koukněte na https://dietpi.com - mám dobrou zkušenost.

Le_Ze

  • ***
  • 113
    • Zobrazit profil
    • E-mail
Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #8 kdy: 24. 02. 2024, 11:23:46 »
Tak jsem zjistil, že za toto muže vncviewer.
https://www.youtube.com/watch?v=opHC7zMD1r4
I když před par dny vyšla verze 7.10.0, tak to problem nevyřešilo.
Přes  TigerVNC to jede normalně.

obconf v prostředi Wayland fakt nefunguje.
https://github-com.translate.goog/lxqt/obconf-qt/issues/217?_x_tr_sl=en&_x_tr_tl=cs&_x_tr_hl=cs

Je něco misto toho?
Jak vytvořit vice pracovních ploch?
Děkují.



Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #9 kdy: 24. 02. 2024, 19:42:44 »
Neviem presne co na tom RPI 5 chces spustat, ale ja mam velmi dobre skusenosti s Ubuntu na RPI v4. Bezi mi to na RPI v4 pod 20.04 v pohode.

Podla https://ubuntu.com/download/raspberry-pi je Ubuntu 23.10 kompatibilne s RPI v5, ale neviem do akej miery. Mozes ked tak skusit.

Le_Ze

  • ***
  • 113
    • Zobrazit profil
    • E-mail
Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #10 kdy: 24. 02. 2024, 21:05:50 »
Matho23 - mi zas nejde o system jaky tam bude ale o kontabilitu.
Linux není se mnou moc velky kamard a vždy, když přejdu na novou verzi, tak dost bojují.
Spiš eletrikař.
Mi nejde o system jak o použivaní ser. portu, a I2C.
Celý barak mi jede přes raspi a  program jsem psal v lazarusu.
Mam 3 plochy. Na jedne muj program, na dalšich jdownloader a FreeRapid Downloader.
Mam souseda se kterým se tak doplnujem.
Tak asi přejit na debian 12 - bookworm bude jednodušší než ubuntu
« Poslední změna: 24. 02. 2024, 21:07:57 od Le_Ze »

Re:Vhodný Raspberry Pi OS pro RPi 5 4GB
« Odpověď #11 kdy: 28. 03. 2024, 18:47:44 »
Pretaktovano na 2.8GHz, stabilni, bezi mi to tu 12dni, v podstate skoro v plne zatezi ( chce to aktivni vetrak + origo zdroj ).
Mam tam pimoroni nvme base + 0.5TB NVME SSD z ktereho to bootuji a bezi to fajn.

Kód: [Vybrat]
bigsam@rpi5:~ $ vcgencmd measure_clock arm
frequency(0)=2800043776
bigsam@rpi5:~ $ uptime
 18:38:29 up 12 days, 20:56,  3 users,  load average: 3.69, 3.31, 3.26
bigsam@rpi5:~ $ uname -a
Linux rpi5 6.6.20+rpt-rpi-2712 #1 SMP PREEMPT Debian 1:6.6.20-1+rpt1 (2024-03-07) aarch64 GNU/Linux
bigsam@rpi5:~ $ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 12 (bookworm)
Release:        12
Codename:       bookworm
bigsam@rpi5:~ $

Jinak mam jeste RPi4 bootovane z iSCSI lunu z NASu a tam je take debian 12,a bezi to jako fik.

Kód: [Vybrat]
bigsam@rpi4:~ $ uptime
 18:45:33 up 46 days, 18:06,  6 users,  load average: 0.09, 0.09, 0.09