MikroTik jako DNS pro IPv6

MikroTik jako DNS pro IPv6
« kdy: 25. 11. 2022, 08:19:24 »
Dobrý den, mám takový dotaz ohledně DNS na Mikrotik. Do internetu mám připojení přes VDSL od O2. Mým cílem je, aby Mikrotik delegoval sám sebe jako DNS server.

Mám nastaveny vlastní DNS servery (ipv4 i ipv6), kterých se má Mikrotik ptát v položce /IP/DNS. Na ipv4 to funguje dobře, tam sám sebe deleguje, ale u ipv6 mi deleguje nastavené servery právě v /IP/DNS, ale ne sám sebe.

Tuším, že zakopaný pes bude někde kolem /IPV6/ND, ale ať dělám co dělám, výsledku nemůžu nějak dosáhnout. Díky za odpověď.
« Poslední změna: 25. 11. 2022, 08:44:18 od Petr Krčmář »


M_D

  • ***
  • 249
    • Zobrazit profil
    • E-mail
Re:MikroTik jako DNS pro IPv6
« Odpověď #1 kdy: 25. 11. 2022, 10:02:35 »
Jaká verzi ROSu v tom Mikrotiku je?
Pokud tomu nebrání něco jiného, tak aktualizujte na poslední 7.6. Tam už jde požadované nastavit. Ve starších je pod ND jen volba advertise-dns=yes|no, která zapne to posílání IPv6 adres DNS serverů dle seznamu z /ip/dns. V posledním ROSu přibyl do nastavení ND přímo DNS list, kde specifikuji přímo co se má v ND posílat při zapnutém advertise-dns=yes, takže tam je třeba vložit LAN IPv6 adresu routeru.
Jiná možnost, fungční i na starších ROSech, tak je použít bezestavové DHCPv6 a posílat DNS servery přes něj, pokud klient bezestavové DHCPv6 akceptuje. Takže v ND je zapnuto other-configuration=yes + advertise-dns=no a v DHCPv6 je něco jako:
/ipv6 dhcp-server option
add code=23 name=dhcp-server-dns-local value=0xfdeeddccbbaa00000000000000000001
/ipv6 dhcp-server
add address-pool="" dhcp-option=dhcp-server-dns-local interface=bridge-lan name=dhcp-server-lan

(0xfdeeddccbbaa00000000000000000001 je pěkně hexa 128 bitů IPv6 adresy fdee:ddcc:bbaa::1)

Re:MikroTik jako DNS pro IPv6
« Odpověď #2 kdy: 25. 11. 2022, 10:40:04 »
Ještě jednou dobrý den,
verzi mám poslední, čili 7.6. Takže jestli to chápu správně, v ND stačí dát do DNS serveru lokální adresu IPv6 routeru a tím je celá věc vyřešena. Router pak deleguje sám sebe a dotaz na DNS záznam zprostředkuje sám, tak jako u ipv4. Někdy věci v IPv6 mi přijdou fakt "nepřehledný".

Re:MikroTik jako DNS pro IPv6
« Odpověď #3 kdy: 25. 11. 2022, 11:36:07 »
Děkuji uživateli M_D za nakopnutí. Skutečně stačilo přidat v /ip6/ND do seznamu DNS serverů ipv6 adresu rozhraní bridge a funguje to na první dobrou.