MikroTik nepouští DHCP klienty do internetu

MikroTik nepouští DHCP klienty do internetu
« kdy: 04. 08. 2022, 14:09:50 »
Ahoj,

máme Mikrotik CRS326, který je nastavený a funguje

DHCP je nastavený (pool je od 10.1.1.200 nahoru) a ty PC, které dostanou IP adresu od DHCP, tak NEMAJÍ přístup do internetu.

Když se nastaví na PC fixní IP adresa např.10.1.1.70, tak do internetu je přístup OK.


Neví někdo kde nastavit, aby PC, které dostávají IP adresu od DHCP mohly do internetu ?
Nebo, jestli by to šlo podle MAC adresy - aby podle MAC adresy, mohly / nemohly do internetu ?

Do Mikrotiku chodíme přes Winbox.

Děkuji za každou odpověď

PM
« Poslední změna: 04. 08. 2022, 14:33:00 od Petr Krčmář »


Re:Mikrotik Router-CRS326-24G
« Odpověď #1 kdy: 04. 08. 2022, 14:22:52 »
Ty počítače potřebují nějakou gateway a DNS, jen IP nestačí.

czipis

  • ***
  • 190
    • Zobrazit profil
    • E-mail
Re:Mikrotik Router-CRS326-24G
« Odpověď #2 kdy: 04. 08. 2022, 14:25:07 »
bez konkretni konfigurace tady asi budeme jenom hadat.

zkuste poslat aspon kus konfigurace
Kód: [Vybrat]
/ip export

Re:MikroTik nepouští DHCP klienty do internetu
« Odpověď #3 kdy: 04. 08. 2022, 15:17:24 »
Děkuji za odpovědi.

Zde je výpis, omlouvam se, ale neco jsem musel nahradit xxx...

Děkuji

# by RouterOS 7.2.3
# software id = 6ASS-UNF6
#
# model = CRS326-xxx
# serial number = xxx
/ip pool
add name=dhcp ranges=10.1.1.200-10.1.1.254
/ip dhcp-server
add address-pool=dhcp interface=bridge name=dhcp1
/ip address
add address=10.1.1.1/24 interface=bridge network=10.1.1.0
add address=x.x.x.x/30 interface=ether1 network=x.x.x.x
/ip dhcp-client
add interface=bridge
/ip dhcp-server lease
add address=10.1.1.10 mac-address=xxxx server=dhcp1
/ip dhcp-server network
add address=0.0.0.0/24 dns-server=8.8.8.8 domain=8.8.4.4 gateway=0.0.0.0 \
    netmask=24
/ip dns
set servers=x.x.x.x
/ip settings
set max-neighbor-entries=xxxx
/ip firewall filter

vymazano

/ip service
set telnet disabled=yes
set ftp disabled=yes
set www disabled=yes
set ssh disabled=yes
set api disabled=yes
set api-ssl disabled=yes
[xxx@xxx] >

czipis

  • ***
  • 190
    • Zobrazit profil
    • E-mail
Re:MikroTik nepouští DHCP klienty do internetu
« Odpověď #4 kdy: 04. 08. 2022, 15:47:18 »
Kód: [Vybrat]
/ip dhcp-server network
add address=0.0.0.0/24 dns-server=8.8.8.8 domain=8.8.4.4 gateway=0.0.0.0 \
    netmask=24

address nastavte na 10.1.1.0/24 a gateway zmente na 10.1.1.1
domain=8.8.4.4 vyhodte
dns-server muzte asi taky nastavit na 10.1.1.1
« Poslední změna: 04. 08. 2022, 15:52:38 od czipis »


Re:MikroTik nepouští DHCP klienty do internetu
« Odpověď #5 kdy: 04. 08. 2022, 19:56:09 »
Děkuji za odpovědi.

/ip dhcp-client
add interface=bridge        --- to je blbost! Když je bridge interní LAN, tak proč by měla přijímat DHCP požadavky. Vyhodit!
                      DHCP klient pouze, pokud by jsi na eth1 měl od providiera adresu z jeho DHCP poolu.

/ip dhcp-server network     ----oprav řádek níže podle tohoto vzoru
add address=10.1.1.0/24 dns-server=8.8.8.8 gateway=10.1.1.1 netmask=24
/ip dns
set servers=x.x.x.x  --- není potřeba pro DHCP klienty, ti se budou dotazovat serveru 8.8.8.8, je potřeba jen pro interní potřebu toho MK.

/ip firewall filter

předpokládám, že tam máš správná pravidla, nejméně INPUT Related/Established  a Forward Related/Established a samozřejmě DROP INPUT vše z ETH1. Jinak se brzy staneš terčem pokusů o průnik.

Taky předpokládám, že máš správně Maškarádu ... jinak by ti to asi nechodilo vůběc.

/ip service
set telnet disabled=yes      --- tím jsi si zakázal možnost se připojit z jiného MK - doporučuji pustit a ometit je na síť 10.1.1.0/24
set ftp disabled=yes
set www disabled=yes      --- tím jsi si zakázal WebFix.
set ssh disabled=yes        --- dtto jako telnet.
set api disabled=yes
set api-ssl disabled=yes
[xxx@xxx] >

Více zde: https://wiki.mikrotik.com/wiki/Manual:IP/DHCP_Server   je to vyčerpávající popis.

Re:MikroTik nepouští DHCP klienty do internetu
« Odpověď #6 kdy: 05. 08. 2022, 07:04:32 »

Děkuji ! Vyzkouším a dám vědět.


PM