Thinkfan na T430

Arthur

  • ***
  • 155
    • Zobrazit profil
    • E-mail
Thinkfan na T430
« kdy: 18. 10. 2021, 10:24:55 »
Zdravím,

na své staré T430 (i5 3320M) s Xubuntu 18.04 chci přenastavit chování ventilátoru, který je relativně hlučný a defaultně se spouští při 40st. Myslím, že 45-50st by mělo bohatě stačit.

Skrze
Kód: [Vybrat]
options thinkpad_acpi fan_control=1 jsem schopen manuálně ovládat /proc/acpi/ibm/fan, tj. enable/disable, levels atd..

Úspěšně jsem nakonfiguroval a zprovoznil thinkfan
Kód: [Vybrat]
tp_fan /proc/acpi/ibm/fan
hwmon  /sys/class/hwmon/hwmon2/temp1_input
...
(0, 0, 45)
(1, 43, 50)
(2, 48, 55)
...

Spouštím jej přes
Kód: [Vybrat]
sudo service thinkfan startve statusu je vše OK

Problém je, že ovládání ventilátoru skrze thinkpad_acpi (které se při spuštění thinkfanu správně deaktivuje) se v pravidelných intervalech samo reaktivuje a spouští ventilátor, aby bylo v zápětí zase deaktivováno. Prostě se to zřejmě mezi sebou nějak mlátí...  Chová se to takto i v manuálním režimu po ukončení thinkfanu, ale dokud jej (poprvé) nespustím tak je to v pohodě.

Takže otázka zní, jak donutit thinkpad_acpi aby byl /proc/acpi/ibm/fan celou dobu disabled ?


k3dAR

  • *****
  • 2 099
  • porad nemam telo, ale uz mam hlavu... nobody
    • Zobrazit profil
    • E-mail
Re:Thinkfan na T430
« Odpověď #1 kdy: 18. 10. 2021, 21:46:57 »
[...]
Úspěšně jsem nakonfiguroval a zprovoznil thinkfan
Kód: [Vybrat]
tp_fan [b]/proc/acpi/ibm/fan[/b]
hwmon  /sys/class/hwmon/hwmon2/temp1_input
[...]
Takže otázka zní, jak donutit thinkpad_acpi aby byl /proc/acpi/ibm/fan celou dobu disabled ?
pro thinkfan mas nastavene aby to pouzival ;-) je normalni ze kdyz thinkfan provadi upravu otacek meni se status enabled/disabled... mam T430s a chova se to stejne...

Arthur

  • ***
  • 155
    • Zobrazit profil
    • E-mail
Re:Thinkfan na T430
« Odpověď #2 kdy: 20. 10. 2021, 09:24:44 »
Ale ono se to děje v době kdy se žádné úpravy otáček konat nemají. CPU má třeba 41st a každých pár vteřin se na chvilku roztočí větrák, zřejmě jako důsledek toho, že se to přepne do enabled módu ...

Zajímavé je, že ta četnost přepínání klesá s rostoucím limitem pro level 1. Když nastavím první úroveň na 55st, tak to dělá tak jednou za minutu, při 50st každých 10-15 vteřin, atd..