Některá zařízení ignorují konfiguraci DNS serverů z RA

vpn22

Narazil jsem na prolém, že některá zařízení ignurují RFC8106.

Jako router používám MikroTik, IPv6 adresy se nastavují metodou SLAAC. V RA se posílají i adresy DNS serverů, ověřeno ve Wiresharku.
Některá zařízení, jako Android telefony a tablety a NB s Ubuntu si adresy vezmou bez problémů z RA. U tří notebooků s Windows 10 jsem zjistil, že si adresy DNS serverů vezmou jen když jsou připojené Ethernetem a na WiFi to ignorují. Na některých zařízeních (Samsung TV, NB s Win 11) to nejde vůbec ať jsou připojeny jakýmkoli způsobem.

V čem může být problém?


Re:Některá zařízení ignorují konfiguraci DNS serverů z RA
« Odpověď #1 kdy: 09. 02. 2023, 12:22:53 »
V těch zařízeních. Nám třeba Samsung Galaxy telefony kvůli tomu nemůžou na intranet, protože ignorují firemní DNS. Položka v nastavení OneUI na to je, ale nefunguje. Jedou všechno přes svoje DNS.

M_D

  • ****
  • 328
    • Zobrazit profil
    • E-mail
Re:Některá zařízení ignorují konfiguraci DNS serverů z RA
« Odpověď #2 kdy: 10. 02. 2023, 21:19:22 »
DNS z RA je moc "horká novinka", většina krámů podporuje starší metodu pomocí bezestavového DHCPv6. Mikrotik to umí, takže paralelně k RA DNS nastavit i toto a chytne se i řada dalších věcí. V ohlášení RA zapnout "Other Configuration" (tím se klientovi řekne, že se má pokusit i o bezestavové DHCPv6). A nastavit DHCPv6 server stylem:
/ipv6 dhcp-server add address-pool="" interface=bridge-lan name=dhcp-server-lan
Toto začne přes DHCPv6 nabízet DNS IPv6 adresy, které jsou definovány pod /ip dns servers. Pokud bych potřeboval, aby se klientovi posílal jako DNS jiné IPv6 adresy, tak je nutno:
/ipv6 dhcp-server add address-pool="" interface=bridge-lan name=dhcp-server-lan dhcp-option=dhcp-dnss
/ipv6 dhcp-server option
add code=23 name=dhcp-dnss value=0xfd492990461643900000000000000001
A to value je hexa 128 bitů celá IPv6 adresa DNS serveru.

vpn22

Re:Některá zařízení ignorují konfiguraci DNS serverů z RA
« Odpověď #3 kdy: 14. 02. 2023, 20:20:42 »
Díky za tip, vyzkouším.

Je mi ale divné, že dva stroje se stejnými Windows a stejnými aktualizacemi se chovají jinak. A dokonce i na jednom stroji je rozdíl, na Ethernetu se vezmou adresy z RA, na WiFi ne. Skoro jako by to spíš byla věc driveru síťového rozhraní...

Re:Některá zařízení ignorují konfiguraci DNS serverů z RA
« Odpověď #4 kdy: 16. 02. 2023, 14:26:13 »
Díky za tip, vyzkouším.

Je mi ale divné, že dva stroje se stejnými Windows a stejnými aktualizacemi se chovají jinak. A dokonce i na jednom stroji je rozdíl, na Ethernetu se vezmou adresy z RA, na WiFi ne. Skoro jako by to spíš byla věc driveru síťového rozhraní...
Ten stroj by mohl mít u WiFi ručně nastavené DNS servery (místo zaškrtnutého "automaticky"), pak se použijí ty. A pokud to u ethernetu není, odpovídalo by to.


vpn22

Re:Některá zařízení ignorují konfiguraci DNS serverů z RA
« Odpověď #5 kdy: 19. 02. 2023, 10:47:08 »
Manuální konfigurace DNS u WiFi adaptéru nebyla.