MikroTik: více adres pro eth1 přes DHCP

MikroTik: více adres pro eth1 přes DHCP
« kdy: 04. 06. 2020, 06:50:12 »
resim spise teoreticky problem - router mikrotik
chtel bych s nim nahradit tri mensi routery - tri site ( cca po dvou vyvodech) - z nich maskarada a na konci dhcp pridelena adresa od poskytovatele internetu, potreboval bych aby si byl schopen an vystupu ( WAN - eth1) rici o tri dhcp adresy
 dik
« Poslední změna: 04. 06. 2020, 08:49:26 od Petr Krčmář »


XX125

Re:microtik vice dhcp adres pro eth1
« Odpověď #1 kdy: 04. 06. 2020, 07:31:14 »
Můžeš si tam udělat statickou DHCP tabulku MAC - IP.

Re:MikroTik: více adres pro eth1 přes DHCP
« Odpověď #2 kdy: 04. 06. 2020, 09:25:56 »
Ahoj,

některé RouterBoardy umí virtuální router (https://wiki.mikrotik.com/wiki/Manual:Metarouter).
Je to asi nejlepší volba, jak si tohle oddělit.
Mám tady RB2011 s 64 MB RAM. To stačí max na jeden virtuální router. Je potřeba víc RAM a podporovaný HW.

Na "fyzickém" routeru:
  • Vytvoř Bridge interface (bridge1)
  • Vytvoř Virtual Ethernet interface (vif1)
  • Do bridge dej vytvořený Virtual Ethernet a WAN interface (např. ether1)
  • Nastav DHCP client na bridge interfacu (bridge1)

Vytvoř nový MetaRouter (mr1).
Tomu routeru přiděl interface (vif1)

Až virtuální router nastartuje, dostaneš se do něj konzolí.
Virtuální router uvidí interface ether1. Na něm nastav DHCP client.

_Jenda

  • *****
  • 861
    • Zobrazit profil
    • https://jenda.hrach.eu/
    • E-mail
Re:MikroTik: více adres pro eth1 přes DHCP
« Odpověď #3 kdy: 04. 06. 2020, 09:29:49 »
A pokud nemáš podporovaný HW pro metarouter, tak tam dej OpenWRT, které podivná omezení neobsahuje, a bridge udělej na něm ;)

Jose D

  • *****
  • 696
    • Zobrazit profil
Re:MikroTik: více adres pro eth1 přes DHCP
« Odpověď #4 kdy: 04. 06. 2020, 09:51:29 »
Až virtuální router nastartuje, dostaneš se do něj konzolí.
jak je to s winboxem, bude pro virtualni router taky fungovat?
Vykon je obdobny fyzickemu podkladovemu routru, nebo jde do haje?


Re:MikroTik: více adres pro eth1 přes DHCP
« Odpověď #5 kdy: 04. 06. 2020, 10:11:46 »
Winbox je úplně v pohodě.

Performance jsem nikdy netestoval. Vždycky jsem to využíval jen pro malé instance s téměř nulovým trafficem.

Jose D

  • *****
  • 696
    • Zobrazit profil
Re:MikroTik: více adres pro eth1 přes DHCP
« Odpověď #6 kdy: 04. 06. 2020, 10:20:21 »
Winbox je úplně v pohodě.
..
Vždycky jsem to využíval jen pro malé instance s téměř nulovým trafficem.
díky. S RouterOS už jsem dělal všelicos ale virtualizaci jsem ještě nepoužil.

Re:MikroTik: více adres pro eth1 přes DHCP
« Odpověď #7 kdy: 04. 06. 2020, 20:38:05 »
Takže nakonec takto:
vytvoren bridge pro wlan, lan1, lan2, lan3
vytvoren metarouter - nebo jak se to jmenuje mr1 - mikrotik je rb2011 - vic nez jed mr neda..
do bridge-wan pridan fyzicky eth1 + vif1-wlan1, vif2-wlan2, vif-wlan3,
do bridge-lan1 pridany fyzicke eth2, eth3 + vif4-lan1 a tak dale pro ostatni
pro kazdy bridge-lan spusten dhcp-server

na mr1: spusteny dhcp clienti pro vif1-wlan1, vif2-wlan2, vif-wlan3
vif4-lan1 a ostatni lan -  nastaveny pevne adresy a ty pro prislusny dhcp-lan-server na fyzickem routeru nastaveny jak gw...
pravidla pro maskaradu nastaveny na mr1
doma na stole to jede.... tak snad...
ale je to teda vopicarna....

M_D

  • ***
  • 217
    • Zobrazit profil
    • E-mail
Re:MikroTik: více adres pro eth1 přes DHCP
« Odpověď #8 kdy: 04. 06. 2020, 22:49:13 »
Zajimavá úloha. Jde to i bez těch virtuálů. Jak na tom ether1 mít 3x DHCP klienta, každý s jinou MAC a tím pádem i jinou IP:
/interface vrrp
add interface=ether1 name=vrrp1 priority=255 v3-protocol=ipv6 vrid=10
add interface=ether1 name=vrrp2 priority=255 v3-protocol=ipv6 vrid=20
add interface=ether1 name=vrrp3 priority=255 v3-protocol=ipv6 vrid=30
/ip dhcp-client
add disabled=no interface=vrrp1
add disabled=no interface=vrrp2
add disabled=no interface=vrrp3