Wireguard a MTU

Mi1an

Wireguard a MTU
« kdy: 08. 06. 2020, 09:23:31 »
Zdravím.
Jaké je správné MTU pro wireguard?

Při konfiguraci wireguardu jsem MTU nikde nezadal a bylo nastaveno automaticky na 1420.

Po pár hodinách jsem zjistil, že nefungují google služby.
Přestalo fungovat vyhledávání, překladač. Přehrávat videa na youtube šlo jenom někdy,
gmail byl hodně pomalý.
Po deaktivaci wg rozhraní je vše v pořádku.

Hledal jsem a našel , že to způsobuje právě MTU.
Někde je doporučeno použít stejné MTU, jako v zbytku sítě. V mém případě je to 1500.
To funguje, ale jestli to dobře chápu, tak je to špatně.
Našel jsem další doporučené hodnoty MTU.
Teď zkouším hodnotu 1412, což se zdá, že zatím funguje.
Nastavil jsem MTU na routeru a přidal ho také do conf souborů pro peery.

Jaké MTU se osvědčilo vám?


Bugsa

Re:Wireguard a MTU
« Odpověď #1 kdy: 08. 06. 2020, 11:42:32 »
WG používám v práci v konfiguraci site-to-site na OpnSense (userspace wireguard-go) a druhou instanci pro road-warriory (klienty) z Androidu a Windows.
Doma server na OpenWRT (wireguard v kernelu 5.6) - klienti Android, Linux, Windows ....

Nikdy nebylo třeba v configu nastavovat explicitně MTU, spojení funguje vždy bezproblémově. Nemůže být problém v něčem jiném? Ve firewallu, DNS na Wireguard serveru? Jak se projevovalo to, že to "šlo jen někdy"?

Mi1an

Re:Wireguard a MTU
« Odpověď #2 kdy: 08. 06. 2020, 16:28:03 »
Nemůže být problém v něčem jiném? Ve firewallu, DNS na Wireguard serveru? Jak se projevovalo to, že to "šlo jen někdy"?

Projevovalo se to tak, že se stránky načetly častečně a dál načítání pokračovalo velmi dlouho nebo do "nekonečna".
Většinou se stránka nenačetla celá. Videa na youtube se po každých pár vteřinách asi na 1-3 minuty zasekla.
Ve vyhledávači google se načetla jenom základní grafika, gmail stejně tak.
Na jiných webech jsem se s problémy nesetkal.

Ve firewallu mám, co se týče wireguardu jenom jedno pravidlo povolující udp port.
DNS mám vlastní ve stejné síti jako router s wireguard.

Mimochodem s tím změněným MTU to od rána funguje bez problémů.

Mi1an

Re:Wireguard a MTU
« Odpověď #3 kdy: 08. 06. 2020, 16:33:35 »
Teď koukám, že na arch wiki mají v konfiguráku MTU = 1500 a nedoporučují nižší MTU než 1280.

https://wiki.archlinux.org/index.php/WireGuard#Low_MTU