Nelze opravit problémy, některé balíky držíte v porouchaném stavu.

ByCzech

  • *****
  • 1 830
    • Zobrazit profil
    • E-mail
Pri tom apt update Vám to píše
Kód: [Vybrat]
The AppStream system cache was updated, but some components were ignored. Refer to the verbose log for more information.
zkuste kouknout do /var/log/apt (nebo tak nějak) jestli tam k tomu není něco navíc,...

To jsem si všiml taky i proto je dobré dávat jeden balíček za druhým, ono to vyleze, co tam nemá dělat (viz předchozí můj příspěvek ohledně balíčku libavutil56).


ByCzech

  • *****
  • 1 830
    • Zobrazit profil
    • E-mail
libavutil56 je již nejnovější verze (10:4.2.1-dmo8).

...

 libpostproc55 : Závisí na: libavutil56 (= 7:4.2.1-2) ale 10:4.2.1-dmo8 se bude instalovat
E: Nelze opravit problémy, některé balíky držíte v porouchaném stavu.[/code]

No vida, problém nalezen! Nainstalujte libavutil56 z Debianu ne z deb-multimedia. Ten vám tam zůstal ;). Případně tam budou další balíčky z deb-multimedia.org, které se updatovaly:

Kód: [Vybrat]
apt install libavutil56/stable

Pardon ve vašem případě má být za lomítkem testing popř. bullseye.

peekaa

  • ***
  • 119
    • Zobrazit profil
    • E-mail
Kód: [Vybrat]
root@pc-2019:~# apt install libavutil56/testing
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí… Hotovo
Vybraná verze „7:4.2.1-2“ (Debian:testing [amd64]) pro „libavutil56“
Následující balíky budou ODSTRANĚNY:
  cheese chromium chromium-l10n gnome-contacts gnome-control-center gnome-photos gnome-video-effects gstreamer1.0-plugins-bad
  libavcodec58 libavformat58 libcheese-gtk25 libcheese8 libchromaprint1 libfreerdp2-2 libgegl-0.4-0 libswresample3 libswscale5
  telegram-desktop vinagre
Následující balíky budou DEGRADOVÁNY:
  libavutil56
0 aktualizováno, 0 nově instalováno, 1 degradováno, 19 k odstranění a 0 neaktualizováno.
Nutno stáhnout 263 kB archivů.
Po této operaci bude na disku uvolněno 343 MB.
Chcete pokračovat? [Y/n]

Super, funguje. Telegram už mám zpět, a ostatní postupně dám taky. A vlc již jde taky :-)

Tak snad již brzy bude v testing to kodi 18.x. Je to podobná situace jako asi před rokem, kdy tam děsně dlouho viděl starý ff, přestárlý ff.

peekaa

  • ***
  • 119
    • Zobrazit profil
    • E-mail
To
Kód: [Vybrat]
The AppStream system cache was updated, but some components were ignored. Refer to the verbose log for more information
už tam mám déle. Občas to vyleze, občas ne, na netu jsem četl "ignorovat", tak to zatím tak dělám. Ale až se rozhodnu, že mi to vadí a nebudu mít mezi svátky co dělat, tak založím nový téma :-)

peekaa

  • ***
  • 119
    • Zobrazit profil
    • E-mail
Lze nějak udělat, aby se při instalaci těch knihoven neodistalovaly app, které na tom závisí? Zrovna opravuji další,a je toho dost:
Kód: [Vybrat]
oot@pc-2019:~# apt install libgstreamer-plugins-bad1.0-0/testing
Načítají se seznamy balíků… Hotovo
Vytváří se strom závislostí       
Načítají se stavové informace… Hotovo
Vybraná verze „1.16.2-2+b1“ (Debian:testing [amd64]) pro „libgstreamer-plugins-bad1.0-0“
Následující dodatečné balíky budou instalovány:
  policykit-1-gnome
Následující balíky budou ODSTRANĚNY:
  chrome-gnome-shell evolution evolution-data-server evolution-plugin-bogofilter evolution-plugin-pstimport evolution-plugins gdm3
  gir1.2-gst-plugins-base-1.0 gir1.2-rb-3.0 gir1.2-webkit2-4.0 gnome-calendar gnome-documents gnome-getting-started-docs gnome-maps
  gnome-music gnome-online-accounts gnome-session gnome-shell gnome-shell-extensions gnome-sound-recorder gnome-sushi gnome-todo
  gnome-user-docs gstreamer1.0-gl gstreamer1.0-gtk3 libedataserverui-1.2-2 libevolution libfolks-eds25 libgoa-backend-1.0-1
  libgstreamer-gl1.0-0 libwebkit2gtk-4.0-37 libyelp0 mutter python3-gst-1.0 rhythmbox-plugins shotwell yelp zenity
Následující NOVÉ balíky budou nainstalovány:
  policykit-1-gnome
Následující balíky budou DEGRADOVÁNY:
  libgstreamer-plugins-bad1.0-0
0 aktualizováno, 1 nově instalováno, 1 degradováno, 38 k odstranění a 0 neaktualizováno.
Nutno stáhnout 2 087 kB archivů.
Po této operaci bude na disku uvolněno 318 MB.
Chcete pokračovat? [Y/n]

Díky.


ByCzech

  • *****
  • 1 830
    • Zobrazit profil
    • E-mail
Lze nějak udělat, aby se při instalaci těch knihoven neodistalovaly app, které na tom závisí? Zrovna opravuji další,a je toho dost:

Jo, downgradeovat všechny balíčky najednou ne po jednom :-).

Zjistíte z /var/log/apt/history.log, které se vám updatovaly, když jste měl zdroj z deb-multimedia.org.
« Poslední změna: 27. 12. 2019, 10:21:16 od ByCzech »

peekaa

  • ***
  • 119
    • Zobrazit profil
    • E-mail
Těžko se v tom hledá, těžko se v tom vyznám. Napadla mě cesta přeinstalovat ty aplikace /chromium, a další/ včetně závislosti. Nebylo to tak jednoduché, jjak jsem si myslel (obyčejné parametry v apt). Našel jsem tohle https://askubuntu.com/questions/275719/reinstall-package-and-its-installed-dependencies a pak tohle https://stackoverflow.com/questions/14639206/how-can-i-pass-all-arguments-with-xargs-in-middle-of-command-in-linux a nakonec mi jede např.:
Kód: [Vybrat]
apt-cache depends evolution | grep '[ |]Závisí na: [^<]' | cut -d: -f2 | tr -d ' ' | xargs -I %  apt-get --reinstall install %/testing


peekaa

  • ***
  • 119
    • Zobrazit profil
    • E-mail
hmm, tak to nejde. Když pak dám znovu apt install libgstreamer-plugins-bad1.0-0/testing, tak mi to znovu píše, že chce evolution odstranit..  Dneska už musím dělat i něco jiného :-) Ale díky :-)