Nabíjení mobilu USBčkem funguje z datové portu, nefunguje z nabíječky

Dobrý den, mám problém stelefonem s microUSB konektorem (stará Nokia, žádný proprietární iphone s antikompatibilním kurvítkem), že mi tam blbne nabíjení při nabíjení z nabíječek. Při  zapojení do datového portu USB  nabíjení funguje OK (avšak proudem 0.44A, limit portu USB tedy) a to i opakovaně (tedy že ho nechám nabíjet chvíli, kabel odpojím, pak zase zapojím a prostě se to nabíjí dál) Při zapojení sirovnou veme 0.25 až 0.38A , po cca 3s následně vzroste na to maximum kolem 0.5A .

V připojení do nabíječky se to chová divně. Zaprvé, vždy se zahájí odběrem 0.05 až 0.07A a to trvá tak 10s. následně proud vzroste na 0.7A(což je stejný maximální proud u zdravého kusu stejného modelu) a (STAV 1, při prvním zapojení) a trvá nějakou dobu (5 sekund až  pár minut v mAh 30 až 200mAh) nebo poklesne na NULU  (STAV 2)a telefon za 3 sec. hlásí, že je nabitý a čárkovný indikátor ukazuje plný počet čárek.
-A i přesto, že baterie má 3.7V (a hlásí to i program natelefonu)
-  Tento stav je trvalý, do té doby než vypnu telefon a zapnu znova (nezkoušel jsem SW restart.), s dvěma vyjímkami::(avšak ne stoprocentně verifikovanou) :
- - je li stav baterie nabití nižší (to subjektivně nevím kolik, prostě "málo", od oka pod 20% nebo pod 3.6V, ale fakt odhaduji)
- -  po uplynutí určité doby od nabíjení (může být 2 minuty klidně, a i když je zapojen v USB tak se prostě z ničeho nic začně nabijet po 2 minutách, co byl předtím z nabíječky přepojen do USB počítače zrovna teď) . ?Mám pocit, že cooldown(terminus nerdus) se zvyšuje s rostoucím stavem nabití (opět čirý odhad: nad 3.9V  půl hodiny, nad 4V nekonečno)
- Nepomůže ani telefon ve stavu 2 připojit  k USB portu počítače (jakože by se ihned začel nabíjet, protože jsem psal, že přeci při nabíjení z USB portu PC problém nemá), avšak tím není dotčen ten cooldown (že po uplynutí určité doby opět telefon jde nabíjet -- nezáleží zda ho dám podruhé do nabíječky či do dataportu)

V čem je problém? Proč to takhle se divně chová v USB nabíječce, zatímco v USB datovém? Nepomůže nějaký tríček který právě spočívá v rozdílu mezi USB komunikací/zapojením rezistivit mezi vodiči?


Spekulace 1 je, že nějak problém tohoto kusu je s vyšším proudem 0.7A...

nemusím dodávat, že u jiného kusu žádný takovéhle problém není. A také že jsem zkoušel 3 nabíječky a 3 kabely USB a i s průtokovým měřičem proudu i bez.
« Poslední změna: 23. 12. 2019, 23:48:33 od Pivotal »


uin

tipoval bych to na špatný akumulátor...
zkusil bych prohodit akumulátory mezi telefony... a vyzkoušet, jak se to chová...

RDa

  • *****
  • 1 283
    • Zobrazit profil
    • E-mail
V připojení do nabíječky se to chová divně. Zaprvé, vždy se zahájí odběrem 0.05 až 0.07A a to trvá tak 10s. následně proud vzroste na 0.7A(což je stejný maximální proud u zdravého kusu stejného modelu) a (STAV 1, při prvním zapojení) a trvá nějakou dobu (5 sekund až  pár minut v mAh 30 až 200mAh) nebo poklesne na NULU  (STAV 2)a telefon za 3 sec. hlásí, že je nabitý a čárkovný indikátor ukazuje plný počet čárek.

To me prijde jako snizena kapacita akumulatoru (vekem), tudiz tam mas tu pre-charge fazi (50-70mA), pak full-charge CC (0.7A) a jakmile to prejde do CV rezimu (30-200mA) a proud baterii klesne pod urcitou mez (CV charge-off current), je nabijeni ukonceno = plny pocet carek.

Jestli mas dva stejne telefony, prohod tu baterii, to ti spolehlive ukaze zda je problem v telefonu nebo baterii.


Jestli mas dva stejne telefony, prohod tu baterii, to ti spolehlive ukaze zda je problem v telefonu nebo baterii.

SAKRA SAKRA SAFRA ! DOSTALI JSTE MĚ , nechal jsem se nachytat!!!!
Zapomněl jsem napsat, samozřejmě k výčtu co jsem zkoušel (3 nabiječky, 3 kabely), že SAMOZŘEJMĚ JSEM I ZKOUŠIL JINÝ AKUMULÁTOR


A mimochodem v jiném notebooku USB nabíjení přes datový port Také nejde  správně:
Asi s periodou 20 sekund  se : nabíjí proudem 250mA asi 10s, pak poklesna na 50mA na 3s, pak na 5s na 20-10mA, pak jse 5s na nule. (To se stalo, když jsem na mobilu zvolil Režim MTP, na mobilu asi s frekvencí 3Hz se animovalo objevení infookénko Telefon připojen v režimu MTP) ... 250mA dle mě odpovídá nějakému startovnímu proudu USB portu, než telefon si určí, že chce nebíjet, ale nerozumím tomu přesně. (to totiž dělá i druh

(Když nezvolím žádný režim). tak začne na 430mA, vydrží 10s, zvedne se na 500, a pa střídavě každé 10 to spadne na nulu. A nebo tak ne, někdy  se tam objeví 20mA... Záleží to asi i na tom, jak předtím hnu s kabelem (protože tam vkládám ten měřák, který má blbý kontakt konektoru a i sám o  sobě přidává 2 rozhraní a sám o sobě musí mít nějaký odpor kolem 50miliohmů např)

Zatím hodně bláznivá hypotéze je, že telefonu nějak vadí, když napětí na portu je přes 4.95V, ale nijak nezkoušeno


Také jsem si všiml že tento kus píská, když se nabíjí (při 420mA)
« Poslední změna: 25. 12. 2019, 12:35:56 od Pivotal »