Jaké jsou vaše „must-have“ appky na Linux?

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #60 kdy: 07. 02. 2018, 10:13:57 »
Tak jsem popsane ted vyzkousel v PM i FF. V obou pripadech to funguje dle ocekavani, takze duvodem je asi to, ze vas dva jmenovite nekdo nema rad.


qwertz

Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #61 kdy: 07. 02. 2018, 10:21:39 »
Jste si jisty, ze nadavate na tu spravnou picu? Co kdyz byste mel nadavat spis na picu, ktera z dostupnych dialogu vybrala nevhodny nebo treba hovadsky naparametrovala jeho pocatecni chovani, tedy ktery prvek ma focus po otevreni dialogu?

Chcete mi tvrdit, že parametrizace může za stav, kdy je myší označen text v jednom poli, ale focus je na poli druhém (bez jakékoli indikace)?

Skoro bych si troufnul tvrdit, že takové idiotské chování není možné v Qt dialogu nastavit ani, kdybyste náhodou chtěl.

Přesně tohle se mi děje, když ukládám ve firefoxu (downloaded) soubor.
Okno "Uložit soubor...", v horním řádku jméno staženého/ukládaného souboru, jméno zvýrazněné, jako po označení.
A když to chce jeden přepsat, tak se píše úplně někam jinam, ten řádek se jménem fokus nemá.

Ještě že mám Firefox s Qt file-save dialogem. To by bylo fakt za trest.

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #62 kdy: 07. 02. 2018, 10:38:16 »
Chcete mi tvrdit, že parametrizace může za stav, kdy je myší označen text v jednom poli, ale focus je na poli druhém (bez jakékoli indikace)?

Ja nic netvrdim, pouze teoretizuju. Ty dialogy jsou nejakym zpusobem univerzalni pro ruzne situace, takze predpokladam, ze budou mit nejakou parametrizaci, kterou lze zkurvit. Ostatne jiz tu jednou nekdo na podobnou vec nadaval a nasledne mu nekdo jiny vysvetlil, ze za to muze nevhodne pouziti dialogu autorem aplikace nebo pouziti nespravneho dialogu nebo tak neco.

Ovsem protoze me to funguje, jak ma, zatimco vam ne, bude pes zakopan asi jinde. Mozna mate verzi GTK s nejakym bugem nebo co. V kazdem pripade pochybuji, ze by tak debilni chovani nekdo implementoval zamerne. Tomu se snazi vyhnout i v Redmondu, i kdyz ne vzdy se zdari.

ByCzech

  • *****
  • 1 812
    • Zobrazit profil
    • E-mail
Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #63 kdy: 07. 02. 2018, 10:39:17 »
Must-have appky jsou hlavně ty, co nepoužívají GTK3. Že jsou vývojáři GNOME poněkud z jiné planety (marně hledánm dostatečně vulgární označení) se tak nějak ví. Ale poté co na mě vyskočil GTK3 file save dialog o upgradu na poslední LibreOffice (Qt dialog zatím chybí), dostal jsem chuť dát někomu přes hubu.

V horním řádku je klasicky filename a je označen, aby šlo defaultní jméno souboru při ukládání přepsat. Jenže když začnete psát, nepřepíše se jméno souboru, ale píšete do úplně jiného políčka "search". která píča zas tohle vymyslela...... Co budu dělat, až tohle postihne GIMP fakt nevím.

Který myslíte poslední LibreOffice? Verzi 6? Abych věděl na co se připravit... V Debian backports je zatím verze 5.4

qwertz

Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #64 kdy: 07. 02. 2018, 10:46:42 »
V kazdem pripade pochybuji, ze by tak debilni chovani nekdo implementoval zamerne. Tomu se snazi vyhnout i v Redmondu, i kdyz ne vzdy se zdari.

Pokud vám GNOME vyhovuje možná to dává smysl. Jenže zkuste se na to podívat z druhé strany, pro nás ostatní je polovina věcí v GNOME/GTK+ implementována naprosto debilně a nelogicky zcela záměrně. (bez urážky). Jak mám asi tak rozlišit, která debilita je nezamýšlený bug, a která debilita je cílená feature.


qwertz

Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #65 kdy: 07. 02. 2018, 10:51:56 »
Který myslíte poslední LibreOffice? Verzi 6? Abych věděl na co se připravit... V Debian backports je zatím verze 5.4

Mám LO Version: 6.0.0.2.0+ OpenSUSE Tumbleweed. Problém je, že priorita file-save dialogu je GTK3>GTK2>Qt4>Native, takže na KDE5 to vůbec není připraveno. Možná bude řešením vynutit nějakým switchem jiný dialog, Qt4 bude asi nejmenší zlo.

Osobně moc nechápu, proč tyhle aplikace, co stejně nejsou nativně GTK tlačí ten nesmyslný GTK infterface, zejména v době, kdy všichni, kdo migrují, přechází směrem GTK>Qt. Je pochopitelné, že nikdo nebude přepisovat GIMP do Qt i kdyby nakrásně chtěl. Ale appky co GTK stejně nejsou moc smysl nedávají (vlastně dávají protože RedHat, kde je spousta chovanců postižených GNOME)

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #66 kdy: 07. 02. 2018, 14:19:15 »
Pokud vám GNOME vyhovuje možná to dává smysl.

GNOME mi nevyhovuje ani nahodou, vyhovuji aplikace, pokud nejsou prilis vazane na GNOME a nechteji si ho aspon pulku k sobe pritahnout. Neliibi se mi naopak Qt dialogy. Nejen, ze jsou seredne, ale jsou prakticke jak hrabe do postele.

ByCzech

  • *****
  • 1 812
    • Zobrazit profil
    • E-mail
Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #67 kdy: 07. 02. 2018, 14:24:46 »
Neliibi se mi naopak Qt dialogy. Nejen, ze jsou seredne, ale jsou prakticke jak hrabe do postele.

To by mě docela zajímalo pročpak. Mě osobně fileopen dialog z Gnome (GTK) nevyhovuje a naopak z KDE mi přišel vždy skvělý. To co udělám v KDE fileopen dialogu lehce a logicky, to buď v GTK nejde, nebo jde děsně složitě či nelogicky.

O šerednosti nevím jestli se má smysl u skinovatelných prostředí bavit.

JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #68 kdy: 07. 02. 2018, 14:58:16 »
To by mě docela zajímalo pročpak.

To ti bohuzel neupresnim, uz se nepamatuju, ale vzdycky mi v nich neco chybelo, jen si uz nepamatuju co. Ale nejak tu nemam zadnou Qt aplikaci, abych se podival. Tusim mi ty dialogy pripadaly stejne blbe, jako ve Widlich.

Asdfer

Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #69 kdy: 07. 02. 2018, 15:17:48 »
Ulaucher

Asdfer

Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #70 kdy: 07. 02. 2018, 15:20:11 »

D.A. Tiger

  • ****
  • 464
  • Tygr, který žere tučňáka ;-)
    • Zobrazit profil
    • E-mail
Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #71 kdy: 07. 02. 2018, 21:10:28 »
O šerednosti nevím jestli se má smysl u skinovatelných prostředí bavit.

Vsechno nenaskinujes. Zrovna ty dialogy (ktere teda nevyhovuji moc ani me osobne) vzhledove nepredelas. Navic GUI tamata jsou mezy jednotlivymi  frameworky naprosto neprenosna. Sice existuje KDE/GTK projekt, ktery to alespon castecne umoznuje, ale dost mizerne (Barevne, ikonove tema, nektere charakteristik UI).

Jo, kdyby autori GUI frameworku pouzivali CSS s XML Layout tak s prenostelnosti budem davno nekde jinde. Ale ne, kazdy musi mit vlastni nejlepe co nejhur portovatelny format, zavisly na internim enginu GUI (treba GTK/Gnome).   

Lopaťuk

Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #72 kdy: 07. 02. 2018, 22:25:05 »
openbox, dmenu, tint

fish, byobu, terminator
 
vim (na rychlou editaci), vs.code (na vývoj v elixiru a pythonu) + zeal

monospace font: hack
sans-serif font: roboto

smplayer, spotify

ByCzech

  • *****
  • 1 812
    • Zobrazit profil
    • E-mail
Re:Jaké jsou vaše „must-have“ appky na Linux?
« Odpověď #73 kdy: 11. 02. 2018, 17:51:56 »
Který myslíte poslední LibreOffice? Verzi 6? Abych věděl na co se připravit... V Debian backports je zatím verze 5.4

Mám LO Version: 6.0.0.2.0+ OpenSUSE Tumbleweed. Problém je, že priorita file-save dialogu je GTK3>GTK2>Qt4>Native, takže na KDE5 to vůbec není připraveno. Možná bude řešením vynutit nějakým switchem jiný dialog, Qt4 bude asi nejmenší zlo.

Tak mi do Debianu přifičel z backports LibreOffice verze 6 a tenhle problém s GTK dialogem nemám. Vypadá, že to nebude LibreOfficem.