reklama

Nejde internet v Archu

Heritage

Nejde internet v Archu
« kdy: 13. 02. 2011, 11:13:21 »
Zdravim

Po instalacii archu neviem nastavit internet. Nefunguje ani ked dam ip, nazov webu alebo adresu gateway. IP, maska a brana su presne tae ako mam v zmluve, takze tam problem nieje.
Fakt neviem kde je problem.

Dakujem za pomoc

/etc/rc.conf

Kód: [Vybrat]
#
# /etc/rc.conf - Main Configuration for Arch Linux
#

# -----------------------------------------------------------------------
# LOCALIZATION
# -----------------------------------------------------------------------
#
# LOCALE: available languages can be listed with the 'locale -a' command
# HARDWARECLOCK: set to "UTC" or "localtime", any other value will result
# in the hardware clock being left untouched (useful for virtualization)
# TIMEZONE: timezones are found in /usr/share/zoneinfo
# KEYMAP: keymaps are found in /usr/share/kbd/keymaps
# CONSOLEFONT: found in /usr/share/kbd/consolefonts (only needed for non-US)
# CONSOLEMAP: found in /usr/share/kbd/consoletrans
# USECOLOR: use ANSI color sequences in startup messages
#
LOCALE="en_US.UTF-8"
HARDWARECLOCK="localtime"
TIMEZONE="Europe/Bratislava"
KEYMAP="us"
CONSOLEFONT=
CONSOLEMAP=
USECOLOR="yes"

# -----------------------------------------------------------------------
# HARDWARE
# -----------------------------------------------------------------------
#
# MOD_AUTOLOAD: Allow autoloading of modules at boot and when needed
# MOD_BLACKLIST: Prevent udev from loading these modules
# MODULES: Modules to load at boot-up. Prefix with a ! to blacklist.
#
# NOTE: Use of 'MOD_BLACKLIST' is deprecated. Please use ! in the MODULES array.
#
MOD_AUTOLOAD="yes"
#MOD_BLACKLIST=() #deprecated
MODULES=()

# Scan for LVM volume groups at startup, required if you use LVM
USELVM="no"

# -----------------------------------------------------------------------
# NETWORKING
# -----------------------------------------------------------------------
#
# HOSTNAME: Hostname of machine. Should also be put in /etc/hosts
#
HOSTNAME="myhost"

# Use 'ifconfig -a' or 'ls /sys/class/net/' to see all available interfaces.
#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
# - prefix an entry in INTERFACES with a ! to disable it
# - no hyphens in your interface names - Bash doesn't like it
#
# DHCP: Set your interface to "dhcp" (eth0="dhcp")
# Wireless: See network profiles below
#

#Static IP example
eth0="eth0 172.37.47.214 netmask 255.255.255.224 broadcast 172.27.37.223"
#eth0="dhcp"
INTERFACES=(eth0)

# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
# - prefix an entry in ROUTES with a ! to disable it
#
gateway="default gw 172.37.47.254"
ROUTES=(gateway)

# Enable these network profiles at boot-up. These are only useful
# if you happen to need multiple network configurations (ie, laptop users)
# - set to 'menu' to present a menu during boot-up (dialog package required)
# - prefix an entry with a ! to disable it
#
# Network profiles are found in /etc/network.d
#
# This now requires the netcfg package
#
#NETWORKS=(main)

# -----------------------------------------------------------------------
# DAEMONS
# -----------------------------------------------------------------------
#
# Daemons to start at boot-up (in this order)
# - prefix a daemon with a ! to disable it
# - prefix a daemon with a @ to start it up in the background
#
DAEMONS=(syslog-ng network netfs crond)

/etc/hosts
Kód: [Vybrat]
#
# /etc/hosts: static lookup table for host names
#

#<ip-address> <hostname.domain.org> <hostname>
127.0.0.1 localhost.localdomain localhost myhost

# End of file

/etc/resolv.conf
Kód: [Vybrat]
#
# /etc/resolv.conf
#

#search <yourdomain.tld>
#nameserver <ip>

# End of file
nameserver 8.8.8.8
nameserver 8.8.4.4



« Poslední změna: 13. 02. 2011, 23:17:50 od Petr Krčmář »

reklama


kane77

Re: Nejde internet v archu
« Odpověď #1 kdy: 13. 02. 2011, 12:50:37 »
a mas eth0 up, co ti vypise ifconfig? skusal si /etc/rc.d/network restart po tom co si to nastavil?

FAWN

Re: Nejde internet v archu
« Odpověď #2 kdy: 13. 02. 2011, 12:59:13 »
Mate preklep v rc.conf:

eth0="eth0 172.37.47.214 netmask 255.255.255.224 broadcast 172.27.37.223"

broadcast ma byt: 172.37.47.223

Heritage

Re: Nejde internet v archu
« Odpověď #3 kdy: 13. 02. 2011, 13:14:55 »
Diki, preklep opraveny ale stale to nejde. Ked zadam /etc/rc.d/network restart vypise to
Kód: [Vybrat]
STOPPING NETWORK
SCIOCADDRT: No such process
STARTING NETWORK
SCIOCADDRT: No such process

kane77

Re: Nejde internet v archu
« Odpověď #4 kdy: 13. 02. 2011, 14:26:30 »
nie som sice sietar, ale nemala by default gw byt v subnete?

v tvojom je rozsah adries 172.37.47.193-222 a gw je 254..

reklama


Heritage

Re: Nejde internet v archu
« Odpověď #5 kdy: 13. 02. 2011, 14:55:53 »
Dakujem vsetkym za ochotu problem som vyriesil.

gateway som nastavil takto:
Kód: [Vybrat]
g0="172.37.47.254 eth0"
gateway="default gw 172.37.47.254"
ROUTES=(g0 gateway)


a potom som zadal: /etc/rc.d/network start

 

reklama