MikroTik NAT a přesměrování portů

TheZIGI

MikroTik NAT a přesměrování portů
« kdy: 26. 12. 2016, 16:05:34 »
Dobrý den,
mám RB2011UiAS-2HnD-IN a když si nastavím port a nasměruju ho na vnitřní IP (např: 192.168.88.2:10000), tak to funguje, ale když to zkusím přes svojí veřejnou IP (např: 1.1.1.1:10000), tak mi to ukáže jen chybu, že web odmítl připojení. Pokud to zkusí kamarád se svého netu tak mu to ukáže v pořádku, mě jen když zadám vnitřní IP a když veřejnou tak chybu. Nevíte čím by to mohlo být? :/
« Poslední změna: 27. 12. 2016, 10:26:52 od Petr Krčmář »


citanus006

Re:Mikrotik NAT
« Odpověď #1 kdy: 26. 12. 2016, 17:10:10 »
Pingnes tu verejnou adresu ze vnitr svoji site?

McFly

  • ****
  • 470
    • Zobrazit profil
    • E-mail
Re:Mikrotik NAT
« Odpověď #2 kdy: 26. 12. 2016, 17:12:05 »

TheZIGI

Re:Mikrotik NAT
« Odpověď #3 kdy: 26. 12. 2016, 17:19:20 »
Pingnu v pohodě.
Hairpin NAT nevím jak správně nastavit právě.

jeniceek

Re:Mikrotik NAT
« Odpověď #4 kdy: 26. 12. 2016, 18:54:59 »
Nemáš NAT loopback, musíš vytvořit druhé pravidlo, které se postará o přesměrování na ten konkrétní stroj, pokud z vnitřní sítě zadáš vnější adresu routeru.


TheZIGI

Re:Mikrotik NAT
« Odpověď #5 kdy: 26. 12. 2016, 19:16:40 »
Nemáš NAT loopback, musíš vytvořit druhé pravidlo, které se postará o přesměrování na ten konkrétní stroj, pokud z vnitřní sítě zadáš vnější adresu routeru.

Neměl by jsi fotku nebo nenapsal jak na to přesně? :)

Jose D

  • *****
  • 750
    • Zobrazit profil
Re:Mikrotik NAT
« Odpověď #6 kdy: 01. 01. 2017, 16:29:08 »
Hairpin NAT nevím jak správně nastavit právě.
Je to v tom linku na mikrotik wiki.

uncle Screwdriver

Re:Mikrotik NAT
« Odpověď #7 kdy: 01. 01. 2017, 17:25:26 »
Hairpin NAT nevím jak správně nastavit právě.

Za 1000,- nastavím...

Salamander

Re:MikroTik NAT a přesměrování portů
« Odpověď #8 kdy: 04. 01. 2017, 09:03:59 »
Pokud nastavujes pres WinBox nebo Web tak je to take pomerne easy.

Ve Firewall -> Mangle musis vytvorit pravidlo
Chain: prerouting
Src. Address : rozsah vnitrni subnety za NATem (192.168.0.0/24)
Dst. Address : verejna IP

protokol a port dle toho co chces presmerovat

V Action das mark connection a New connection mark si nejak pojmenujes (treba int-mangle)

V NATu potom vytvoris nove pravidlo pro maskaradu
Chain: srcnat
Connection mark: int-masquerade
Action: masquerade


Re:MikroTik NAT a přesměrování portů
« Odpověď #9 kdy: 17. 04. 2017, 19:43:32 »
Pokud nastavujes pres WinBox nebo Web tak je to take pomerne easy.

Ve Firewall -> Mangle musis vytvorit pravidlo
Chain: prerouting
Src. Address : rozsah vnitrni subnety za NATem (192.168.0.0/24)
Dst. Address : verejna IP

protokol a port dle toho co chces presmerovat

V Action das mark connection a New connection mark si nejak pojmenujes (treba int-mangle)

V NATu potom vytvoris nove pravidlo pro maskaradu
Chain: srcnat
Connection mark: int-masquerade
Action: masquerade
Ahoj, jde v Mangle vytvořit pravidlo pro více portů, nebo musím pro každý port vytvořit zvlášť pravidlo?
Dík

uncle Screwdriver

Re:MikroTik NAT a přesměrování portů
« Odpověď #10 kdy: 17. 04. 2017, 20:24:09 »
Mikrotik Wiki má výpadek?

Salamander

Re:MikroTik NAT a přesměrování portů
« Odpověď #11 kdy: 18. 04. 2017, 09:20:50 »
Ahoj, jde v Mangle vytvořit pravidlo pro více portů, nebo musím pro každý port vytvořit zvlášť pravidlo?
Dík
[/quote]
na 100% jisty si nejsem, ale podle me jde dat maximalne rozsah, treba 5000-5005, ale jinak musis mit pro kazdy port pravidlo zvlast

Re:MikroTik NAT a přesměrování portů
« Odpověď #12 kdy: 18. 04. 2017, 09:52:08 »
Tak jsem mi to povedlo bez Mangle. Jen jsem ke každému pravidlu vytvořil druhé pravidlo. Příklad s rozdílným portem:
Kód: [Vybrat]
/ip firewall nat
add chain=dstnat dst-address-type=local protocol=tcp dst-port=8888 \
action=dst-nat to-address=192.168.0.2 to-port=80

/ip firewall nat
add chain=srcnat src-address=192.168.0.0/24 \
dst-address=192.168.0.2 protocol=tcp dst-port=80 \
out-interface=ehter2-master-local action=masquerade