reklama

Debian - problémy s kompilací PHP

marian

Debian - problémy s kompilací PHP
« kdy: 01. 01. 2017, 15:33:09 »
balicek php5 v debianu pouziva jinou GD knihovnu nez s kterou se PHP normalne kompiluje (diky tomu v nem chybi nektere podstatne funkce)
dle vyjadreni v bugtrackeru to oni nebudou upravovat, protoze by to mohlo prinest bezpecnostni problemy a bylo by to problematicke udrzovat (?)


Takze si tedy stahnu zdrojak, pripravim zavislosti  a pustim apt-get build-dep php5
Jenze na serveru uz pouzivam mariadb-server  a  build-dep mi tam zacne cpat mysql-server  ... no tyhle dve veci se mezi sebou znacne perou a shodi mi to maria-db.

Poradite co s tim?


reklama


Danny

Re:Debian - problémy s kompilací PHP
« Odpověď #1 kdy: 01. 01. 2017, 17:58:27 »
v tom kroku "pripravim zavislosti" deklarovat zavislost na mariadb-server?

marian

Re:Debian - problémy s kompilací PHP
« Odpověď #2 kdy: 01. 01. 2017, 18:50:53 »
A to mohu udelat jak? Ja predtim nainstaluji jen build-essential a pak uz rovnou build-dep php5

pokud si vyjedu informace o zavislostech

apt-cache showsrc php5
Kód: [Vybrat]
Build-Depends: apache2-dev (>= 2.4), dh-apache2, dh-systemd (>= 1.3), libsystemd-daemon-dev [linux-any], autoconf (>= 2.63), automake (>= 1.11) | automake1.11, bison, chrpath, debhelper (>= 9), dpkg-dev (>= 1.16.1~), firebird-dev [!hurd-any !m68k !hppa !ppc64] | firebird2.5-dev [!hurd-any !m68k !hppa !ppc64] | firebird2.1-dev [!hurd-any !m68k !hppa !ppc64], flex, freetds-dev, libapr1-dev (>= 1.2.7-8), libbz2-dev, libc-client-dev, libcurl4-openssl-dev | libcurl-dev, libdb-dev, libedit-dev (>= 2.11-20080614-4), libenchant-dev, libevent-dev (>= 1.4.11), libexpat1-dev (>= 1.95.2-2.1), libfreetype6-dev, libgcrypt11-dev, libgd-dev (>= 2.1.0) | libgd2-dev, libglib2.0-dev, libgmp3-dev, libicu-dev, libjpeg-dev | libjpeg62-dev, libkrb5-dev, libldap2-dev, libmagic-dev, libmcrypt-dev, libmhash-dev (>= 0.8.8), libmysqlclient-dev | libmysqlclient15-dev, libonig-dev, libpam0g-dev, libpcre3-dev (>= 6.6), libpng-dev | libpng12-dev, libpq-dev, libpspell-dev, libqdbm-dev, librecode-dev, libsasl2-dev, libsnmp-dev, libsqlite3-dev, libssl-dev, libtidy-dev, libtool (>= 2.2), libwrap0-dev, libxmltok1-dev, libxml2-dev, libvpx-dev, libxslt1-dev (>= 1.0.18), systemtap-sdt-dev [amd64 i386 powerpc armel armhf ia64], locales-all | language-pack-de, mysql-server | virtual-mysql-server, netbase, netcat-traditional, re2c, unixodbc-dev, zlib1g-dev, tzdata, libapparmor-dev


To tedy musim rucne sesbirat ty zavislosti a vsechny je pak nainstalovat  a zaroven jeste zmenit vsechny mysql balicky za mariadb ekvivalenty?? A jak mohu poznat jak se ma jmenovat mariadb ekvivalent u kazdeho balicku?

Danny

Re:Debian - problémy s kompilací PHP
« Odpověď #3 kdy: 01. 01. 2017, 19:00:18 »
sorry, ja delal pouze RPM, ne DEB balicky a tam to bylo tak, ze pro ten "hlavni" balicek, ktery chces buildovat, byl .spec soubor jmeno-balicku.spec a tam byly polozky "Requires:" a "BuildRequires:" kde se daly napsat, pripadne zmenit zavislosti

(ted to ramcove googlim pro Debian, a tam by to mel byt "control" soubor a polozka Build-Depends)

marian

Re:Debian - problémy s kompilací PHP
« Odpověď #4 kdy: 01. 01. 2017, 22:54:32 »
tak s tema balickama jsem to vzdal a rucne  jsem to vytahl.
kdyby to nekoho zajimalo, tak zde davam zavislosti pro zkompilovani php5 s mariadb na zakladni instalaci debianu

Kód: [Vybrat]
apt-get install build-essential

Kód: [Vybrat]
apt-get install apache2-dev dh-apache2 dh-systemd libsystemd-daemon-dev autoconf automake dpkg-dev firebird-dev flex freetds-dev libapr1-dev  libbz2-dev libc-client-dev libcurl4-openssl-dev libdb-dev libedit-dev libenchant-dev libevent-dev libexpat1-dev libfreetype6-dev libgcrypt11-dev libgd-dev libgd2-dev libglib2.0-dev libgmp3-dev libicu-dev libjpeg-dev libkrb5-dev libldap2-dev libmagic-dev libmcrypt-dev libmhash-dev libpng-dev libpng12-dev libpq-dev libpspell-dev libqdbm-dev librecode-dev libsasl2-dev libsnmp-dev libsqlite3-dev libssl-dev libtidy-dev libtool libwrap0-dev libxmltok1-dev libxml2-dev libvpx-dev libxslt1-dev systemtap-sdt-dev locales-all netbase netcat-traditional re2c unixodbc-dev zlib1g-dev tzdata libapparmor-dev libmariadbd-dev mariadb-server libonig-dev libpam0g-dev libpcre3-dev libjpeg62-turbo-dev

reklama


marian

Re:Debian - problémy s kompilací PHP
« Odpověď #5 kdy: 01. 01. 2017, 22:56:25 »
+
Kód: [Vybrat]
apt-get install libfcgi-dev libfcgi0ldbl libmcrypt-dev libssl-dev libc-client2007e libc-client2007e-dev

Kód: [Vybrat]
ln -s /usr/lib/libc-client.a /usr/lib/x86_64-linux-gnu/libc-client.a

 

reklama