Debian a instalace ATI ovladačů

Jiri

Debian a instalace ATI ovladačů
« kdy: 23. 12. 2010, 22:01:01 »
Zdravim,

na cistou instalaci Debianu 5 Lenny jsem potreboval nainstalovat ATI ovladace ke grafice. Bohuzel po restartu uz me nenabehne vubec Gnome (zustane cerna obrazovka). Je nejaka moznost jak to zprovoznit? Dostanu se nejak alespon do konzole?

(Omlouvam se za zacatecnicky dotaz, pred lety jsem pouzival Slackware, kde fungovalo prepnuti do konzole pres Ctrl + Alt + F1 .. F5, tohle me ale na debianu nejak nejde).

Muze me nekdo nakopnout spravnym smerem?
Diky
« Poslední změna: 24. 12. 2010, 00:28:01 od Petr Krčmář »


D.A. Tiger

  • ****
  • 458
  • Tygr, který žere tučňáka ;-)
    • Zobrazit profil
    • E-mail
Re: Debian - instalace ATI ovladacu
« Odpověď #1 kdy: 23. 12. 2010, 22:53:52 »
Citace
(Omlouvam se za zacatecnicky dotaz, pred lety jsem pouzival Slackware, kde fungovalo prepnuti do konzole pres Ctrl + Alt + F1 .. F5, tohle me ale na debianu nejak nejde).

To je dost divný. V Debianu to funguje úplně stejně, to skoro vypadá jako by se ti to při startu XServeru seklo. Skus tedy nabootovat do single režimu, kdy ti najede jen základní systém v v konzoli s právi roota. Tam se pak mrkni na nastavení XOrg. Pokud používáš LILO mělo by pro tento runlevel stačit zadat na výzvu "boot"

Kód: [Vybrat]
linux single
a pro Grub je jeden návod třeba tu : http://www.cyberciti.biz/faq/grub-boot-into-single-user-mode/
 
« Poslední změna: 23. 12. 2010, 22:57:18 od D.A. Tiger »

Blaazen.

Re: Debian - instalace ATI ovladacu
« Odpověď #2 kdy: 23. 12. 2010, 23:09:49 »
Předpokládám, že máte na mysli proprietární driver. Já s ním měl problém pouze jednou, v Kubuntu 10.4 jsem nerozchodil žádnou verzi (jádro 2.6.32.25). Ale v 10.10 (jádro 2.6.35.22) fungovalo s verzí driveru 8.780 (která tehdy byla na serverech Canonicalu dříve, než na oficiálních stránkách ATI). Ještě přidám výpis xorg.conf:

Kód: [Vybrat]
Section "ServerLayout"
Identifier     "aticonfig Layout"
Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "ServerFlags"
Option     "DontZap" "False"  #this ENABLES Ctrl+Alt+BackSpace
Option     "AIGLX" "on"
EndSection

Section "Monitor"
Identifier   "aticonfig-Monitor[0]-0"
Option     "VendorName" "ATI Proprietary Driver"
Option     "ModelName" "Generic Autodetecting Monitor"
Option     "DPMS" "true"
EndSection

Section "Device"
Identifier  "aticonfig-Device[0]-0"
Driver      "fglrx"
BusID       "PCI:8:0:0"
EndSection

Section "Screen"
Identifier "aticonfig-Screen[0]-0"
Device     "aticonfig-Device[0]-0"
Monitor    "aticonfig-Monitor[0]-0"
DefaultDepth     24
SubSection "Display"
Viewport   0 0
Depth     24
EndSubSection
EndSection


Jiri

Re: Debian - instalace ATI ovladacu
« Odpověď #3 kdy: 23. 12. 2010, 23:20:18 »
Diky za opovedi.

Single rezim mam jako druhou volbu v GRUBu, ale to mi moc nepomohlo, po zadani hesla roota nemuzu delat prakticky nic (ani ls nevypise nic nez prazdny radek). Pokud zmacknu Ctrl + D, tak se zacne startovat XServer a jsem zase tam kde jsem byl.

Nebude jednodussi nabootovat z nejaky live linux, primountovat oddil a nejak vykopat ty ovladace? Nebo jenom upravit ten xorg.conf (momentalne netusim jak vypada ten muj)?