reklama

Balíky z archivu pro staré verze Debianu

astray

Balíky z archivu pro staré verze Debianu
« kdy: 24. 05. 2016, 13:56:35 »
Ahoj,

mám debian squeeze a v něm nainstalovaný balík např. dovecot-common_1.2.15-7+deb6u1_amd64.deb. Po odsunutí squeeze na smetiště dějin se balík vyskytuje tady: http://archive.debian.org/debian/pool/main/d/dovecot/dovecot-common_1.2.15-7+deb6u1_amd64.deb , ale není v žádném Packages.gz  souboru, takže se k němu APT nezná a "aptitude download dovecot-common" píše:  "E: No downloadable files for dovecot-common version 1:1.2.15-7+deb6u1; perhaps it is a local or obsolete package?"

Co s tím?

V sources.list mám:
deb http://archive.debian.org/debian/ squeeze main contrib non-free
deb http://archive.debian.org/debian-security squeeze/updates main contrib non-free
« Poslední změna: 24. 05. 2016, 23:03:30 od Petr Krčmář »

reklama


Palo M.

Re:Balíky z archivu pro staré verze Debianu
« Odpověď #1 kdy: 25. 05. 2016, 05:02:11 »
Pridaj do sources.list este:
Kód: [Vybrat]
deb http://archive.debian.org/debian/ squeeze-lts main contrib non-free

astray

Re:Balíky z archivu pro staré verze Debianu
« Odpověď #2 kdy: 25. 05. 2016, 10:16:24 »
Pridaj do sources.list este:
Kód: [Vybrat]
deb http://archive.debian.org/debian/ squeeze-lts main contrib non-free

Sqeeze-lts už je zrušené. Aptitude update vrací:
E: Release file expired, ignoring http://archive.debian.org/debian/dists/squeeze-lts/Release (invalid since 70d 16h 53min 44s)

Já si ty balíky jsem schopný najít a stáhnout ručně, ale šlo mně o to, proč nejsou updatované balíky v seznamech.


Palo M.

Re:Balíky z archivu pro staré verze Debianu
« Odpověď #3 kdy: 25. 05. 2016, 11:00:05 »
Sqeeze-lts už je zrušené. Aptitude update vrací:
E: Release file expired, ignoring http://archive.debian.org/debian/dists/squeeze-lts/Release (invalid since 70d 16h 53min 44s)

Já si ty balíky jsem schopný najít a stáhnout ručně, ale šlo mně o to, proč nejsou updatované balíky v seznamech.
Lenze ta tvoja vysnena verzia 1.2.15-7+deb6u1 je prave v squeeze-lts...

Ale ked uz sa vrtas v prastarych a nepodporovanych verziach, tak pri chybovych hlaskach skus pouzit nejaky ten vyhladavac. Mozno najdes aj nieco ako napriklad http://unix.stackexchange.com/questions/2544/how-to-work-around-release-file-expired-problem-on-a-local-mirror


 

reklama