reklama

Všechny názvy souborů s velkými písmeny

ondro

Všechny názvy souborů s velkými písmeny
« kdy: 08. 06. 2015, 13:50:27 »
Mam jeden specialny USB disk, ktory sa tvari ako klasicka USB flash-ka (atmel procesor + 2x512kB flash). Doteraz som tento disk pripajal k starsiemu Debianu(pouzivam Etch a Lenny) a tam su vsetky subory s malymi psimenami. Ak ho primontujem v Debian Jessie, tak vsetky subory su s velkymi pismenami.


Nevie mi niekto poradit preco sa to deje a ako dosiahnut to aby aj v Jessie boli tieto subory s malymi pismenami?

Potrebujem premigrovat aplikaciu na Debian Jessie a ta aplikacia ocakva subory s malymi pismenami. V Jjessie mi zahlasi, ze subory nevie najst.
« Poslední změna: 08. 06. 2015, 14:13:52 od Petr Krčmář »

reklama


JardaP .

  • *****
  • 11 064
    • Zobrazit profil
    • E-mail
Re:na primonovanom disku su vsetky nazvy suborov velkymi pismenami
« Odpověď #1 kdy: 08. 06. 2015, 14:15:45 »
A filesystem je tam jaky? Treba je to nejaky, ktery nepodporuje mala a velka pismena a tak se to zobrazuje budto jednim nebo druhym, pricemz default je nekde natvrdo zadelany nebo v nejakem konfiguraku. Kdyz mrknete na man mount, tak u nekterych FS tam jsou parametry, kterymi se da ovlivnit zobrazeni nazvu.

Filip Jirsák nepřihlášený

Re:Všechny názvy souborů s velkými písmeny
« Odpověď #2 kdy: 08. 06. 2015, 14:51:50 »
Předpokládám, že souborový systém je VFAT, ten „nějaký konfigurák“ se jmenuje /etc/fstab a určuje to parametr shortname.

ondro

Re:Všechny názvy souborů s velkými písmeny
« Odpověď #3 kdy: 08. 06. 2015, 15:20:18 »
dik za reakcie.

Ak som ho primontoval s paramterom -o shortname=lower, tak uz su zase malym.

Este jedna otazka. Da sa nejako nastavit Debian aby nebolo potrebne pouzit tento parameter? Prikaz na montovanie je natvrdo v aplikacii. Aplikacia si zistuje pritomnost USB disku a ak ho najde, tak si ho sama primontuje.

mjhgtuyhnb

Re:Všechny názvy souborů s velkými písmeny
« Odpověď #4 kdy: 08. 06. 2015, 15:43:51 »
dik za reakcie.

Ak som ho primontoval s paramterom -o shortname=lower, tak uz su zase malym.

Este jedna otazka. Da sa nejako nastavit Debian aby nebolo potrebne pouzit tento parameter? Prikaz na montovanie je natvrdo v aplikacii. Aplikacia si zistuje pritomnost USB disku a ak ho najde, tak si ho sama primontuje.
Mělo by stačit dát den disk (nejlépe UUID) do /etc/fstab s příslušnými parametry+noauto a pak stačí "mount /dev/sdX1" a ono to provede mount podle parametrů ve fstab.

reklama


 

reklama