reklama

Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Příspěvky - qelurg

Stran: [1] 2 3 ... 16
1
Studium a uplatnění / Re:Vývojář bez znalostí
« kdy: 30. 05. 2020, 15:00:02 »
Teorie z VŠ je k ničemu
Vyhozené peníze, měli by je všechny pozavírat. Za ušetřené peníze by se mohly koupit třeba koblihy, ti, co je žerou, už VŠ mají (života).
Kdybys nějakou kvalitní vš vystudoval, možná že bys dokázal číst s větším pochopením a byl méně demagogický.

2
/dev/null / Re:Kam schovat peníze před inflací?
« kdy: 29. 05. 2020, 20:13:25 »
Předpokládám dlouhodobější uložení. Na zlato není vhodná doba, je drahé. Jestli to chceš mít pohodlné, investuj do podílových fondů, ty teď spadly a půjdou zase nahoru. Také nemovitosti by mohly být zajímavé, ale na ně máš málo peněz.

3
Studium a uplatnění / Re:Základy programování
« kdy: 29. 05. 2020, 19:50:21 »
Začni Pythonem, s tím se dá začít jednoduše a dá se s ním dostat daleko. Je to jazyk akademické sféry, možná že ti postačí sám o sobě. Pokud budeš chtít víc prohloubit znalosti a chápání programování, pak jazyk C ti ukáže trochu jiný pohled na věc. A pak už si budeš umět vybrat sám.

4
Odkladiště / Re:Jak zdrhnout z IT?
« kdy: 21. 05. 2020, 08:45:48 »
Nezdravý životní styl a přepracován můžete být v každém oboru. Doporučuju snížit si životní standard a méně pracovat. Někteří lidé umí žít i za 25 litrů na měsíc, tak za 40 litrů na měsíc to zvládnete taky. Získaný čas věnovat svým potřebám, ať jde o kultivaci těla nebo duše. Doporučuji trávit hodně času v přírodě, zregeneruje vám mysl.

5
Tak jsem se rozhodl to považovat za bug v ubuntu balíčcích. Jako nejjednodušší řešení jsem zvolil nainstalovat nové ubuntu.

6
https://stackoverflow.com/a/58568176/6950905

Děkuji, ale doufám že existuje i jiné řešení než další distribuční systém software. Začíná být v tom linuxu bordel. Stačí že můj systém používá apt, snap a appimage, další už nechci. Když už v tom apt (a jde o oficiální kanál od ubuntu) ten python3.8 je, tak to snad musí jít i nějak rozumně používat, ne? Nějaký tajemný zásah do registrů, nebo magický přepínač nebo tak něco.

7
Na první pohled je to jednoduchý úkol, protože pro instalaci stačí příkaz:

Kód: [Vybrat]
sudo apt-get install python3.8
Jenže takto nainstalovaný python používá /usr/lib/python3/ stejně jako systémový python3.6, což nadělá paseku.

Já třeba narazil na chybu

Kód: [Vybrat]
...
  File "/home/petr/.local/lib/python3.8/site-packages/IPython/utils/process.py", line 19, in <module>
    from ._process_posix import system, getoutput, arg_split, check_pid
  File "/home/petr/.local/lib/python3.8/site-packages/IPython/utils/_process_posix.py", line 23, in <module>
    import pexpect
  File "/usr/lib/python3/dist-packages/pexpect/__init__.py", line 75, in <module>
    from .pty_spawn import spawn, spawnu
  File "/usr/lib/python3/dist-packages/pexpect/pty_spawn.py", line 14, in <module>
    from .spawnbase import SpawnBase
  File "/usr/lib/python3/dist-packages/pexpect/spawnbase.py", line 224
    def expect(self, pattern, timeout=-1, searchwindowsize=-1, async=False):
                                                               ^
SyntaxError: invalid syntax

Což je v pořádku, protože v Pythonu 3.8 je async zakázaný keyword. Blbý je, že leze do systémové knihovny pro 3.6.

Když chci nainstalovat lokální pexpect, tak opět narážím na systémový.

Kód: [Vybrat]
petr@T460s-U18:~/Dropbox/!DATA-WORK/SITES/rady$ python3.8 -m pip install pexpect
Defaulting to user installation because normal site-packages is not writeable
Requirement already satisfied: pexpect in /usr/lib/python3/dist-packages (4.2.1)

Jak python 3.8 nainstalovat, aby nelezl do systémových knihoven pro jinou verzi pythonu?

8
Software / Re:změna vzhledu hudebního přehrávače Audacious
« kdy: 15. 05. 2020, 08:03:40 »
Na VM nezáleží. Na nový vzhled si zvykneš, mně se to druhé líbí víc. Kdyby to byla GTK aplikace, šlo by to ostylovat (ale nestálo by to za to), u QT nevím, leda si nainstalovat tu starší verzi. Ještě můžeš audacious přepnout do winamp modu, ten je hezky usporny.

9
Hmm, hmm, dekuji. Budu se muset podivat, co to je Appimage. Ja znam jen apt a snap.

10
Zajímavy, cim je to hlidane, kdyz prava uzivatele/linux to vlastne neridi? Ty ostatni bych k tomu nerad poustel (mladsi deti), aby nezlikvidovali praci tem starsim. Ale jestli to nejde jinak, tak aspon ze tak. Dekuji.

11
Hardware / Externí keypad
« kdy: 03. 05. 2020, 21:10:37 »
Můj pracovní book je Lenovo T460s a s ním používám externí usb numerický keypad, funguje to bez problémů. Vytáhl jsem teď ze skříně starý IBM T43 pro syna a tam jsem zjistil zajímavý problém.

T43 má numlock a když se zapne, lze zadávat čísla pomocí kláves 7890, UIOP, JKL; a M./ Tedy z části znakové klávesnice se stane numerická. Bohužel, to samé se děje i když k němu připojím a zapnu externí numlock. Jde nějak nastavit ubuntu, aby externí numerický blok fungoval jako numerický blok a přitom znaková klávesnice dál fungovala jako znaková?

12
Mohu doplnit informaci, že editor Sublime Text nainstalovaný ze snapu s tím problém nemá, do sdíleného adresáře vidí a umožňuje v něm prohlížet a editovat soubory.

13
Distribuce / Odmítnutá přístupová práva ve snap aplikaci
« kdy: 02. 05. 2020, 21:41:39 »
Rozhodl jsem se oživit jednu vykopávku, aby se děti nehádaly o počítač. Jde o IBM T43 a až mě překvapuje, jak to všechno krásně všechno šlape. Nainstaloval jsem na to Lubuntu 18.04 a v /home vytvořil sdílený adresář /home/spolecny, který vlastní root a skupinu má users. Práva jsou nastavena drwxrwsr-x. Všechno až na pár drobností hezky fungovalo.

Jenže potřebujeme používat aplikaci musescore a ta je tam dost stará, verze 2.1. Už dávno používáme verzi 3.x, která bohužel není zpetně kompatibilní, takže většina not, které máme, v 2.1 nejdou otevřít. Nainstaloval jsem tedy snapd a nainstaloval musescore 3.4 ze snapu . A tady jsem narazil. Když chci vlézt do toho adresáře společný, nepustí mě to tam, permission denied. Přitom ta aplikace běží pod normálním uživatelem a z jiných aplikací se  tam bez problémů dostanu. Zkusil jsem ve snapu nainstalovat notepad++ a zjistil, že ani s ním se tam nedostanu. Problém je tedy nějaký se snapem, ale nechápu jaký. Neví někdo co s tím?

14
Distribuce / Re:Ubuntu vs Xubuntu: objasnění podpory
« kdy: 28. 04. 2020, 21:42:30 »
Dej si pozor, ani všechny balíčky v LTS Ubuntu nemají podporu 5 let
takže radíš všechny LTSka upgradovat po těch třech letech? já to tady nechal čtyři roky kvůli své lenosti...
Záleží na tobě, jak se říká, co ti funguje, to neopravuj. Pokud budeš cítit nedostatky, bude tě to motivovat k dřívějšímu upgrade, pokud ne, proč bys to dělal?

15
Hardware / Re:Provoz PC bez grafické karty
« kdy: 14. 04. 2020, 18:29:04 »
Jedna kW/h stojí spíš 4 Kč. Pokud tazatel používá tepelná čerpadlo, tak cca 2 Kč. Takže spotřebovat za rok megawathodinu na PC už docela leze do peněz a upgrade na něco úspornějšího se může vyplatit.
Já to vidím na tu korunu: https://www.kurzy.cz/elektrina/?gclid=EAIaIQobChMI7rfA7Kro6AIViaztCh3rdAqDEAAYAyAAEgKt0PD_BwE

Stran: [1] 2 3 ... 16

reklama