Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Témata - crown

Stran: [1] 2 3
1
Desktop / Připojení na strongSwan přes NetworkManager
« kdy: 04. 03. 2023, 23:41:59 »
Dobry vecer,

podarilo se mi zprovoznit pripojeni na strongswan server pomoci charon-cmd

Kód: [Vybrat]
sudo charon-cmd --cert /home/mila/Dokumenty/certifikaty/ca2020.pem --p12 /home/mila/Dokumenty/certifikaty/mila2020.p12 --host xxx.xxx.xxx.xxx --identity CN=mila2020
Po zadani se me to zepta na heslo k p12 souboru a po zadani se to pripoji. Funguje to jen jako admin (sudo)

Zkousel jsem to same nastavit pomoci network-manager strongswan module, ale nejsem schopen to zprovoznit. Po zapnuti vpn mi to ihned nalasi chybu, ze se pripojeni nezdarilo, protoze se nezdarilo spusteni sluzby VPN.
Nahazovat spojeni pres konzoli je pro uzivatele dost neprakticke, navic musi zadavat rucne heslo p12 souboru.

Nemate nekdo napad, co zkusit?

2
Sítě / Přesměrování portu ve firewallu MikroTik
« kdy: 06. 01. 2023, 17:19:43 »
Ahoj, mohl by mi prosim nekdo poradit, co delam spatne. Chci jen jednoduse v mikrotiku presmerovat port 445 na pocitac 10.0.0.225 ve vnitrni siti, porty 443.

Kdyz jsem to nastavil, a zkusim se zvenku prihlasit na externi ip adresu:443, tak v logu vidim odmitnuti spojeni.
Kód: [Vybrat]
drop input: in:ether1 out:(unknown 0), connection-state:new src-mac cc:2d:e0:dc:0f:6c, proto TCP (SYN), 78.80.106.4:6661->10.107.1.196:443, len 60
adresa 78.80.106.4 je muj mobil docasne pridelena ip (asi vystupni brana operatora)
proc to ale pise, ze se to snazi pristoupit na 10.107.1.196, kdyz to ma byt presmerovano na 10.0.0.225 ?

Tady je vypis konfigurace firewallu:
Kód: [Vybrat]
# model = RB750Gr3

/ip firewall address-list
add address=0.0.0.0/8 comment=RFC6890 list=not_in_internet
add address=172.16.0.0/12 comment=RFC6890 list=not_in_internet
add address=192.168.0.0/16 comment=RFC6890 list=not_in_internet
add address=169.254.0.0/16 comment=RFC6890 list=not_in_internet
add address=127.0.0.0/8 comment=RFC6890 list=not_in_internet
add address=224.0.0.0/4 comment=Multicast list=not_in_internet
add address=198.18.0.0/15 comment=RFC6890 list=not_in_internet
add address=192.0.0.0/24 comment=RFC6890 list=not_in_internet
add address=192.0.2.0/24 comment=RFC6890 list=not_in_internet
add address=198.51.100.0/24 comment=RFC6890 list=not_in_internet
add address=203.0.113.0/24 comment=RFC6890 list=not_in_internet
add address=100.64.0.0/10 comment=RFC6890 list=not_in_internet
add address=240.0.0.0/4 comment=RFC6890 list=not_in_internet
add address=192.88.99.0/24 comment="6to4 relay Anycast [RFC 3068]" list=\
    not_in_internet
add address=10.0.0.1-10.0.0.255 list=allowed_to_router
/ip firewall filter
add action=accept chain=forward dst-address=10.0.0.225 dst-port=443 \
    in-interface=ether1 out-interface=bridgeLocal protocol=tcp src-address=\
    0.0.0.0
add action=accept chain=input comment="default configuration" \
    connection-state=established,related
add action=accept chain=input src-address-list=allowed_to_router
add action=accept chain=input protocol=icmp
add action=drop chain=input log=yes log-prefix="5 drop"
add action=fasttrack-connection chain=forward comment=FastTrack \
    connection-state=established,related hw-offload=yes
add action=accept chain=forward comment="Established, Related" \
    connection-state=established,related
add action=drop chain=forward comment="Drop invalid" connection-state=invalid \
    log=yes log-prefix=invalid
add action=drop chain=forward comment=\
    "Drop incoming packets that are not NAT`ted" connection-nat-state=!dstnat \
    connection-state=new in-interface=ether1 log=yes log-prefix=!NAT
add action=accept chain=icmp comment="echo reply" icmp-options=0:0 protocol=\
    icmp
add action=accept chain=icmp comment="net unreachable" icmp-options=3:0 \
    protocol=icmp
add action=accept chain=icmp comment="host unreachable" icmp-options=3:1 \
    protocol=icmp
add action=accept chain=icmp comment=\
    "host unreachable fragmentation required" icmp-options=3:4 protocol=icmp
add action=accept chain=icmp comment="allow echo request" icmp-options=8:0 \
    protocol=icmp
add action=accept chain=icmp comment="allow time exceed" icmp-options=11:0 \
    protocol=icmp
add action=accept chain=icmp comment="allow parameter bad" icmp-options=12:0 \
    protocol=icmp
add action=drop chain=icmp comment="deny all other types"
add action=jump chain=forward comment="jump to ICMP filters" jump-target=icmp \
    protocol=icmp
add action=drop chain=forward comment=\
    "Drop incoming from internet which is not public IP" in-interface=ether1 \
    log=yes log-prefix=!public src-address-list=not_in_internet
/ip firewall nat
add action=dst-nat chain=dstnat dst-port=443 protocol=tcp src-address=0.0.0.0 \
    to-addresses=10.0.0.225 to-ports=443
add action=masquerade chain=srcnat out-interface-list=WAN

diky

3
Sítě / Nastavení WireGuardu z mobilu na OpenWRT
« kdy: 24. 10. 2022, 15:57:24 »
Snazim se nastavit Wireguard na OpenWRT routeru (turris 1.1) a klienta na Androidu.

Takhle to vypada na strane routeru, rozhrani pro wireguard vypada, ze je zalozene, firewall ma povoleny vstup na port 51820.
Kdyz na Androidu zapnu wireguard, tak aplikace zobrazi zamecek, ale spis to vypada, ze se na server vubec nepripoji. Musim tam delat neco spatne.


4
Hardware / Doporučte Zigbee relé
« kdy: 11. 10. 2022, 13:34:12 »
Na motoru od vrat v garáži zlobí ovladač a stejně už jsem to chtě dávno nahradit ovládáním přes zigbee.
Na motoru jsou tlačítka, zkusím to rozebrat a tlačítka vyvést ven.
Potřeboval bych poradit nějaké menší zigbee relé, ideálně, kdyby rovnou podporovalo zmáčknutí tlačítka (tedy spoj kontakt, počkej 0,2 sec a rozpoj kontakt.)

Díky

5
Vývoj / Jaký jazyk na malé portabilní programy
« kdy: 15. 09. 2022, 10:35:37 »
Programoval jsem v c# ve Visual Studiu. Ted uz moc kod nepisu, ale rad bych se trochu posunul a naucil se dalsi jazyk.

Use case je male programy s GUI, ktere muzou bezet na Win i na Linuxu a idealne i na Androidu. Dulezite je, aby bylo dostupne jednoduche IDE, kde jde naklikat gui a prirazovat akce tlacitkum. Take je potreba, aby se dal distribuovat jen ten program a uzivatel nemusel instalovat obrovsky runtime (jako treba python). Vyvovuje mi objektove programovani.

Ano, mohl bych pokracovat v c# a mono, ale radsi bych neco jineho.

Diky

zatim jsem koukal na nize a toto jsou moje potrehy. Samozrejme se muzu plest
python - slozite GUI, potreba mit ho nainstalovany  + vyhoda ma miliardyknihoven
go - slozite GUI, neumi objektove programovani  + vyhoda umi spousty veci v sitovani

6
Bazar / Daruji elektro haraburdí
« kdy: 12. 09. 2022, 11:37:00 »
Nasel jsem ve sklepě staré elektro haraburdí. Je to k něčemu nebo to tříděný odpad jistí?

7
Sítě / MikroTik klonování nastavení
« kdy: 02. 09. 2022, 15:16:41 »
Ahoj,

mam dva male mikrotiky mAP lite. Jeden je spravne nakonfigurovany jako pristupovy bod bez NAT atd. Muzu se na nej pripojit pres mobilni aplikaci Mikrotik. Nejsem schopen tam najit moznost vyexportovat nastaveni, abych to mohl naimportovat do druheho mikrotiku identicky. Muzu to vsechno zase naklikat rucne, ale radsi bych importoval konfiguraci.
Jde to vubec?

(Proc ne pres pocitac - mikrotik je v rezimu bridge, neni videt pres IP adresu a je ode mne pres dva switche. Winbox ho nenajde. Asi se muzu k nemu presunout s notebookem blize, ale pres mobil by bylo jednodussi.)

Diky

8
Odkladiště / Google one - sdílení místa s G suite free
« kdy: 22. 08. 2022, 18:17:55 »
Google nabízí rozšíření místa (100 BG za asi 60Kč) s tím, že lze sdílet místo se členy rodiny. Někteří členové rodiny ale používají G suite free edition. Nezkoušel jste někdo, jestli jde sdílet místo i s nimi?
Bohužel informací je málo a jedniné, jak to zjistit je vyzkoušet to.

Díky

9
Bazar / Věnuji HP LaserJet Pro M1212nf
« kdy: 06. 12. 2021, 14:28:40 »
Věnuju někomu do rodiny tiskárnu HP LaserJet Pro M1212nf, síťová černobílá laserová tiskárna. Funguje, toner už je slabý, scanner funguje dobře. Náhradní toner 285A (kompatibilní toner v obchodech od  200 Kc výše).

Osobní předání Praha 6 u OC Bořislavka. (neposílám)

10
Hardware / Jak připojit notebook s HDMI k USB-C monitoru
« kdy: 09. 07. 2021, 15:00:17 »
Chci si koupit maly prenosny USB-C monitor. (treba 15,6" AOC I1659FWUX nebo 15.6" Acer PM161Q)
K hlavnimu notebooku to fungovat bude, tan ma USB-C vystup pro displej.

Rad bych ale ten monitor obcas pouzil i u starsiho notebooku, ktery ma jen HDMI / VGA video vystup a USB-A porty.
Existuje nejaka redukce, se kterou by to slo pouzit? Monitor (aspon jeden z nich) ma moznost napajeni z adapteru, takze nemusi nutne brat napajeni z usb-c.

diky

PS: na googlu jsem nic kloudneho nenasel, proto se ptam tady

11
Zkoušel jsem se ptát na turris foru https://forum.turris.cz/t/jak-blokovat-prichozi-provoz-podle-regionu/15486, ale není to tam moc živé.

Mám modrý turris s OpenWRT a přesměrovávám si porty 80 a 443 na nextcloud (pi)  krabičku v interní síti. Rád bych router nastavil tak, aby pouštěl pouze provoz z EU. Nechci, aby mi zkouseli hadat heslo boti z Číny, Ruska a dalších zemí.
Zároveň ale chci mít možnost se z vnitřní sítě dostat na weby v těchto zemích. Filtrace podle země se tedy má týkat jen port forwardingu portu 80 a 443.

Zkoumam ted package https://github.com/openwrt/packages/blob/master/net/banip/files/README.md ale je tam problem zavislosti.
Collected errors:
 * check_data_file_clashes: Package logd wants to install file /sbin/logread
   But that file is already provided by package  * syslog-ng
 * opkg_install_cmd: Cannot install package banip.

12
Software / Druhý pevný disk označen jako removable
« kdy: 27. 05. 2021, 19:01:45 »
Mam notebook a jsou v nem dva disky. Na sdb je system a sda je sekundarni na data. Historicky nemel nastaveny mount point a zobrazoval se jako removable. Ted jsem ho pridal do fstabu

Takhle vypada fstab - je to ten posledni radek
Kód: [Vybrat]
UUID=f768ec01-ef6e-47d7-a8b4-b66cd72cc030 /               btrfs          defaults,subvol=@      0 1
UUID=3959-F245                            /boot/efi       vfat           umask=0077            0 1
UUID=f768ec01-ef6e-47d7-a8b4-b66cd72cc030 /home           btrfs          defaults,subvol=@home   0 2
/swapfile                                                 none           swap         sw              0  0
UUID=27e3442d-2d86-45bd-be4a-908f303606af /media/filip/Druhy_disk            ext4 defaults    0 2

Pri startu pocitace se pripoji fajn, ale pruzkumnik a aplet vpravo dole nabizi odpojeni tohoto disku. Nechci, aby se to tam objevovalo a aby ho nekdo omylem neodpojil. Potom by selhalo napriklad zalohovani.

Co delam spatne?

13
Software / Jak uložit zdroj pro skenování
« kdy: 21. 05. 2021, 18:14:52 »
Mam nextcloud instanci na Odroid HC2.

Na stejne siti je HP mutifunkce a chci nastavit skenovani z nextcloudu. Nainstaloval jsem sane-utils, netpbm, hplip, nastavil multifunkci pres hp-setup -i, upravil sudoers file, aby www-data mohl spoustet scanimage. Potom aplikace nextcloud-scanner.
Nakonec to celkem funguje, kdyz se dokument da do automatickeho podavace.

Potreboval bych ale nastavit, aby to skenovalo z plochy skeneru.

Skenovaci aplikace jednoduse spousti pod uzivatelem www-data
 
Kód: [Vybrat]
scanimage --mode color --resolution 300 -x 215 -y 297|pnmtojpeg > /tmp/img

Pokud to spustim rucne a pridam parametr
Kód: [Vybrat]
--source flatbed  tak to skenuje spravne z plochy.

Poradi mi nekdo prosim, v jakem konfiguranim souboru a jak to volbu --source flatbed ulozit?

14
Hardware / Dell precision M4600 vada obrazu
« kdy: 05. 05. 2021, 14:38:44 »
Dobre odpoledne,

mám Dell Precision M4600 s grafickou kartou AMD a na obrazovce se projevuji artefakty. Většinou je obraz OK, ale občas je například posunutý o čtvrt displeje doprava a na levé části je chybějící pravý kus obrazu. Někdy to vypadá jako 3D obraz, kdy jsou lichá řádky posunuté oproti sudým. Někdy se na tom projeví pulzující rušení, jako kdyby tam pronikalo rušení ze sítě.
Zkoušel jsem i externí monitor, projevuje se tam také rušení, ale není to synchronizované s displejem.
Přeinstaloval jsem ovladače, ale nepomohlo to. Bez adaptéru nemůžu zkusit, protože je mrtvá baterka. Zkoušel jsem dva různé adaptery, najdu ještě někde další.

Máte nějaký nápad?
Díky

15
Hardware / Bluetooth sluchatka se neumí znovu připojit
« kdy: 21. 03. 2021, 00:29:45 »
Mám problém s jedněmi bluetooth sluchátky. Druhá sluchátka, co mám se chovají baz problémů.

Linux Mint 20.1 mate
Sluchátka hid-generic 0005:05D6:000A.0002: input,hidraw0: BLUETOOTH HID v2.40 Device [SBKP 4 A1] on 28:b2:bd:8a:41:2e
Verze bluez je Version: 5.53-0ubuntu3

Pokud sluchátka nově spáruju s počítačem, tak fungují v pořádku
Když je následně vypnu a za chvíli zapnu, tak dole ikona píše connected to SBKP 4 A1, ale audio do sluchátek nejde. V pavucontrol bluetooth nevidím. Mačkání tlačítka play/pause na sluchátkách nepomůže.
Po asi minutě se sluchátka samy odpojí.
Když v buetooth kliknu na zařízení + na connection, tak se opět připojí a většinou to už jde. Stejně tak, když v době, kdy jsou ještě připojená kliknu na connection (odpojím) a opět connection (připojím), tak zvuk jde.

Jak udělám, aby se po zapnutí sluchátek samy připojily (stejně jako se mi tak chovají druhá sluchátka)? Kde najdu bluetooth log, abych viděl, co se tam děje?

Díky za nasměrování

Stran: [1] 2 3