Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Příspěvky - xmms

Stran: [1] 2 3 ... 10
1
Mám letsencrypt pro apache v centos 8 pro certifikát webu. Chci využívat ten stejný certifikát také pro proftpd ftps a možná i jiné programy. Funguje to dobře, jen nevím, jak zajistit, aby se udělal reload proftpd v případě automatické obnovy certifikátu pro apache. Napadá mě hodit do crontabu každou hodinu systemctl reload proftpd, ale já to chci udělat jen při vygenerování nového certifikátu automaticky certbotem. Nevím, jak uvnitř funguje certbot, je to nějaká binárka. Na starém centosu to byl skript #!/bin/sh, ale to už je dávno minulostí.

which certbot
/usr/bin/certbot

file /usr/bin/certbot
/usr/bin/certbot: symbolic link to /snap/bin/certbot

file /snap/bin/certbot
/snap/bin/certbot: symbolic link to /usr/bin/snap

file /usr/bin/snap
/usr/bin/snap: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2

2
Tak už jsem pochopil, jak nastavit php-fpm pooly pro víc uživatelů a každý má na svém sajtu ten svůj. A funguje, každý si pouští php po svým userem. To zatím stačí, takhle jsem to potřeboval.

Zatím díky za posun správným směrem.

3
Já jsem doufal, že to půjde nějak jednoduše nastavit direktivou SuexecUserGroup user1 user1 pro každý virtualhost. Čekal jsem, že v dnešní době bude mít nejnovější apache už takové věci dávno v sobě.

Děkuji všem za snahu, ale do proxy a různých instancí apache na různých portech se pouštět nechci.
A jak tohle v praxi řeší webhostinogové firmy, které mají tisíce zákazníků? Těma fpm poolama nebo nějak jinak?

4
Open-basedir mi udělá jen stránku typu mujsite.com/~user. shell_exec('whoami') v php vrací www-data (mám ubuntu 18). Funguje nastavení APACHE_RUN_USER v /etc/apache2/envvars, ale to je globální.
Zkouším nějaké návody na SuexecUserGroup a fast cgi a nedaří se mi to udělat. Znáte někdo příklad funkčního nastavení pro nějaký VirtualHost? Chci mít pro každý virtualhost jiného usera, pod kterým pojede jeho php skript.

5
Server / Jak nastavit práva /var/www/html pro víc uživatelů
« kdy: 01. 04. 2021, 23:04:10 »
Potřebuju mít několik sajtů, pro každého uživatele zvlášť v /var/www/html/username nebo v /home/username

Jak se u toho v praxi nastavují práva, aby do toho mohlo apache a každý uživatel (přes ftp nebo ssh) jen do svého adresáře? Jde o to, že kdokoliv si může vyrobit php skript, kterým se dostane i do adresářů jiných uživatelů (protože běží pod uživatelem apache) a to nechci. PHP skript webu jednoho uživatele se nesmí dostat k souborům jiných uživatelů.

6
Distribuce / Re:Proč se to ISO jmenuje i386
« kdy: 29. 01. 2017, 22:07:50 »
Já radši tenis. Bohužel nemám tu 386ku, abych na tom tu novou Fedoru otestoval. Musím někde sehnat repasovanou. Pokud by to náhodou nešlo, bude to reklamační závada...

7
Distribuce / Proč se to ISO jmenuje i386
« kdy: 29. 01. 2017, 20:48:53 »
U nejnovějších dsitribucí jsou kromě x86_64 stále k dispozici ISO s označením i386. Znamená to, že je kompatibilní se starou 386kou a půjde to tam skutečně spustit? Už jenom samotné jádro žere víc ramky, než kolik se na 386 tehdy pouštělo... Má to pořád kompatibilní instrukční sadu?

8
Desktop / Re:Nefunguje rozšíření GNOME
« kdy: 30. 11. 2016, 18:13:39 »
Vsechny uvedene gnome-shell balicky jsou nainstalovane. Na adrese https://extensions.gnome.org/local/ jsou videt moje doplnky, ale pri pokusu ho zapnout/vypnout spadne plugin.
https://postimg.org/image/qd0girob1/

Delal jsem yum upgrade a vsechno je aktualni.

9
Desktop / Re:Nefunguje rozšíření GNOME
« kdy: 29. 11. 2016, 20:14:45 »
Díky :-) To mě po těch letech ve windows nenapadlo... Už mám obrázek tady, rozšíření na nic nereaguje, nejde zapnout, odstranit.
https://postimg.org/image/xkabs61c5

10
Distribuce / Re:Přesun systému z jednoho RAIDu do druhého
« kdy: 29. 11. 2016, 19:38:12 »
Chodí to.

Jak to myslíte s tím grubem UUID? Co přesně kde nastavit? Někdy se mi stalo (ne vždy), že po výměně disku (typ mbr) v raidu a instalaci grubu do /dev/sdX a následném pokusu o boot z tohoto disku nenabootoval, ale po druhé instalaci grubu to už fungovalo.

Dělal jsem třeba u disku sdb
grub
root (hd1,0)
setup (hd1)

To bylo na stejném raidu přes fail, remove a potom nový add

11
Desktop / Nefunguje rozšíření GNOME
« kdy: 29. 11. 2016, 19:31:24 »
Mám Centos 7, Gnome, gnome-tweak-tool a na kartě rozšíření je prvních 5 rozšíření, které mají vyšedlý slider a nejdou zapnout, asi se má něco doinstalovat, ale co?
Chtěl jsem udělat screenshot, ale po provedení printscreen to sice udělá efekt foťáku, ale nezkopíruje se to do schránky a nejde vložit do kolourpaintu, poradí někdo?

12
A kam jinam? Na md0 je filesystem.

Uz jsem to nasel, v souboru /boot/grub/menu.lst se musi editovat parametr rd_MD_UUID na nove cislo raidu zjistene pres mdadm -D /dev/md1
A pak to zacne fungovat, tohle jedine tomu chybelo. Zkousel jsem i takto naklonovat ze systemu bez raidu sda1 > md1 a taky funguje, jen se musi nastavit ten rd_MD_UUID v menu.lst Naopak root=UUID zustava stejne, ale ten stary disk se musi odebrat, s tim take pocitam.

No a pokud nechci mit automaticky precislovane md127 po restartu, tak udelat
Kód: [Vybrat]
mdadm --detail --scan > /etc/mdadm.conf
dracut initramfs.img `uname -r`

Takze na tom klonovani md neni nic spatneho, jen se musi upravit menu.lst

Tohle je, co jsem hledal.

13
To vim taky, ze sda1 je prvni oddil disku sda. Na ten oddil se uklada ten raid. Preinstalovat to nechci. Cilem je pochopit, jak se ten raid chova, teprve se to ucim.

14
To se snazim pochopit jak to funguje. Mel jsem za to, ze "binarni obsah" SW raidu je sda1, nikoliv md0. A md0 by mel obsahovat jenom filesystem samotny.

Kdyz naklonuju sda1, tak se tim zkopiruje ten puvodni raid, ktery jsem kopirovat nechtel.

Mozna jsem se spatne vyjadril, mym cilem je zkopirovat filesystem na novy raid md1.

15
Varianta popsana czipis funguje, ale me zajima, proc to nejde takhle. Budu mit situaci, ze mam image tech logickych disku a chci je spustit v novem raidu.
Udelal jsem nejake dalsi pokusy s klonovanim na stejne velke disky a stejne velke partition pres sfdisk -d, ale vysledek je stejny, nefunguje to. Delam to offline z live cd.

Funguje ale, kdyz klonuju na jiny disk bez raidu takto dd if=/dev/md0 of=/dev/sde1
Potom nainstalovat grub a nasledne po odebrani puvodnich disku se to da nabootovat a funguje to. Tohle funguje i na klonovani spusteneho systemu (ono tam toho moc nebezi).

No takze zpusob klonovani bude asi OK, velikost disku a partition taky, ale neco tomu vadi u toho noveho raidu, ale nevim co. Metadata 1.0 je stejne jako na puvodnich discich a dale uz me nic nenapada.

Stran: [1] 2 3 ... 10