Zobrazit příspěvky

Tato sekce Vám umožňuje zobrazit všechny příspěvky tohoto uživatele. Prosím uvědomte si, že můžete vidět příspěvky pouze z oblastí Vám přístupných.


Příspěvky - madmucho

Stran: [1] 2 3 4
1
Server / Re:Dlouhé načtení Nextcloudu
« kdy: 05. 04. 2023, 09:39:54 »
Zdravím,
podle chování bych si typnul že se buď vůbec nepoužívá FPM a nebo je v modu on demand kdy neběží worker dokud se po něm nic nechce, a jak se po něm nic nechce x sec tak se worker vypne. Pokud je FPM tak bych ho nastavil na dynamic.
A určitě mít zapnutou nějakou keš, memcache asi nejjednodužší, a respektovat doporučení na opcache v php.ini

v php.ini pro opcache
Kód: [Vybrat]
opcache.enable=1
opcache.enable_cli=1
opcache.memory_consumption=140
opcache.interned_strings_buffer=25
opcache.max_accelerated_files=10000
opcache.fast_shutdown=1
opcache.revalidate_freq=1

memcace na lokalu bežící nastavená v config.php

Kód: [Vybrat]
'memcache.local' => '\\OC\\Memcache\\Memcached',
  'memcache.distributed' => '\\OC\\Memcache\\Memcached',
  'memcached_servers' =>.
  array (
    0 =>.
    array (
      0 => '127.0.0.1',
      1 => 11211,
    ),
  ),

2
Sítě / Re:HW hotové řešení IDS/IPS, security onion
« kdy: 08. 03. 2023, 08:18:14 »
Tak to pak bych doporučil k tomu siem ossim https://cybersecurity.att.com/products/ossim
a par sond na čmuchání kde bude potřeba.
Případně jeho placenou variantu.

3
Vývoj / Re:PHP a SOAP
« kdy: 03. 03. 2023, 10:11:02 »
Co tenhle ?
https://github.com/debuss/MTOMSoapClient
Ale i tak to asi bude dost prasarna, poskládat si to pak z base64 zpět to bude trvat.

4
Server / Re:Náhrada SMS brány Vodafone
« kdy: 09. 02. 2023, 22:05:27 »
Raspberry pi, usb gsm modem takovej ten obič, hujavej třeba mi v tom běží roky.
http://smstools3.kekekasvi.com/ pro obsluhu modemu.
a pro api na webu přes https://playsms.org/ Čtu přes to i doručenky jestli zprávy opravdu dorazily.

Jednou za čas promáznout historii aby se s toho raspberry nezblaznilo a takhle to běží už roky na první generaci raspberry.
Ročně kolem 15 tisíc sms.
Asi se to nedá srovnávat s nějakou ACME krabičkou ale dělá to co má ale kdyby někdo chtěl směr tak tudy to jde.
Dík  :-) Klasický OS?
Ano, nebylo třeba nic extra, jen přemluvit modem aby se po startu přepnul z usb flešky do modem modu, to je ale u každého modemu jinak. A dá se to vygoolilt.

5
Server / Re:Náhrada SMS brány Vodafone
« kdy: 09. 02. 2023, 14:47:07 »
Raspberry pi, usb gsm modem takovej ten obič, hujavej třeba mi v tom běží roky.
http://smstools3.kekekasvi.com/ pro obsluhu modemu.
a pro api na webu přes https://playsms.org/ Čtu přes to i doručenky jestli zprávy opravdu dorazily.

Jednou za čas promáznout historii aby se s toho raspberry nezblaznilo a takhle to běží už roky na první generaci raspberry.
Ročně kolem 15 tisíc sms.
Asi se to nedá srovnávat s nějakou ACME krabičkou ale dělá to co má ale kdyby někdo chtěl směr tak tudy to jde.

6
Server / Re:Dvě verze PHP v rámci jednoho serveru
« kdy: 31. 01. 2023, 20:16:03 »
Zdravím,
pokud je potřeba provozovat na jednom http serveru více php verzí nevidím v tom problém běžně se to řeší přes FPM nebo FCGI a http dns vhost.

Neřešil bych vůbec co Vám dává distribuce za php runtime, pro chod webu můžete mít více php instancí a každá sajta je obsluhována jiným runtimem na stejném portu 80 nebo 443 a ani jedna nemusí využívat php z distribučních mirrorů.
Běžně se to tak dělá.
Pokud se Vám s tím nechce patlat na howtoforge máte navody na ispconfig a podle toho to zvládnete.

7
Sítě / Re:Zálohování switchů, routerů
« kdy: 30. 01. 2023, 08:35:25 »
Na zálohy konfigurací a diff používáme unimus.
Je to placené od 5ti zařízení a více. Ale funguje jak má.

8
Distribuce / Re:Automatické aktualizace PHP v Debianu
« kdy: 17. 01. 2023, 12:25:00 »
Dobrý den,
pro výběr phpka které ma systém použivat jsou příkazy kterými vyberete verzi a ta pak zůstává.

Kód: [Vybrat]
update-alternatives --config php
update-alternatives --config php-cgi
update-alternatives --config php-fpm.sock

Běžně takové instlaace pro korporáty dělám v ispconfigu protože jsou tam i archeologické vykopávky na php 5.6 tak v ispconfigu každá sajta muže mít jiné php klidně i subverzi a běží na jednom serveru pro to určeném.

https://www.howtoforge.com/ispconfig-php-ubuntu/

9
Distribuce / Re:Debian-testing pro webserver?
« kdy: 24. 07. 2022, 22:13:27 »
Zdravím, pokud jde o php použijte repozitáře od Ondřeje . Viz https://deb.sury.org/ můžete si vybrat které php chcete, repozitář je aktivně udržován.

Nemusíte jet testing. Buďte na stable.

10
Sítě / Re:QoS na 250M DSL lince
« kdy: 20. 12. 2021, 20:04:00 »
Chtěl bych dosáhnou minimální latence kvůli hraní online her a celkově mít možnost různým klientům přiřadit různou šířku pásma. Ping bez zatížení je 9-10ms, ale při zátěži stoupá a pro hraní to není ideální. Teď testuji Mikrotika RB750G3, který je za terminátorem od Cetinu. Stadia jede na portech 44700-44899, tak se je snažím prioritizovat a snížil jsem maximální rychlost, abych dosáhl nižší latence. Teď to mám takto a zdá se, že je to funkční. Rychlost internetu se v tomto připadě snížila jen nepatrně cca na 220M. QoS na celé síti moc tímto Mikrotikem řídit nelze, protože pak rychlost padne někam ke 140M, i když k internetu přistupuje jen jeden klient.

/ip firewall mangle
add action=mark-packet chain=prerouting dst-port="" new-packet-mark=stadia \
    passthrough=no port=44700-44899 protocol=udp
add action=mark-packet chain=prerouting new-packet-mark=stadia1 passthrough=\
    no port=44700-44899 protocol=tcp
/queue simple
add max-limit=20M/80M name="stadia googleTV" packet-marks=stadia,stadia1 \
    queue="QOS fq codel/QOS fq codel" target=bridge

Myslím že to máte v principu správně, jen máte tu frontu na bridge ale měla by být na odchozí interface timhle si zpomalujete provoz v LAN, problém ale je že DSL nemáte symetrické. Download upload..
Vyřešíte tím jen provoz který jde od Vás ven, ale u asymetrické linky se snižuje download když někdo cokoli odesílá což muže způsobit, že i tak vylítnou latence když bude stadia v prioritě.

Pokud jde o nesymetrickou linku tak myslím že nic lepšího nevymyslíte.
Já to řeším přes DSCP v rámci sitě a měnim DSCP u paketů odchozích a doufám že něco dál tento mechanizmus respektuje. Mohu ale jen doufat. Každopádně to funguje určitě lepe než když tam nic takového nebylo.

11
Sítě / Re:QoS na 250M DSL lince
« kdy: 20. 12. 2021, 18:30:10 »
Dobrý den,
myslím si že to co hledáte je qos např přes DSCP, mam podobné potřeby řešeny přes Mikrotik jako bránu která vytáčí ppoe O2 VDSL a s GforceNow (cloud gaming) stramem.
Aplikace generuje ve streamu packety s DSCP číslem, na Mikrotik má tento provoz přednost před ostatním.

Nevím jak Stádia, muselo by se okoukat ve wiresharku jestli pakety značkuje, pak by to takhle šlo.
Ale nenapsal jste co máte na bráně takže těžko radit.

12
Sítě / Re:Výběr SIEM - jak sledujete, co se děje v síti?
« kdy: 01. 11. 2021, 08:27:06 »
Zdravím,
jako siem používáme ossim (agenty, netflow z centrálních síťových prvků, suricata na dedikované síťovce, testy zranitelností pravidelně).
Jako central log, graylog, na graylogu spousty sledovaní všeho co bylo potřeba, posila se mailem tomu kdo to chtěl (graylog 3 servery celkem db replikovaná).

Na perimetru Sophos pere provoz.

Stejně si ale myslím že pokud by něco přišlo přijde to odjinud, přes lidi.
Takže s průserem se u Nás počítá.

13
Server / Re:Vadný NAS Synology
« kdy: 25. 10. 2021, 09:45:29 »
Ano, s přihlédnutím k tomu, že ty zdroje vydrží cca 4 roky a k tomu, že už to nějakou dob žije, taky to chce zohlednit životnost disků.

Prostě očakávám, že to za čtyři, čtyři a půl roku bude potřebovat další - větší - údržbu.  Ta už možná nebude dávat valný smysl. OS podporovaný asi bude.

OT: To jako vážně ty Synology zdroje (a u modelu za bratru 15k) vydrží jen 4 roky? Občas se mě někdo ptá jaký domácí NAS pořídit (pro BFU) - Tak doporučuju Synology,  klidně novější model (DSx16 a novější) z druhé ruky (ale nové disky). Vzhledem k dobré podpoře výrobce jsou moje očekávání dalšího provozu 5-10 let. Doteď jsem se toho nebál.

Pokud zdroj (a kondíky na desce) Synology vydrží jen 4 roky, co má cenu domu kupovat, aby to vydrželo aspoň 5-10 let s podporou výrobce? A teda nestálo to raketu - jako pro normálního uživatele je krabice na zálohy fotek, domácího videa a starých školních a pracovních dokumentů za 7000,- drahá (páč je za to je nový počítač).
Prostě to obyčejný lidi berou jenom jako stále připojený externí hdd, sdílený v rodině. Tak aby to bylo trochu svižný, moc to nežralo, pro bfu co občas aktualizuje bezpečný a jiný pitchoviny od toho víceméně nepotřebujou.

Ne vydrží klidně i déle, máme jich desítky a měníme je opravu jen když nám to zakazník chce zaplatit nebo pokud zařízení už nestačí.
Disky neřeším to odejde klidně i nový.  Pokud odejde naska uplně, třeba bleskem a přezijou disky tak přendat disky do jiného syno boxu a jede se dál. Přijde mi že je tohle řešení to lepší na trhu, čekat podporu 10 let je ale utopie, ono to chodí ale neběhá, mam takhle starý qnap funguje, ale je to už utrpení očividně nestihá ani UIčko.

14
Server / Re:Vadný NAS Synology
« kdy: 24. 10. 2021, 15:00:31 »
Proč jen 4 roky a pak půjde do popelnice? Já věci kupuju s tím, že vydrží minimálně 10-15let fungovat (kromě spotřebky jako je HDD nebo mírné údržby jako tady ta výměna kondenzátorů atd)
Patrně tim bylo myšleno dokud bude zařízení podporováno výrobcem, davají na ně mezinárodní zaruku, už jsem to 4 rok využil u prodejce zaruka nebyla, u synology ano. Box mi vyměnily byla vadná pamět kernel panic.

Více info https://www.synology.com/cs-cz/products/status

15
Sítě / Re:Česká firma implementující PacketFence
« kdy: 24. 10. 2021, 14:57:18 »
Zdravím,
v práci mám s Packetfence pilotní provoz, osvědčil se, ale ne vše co si představuji funguje úplně, je třeba doladit pár věci v naší šabloně pro mikrotik switch a zatím to není v komunitě ani v procesu a u mě není moc čas, zatím ale spokojenost. Polepšili jsme si tím.

#Co mi funguje
802 1x ověřovaní na mikrotik switchy (Dot1X) klient Windows suplicant, ověřování počítač nebo user z AD. Dle nastavení nodu z packetfence dostane úspěšnou vlan neúspěšnou vlan nebo karanténní vlan kde se muže lognout přes web, skenuje klienta v pozadí jestli je vše z jeho pohledu běžné a pošle mi pěkně info pokud by se mu něco nezdálo klienta neověří dostanu info.

# Co nefunguje ještě stopro.
máme více switch vendorů (HPE,Mikrotik) takže to bude ještě trocha laborování aby šly i ostatní věci na stopro, postupně segmenty síte zapojujeme do ověřování.
U mikrotiku mi nejde odpojování klientů na portu (reevaluate access), zkoušel jsem radiusem i přes snmp ale radius posilá patrně špatný příkaz na schození mac/portu, takže data přijdou ale nic to neudělá na swtichy, odpojení tedy je po reautentifikaci klienta do rekonektu portu jede jak předtím, mělo by ho to samo vyhodit v ideálu.

Bohužel druhou část otázky kdo to dělá s podporou to netuším.

Stran: [1] 2 3 4